Plantronics + Polycom. Now together as Poly Logo

CX300, dialtone playing over voicemail?

Nullifier
Occasional Contributor

CX300, dialtone playing over voicemail?

I have a weird issue with all of my users using CX300 phones on Lync 2010:

 

  • A user plays a voice mail message from the dialpad tab in Lync
  1. Sound starts to play from the CX300 speaker, as expected. Busy office, nobody else wants to hear your voicemail, so:
  2. User picks up handle, sound stops from the speaker, and message continues in handle, but display shows :Enter a number to dial, and a dialtone plays in handle indefinitely, not stopping after a few seconds like it does for some other people having this problem. I don't personally find any length of dialtone acceptable in this situation, both the phone and lync know the handle is off the hook and audio is playing... WHY play a dialtone?
  3. If user replaces handle while the message is still playing, sound is returned to the speaker (?) it only does this for one of our users. If the handle is picked up again, the message ceases to be played on the speaker and does not begin playing on the handle. Playback is indicated as stopped in Lync, which is the action one expects the FIRST time the handle is returned to the hook. A dialtone is played indefinitely when the handle is picked up the second time.

If I can't fix the problem, we'll probably end up changing phones entirely. I don't want to do that. I don't want to turn off the dialtone either, this is a 60 person system and some of the users are aging; they would not understand that dead air means you can dial.

 

Found someone else with the same issue, described here:
http://social.technet.microsoft.com/Forums/en-US/ocsclients/thread/f873f3a1-0a1f-4e42-99a0-f95fecfb3...

 

I'll ticket this with MS too as I know they are directly responsible for the software/firmware the phone is running. I just thought maybe someone might have a quick answer here, or might have the same problem.

Message 1 of 2
1 REPLY 1
Graham Cropley
Occasional Visitor

Re: CX300, dialtone playing over voicemail?

I know this is an old post, but I thought I'd reply anyway - I came across this recently on a deployment, and I found a workable solution.

 

On the Lync server you can configure the Client Policy to reduce the length of time the dialtone is played for..

 

Set-CsClientPolicy <Policy or Global> -PlayAbbreviatedDialTone <$True | $False>

 

TechNet says - "When set to True, a 3-second dial tone will be played any time a Lync-compatible handset is taken off the hook. (A Lync-compatible handset looks like a standard telephone, but plugs into a USB port on your computer and is used to make Lync calls rather than "regular" phone calls.) When set to False, a 30-second dial tone is played any time a Lync-compatible handset is taken off the hook."

 

Setting that to $True means that the dialtone is played for a much shorter time, this is then short enough to pick up the receiver, and then press play on the voicemail as the dialtone fades out, so it doesn't overlap.

 

It doesn't fix the issue, but makes it much more 'user friendly'... Hope this helps. :)

Message 2 of 2