Plantronics + Polycom. Now together as Poly Logo

CX5500 provisioning issues

Highlighted
Polycom Employee & Community Manager

Re: CX5500 provisioning issues

Hello Enrico,

have you got the FTP logs in addition or can you attach the logs to this post ?

 

You may have to ZIP them.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 21 of 33
Highlighted
Advisor

Re: CX5500 provisioning issues

I've written the FTP logs (2 lines) in the last post.

Message 22 of 33
Highlighted
Polycom Employee & Community Manager

Re: CX5500 provisioning issues

Hello Enrico,

I would need a few more details and the logs but cannot action this via the community.

 

Can you open a support ticket via your Polycom reseller or alternatively provide me with your MAC address so I can look up who you need to work with?

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 23 of 33
Highlighted
Advisor

Re: CX5500 provisioning issues

Support ticket is opened with number 1-1701580061

Message 24 of 33
Highlighted
Advisor

Re: CX5500 provisioning issues

I am happy to say I finally got the remote update of the CX5500 to work.  I looked at the logs on the phone when it tried to update and it mentioned a file it was trying to access but was unsuccessful.  I checked IIS logs on the server and didn't see the attempt being made so that puzzled me.  I thought just for the heck of it, I would try something with the folder structure and the remote update worked!  I upgraded and downgraded many versions and it worked every time.  Here is the solution that worked for me.  The remote server is IIS v6 on Windows 2008, but I imagine it would work on other IIS versions.  Using http access, I didn't try https:

 

I unpacked the TAR file for the CX5500 and the folder structure contained Millennium with subfolders platform and pool.  From there I put the folder structure as below

All under root of IIS\

\Millennium\pool

\Millennium\platform

\Polycom\Millennium\pool

\Polycom\Millennium\platform

 

That was it.  The trick that worked for me is to copy the exact folder structure under the Polycom folder  and also have the root Milliennium folder structure too. 

On the Cx5000 I set the update server to http://server and the update took off.

 

Hope this can help other people that may have this problem.

 

Highlighted
Polycom Employee & Community Manager

Re: CX5500 provisioning issues

Hello RonR,

thanks for the feedback on this but this is already stated in detail on page 46 in the Admin Guide => here <=

 

To download the Polycom UC Software for the CX5500 system:

 

  1. On the CX5500 Support page, click the latest version of software available.
  2. Click Save to download the software package
  3. Open and extract (uncompress) the .tar file
  4. Copy all files from the distribution .tar file to the home directory on the provisioning server, maintaining the same folder hierarchy. To simplify provisioning, Polycom recommends editing copies of each file as a best practice to ensure that you have unedited template files containing the default values.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 26 of 33
Highlighted
Advisor

Re: CX5500 provisioning issues

Steffen, I read this area back when I posted my original problem.  I did keep the original folder structure, but didn't have it in two locations as I mentioned.  Not sure why it was needed, but I wanted to share my findings in the case someone else is in the same situation.  Just as a test, I removed one of the folders (polycom, then put back and then removed millennium) and the update failed.  That confirmed to me both folders with the same folder structure was required for my environment.

 

Message 27 of 33
Highlighted
Visitor

Re: CX5500 provisioning issues

Hi RonR - I am working on the same issue here and am having the same difficulties getting the remote firmware upgrades to work. With your post did you just upload the files directly to IIS and not call the FTP server in the custom.server.url in the config file? Or did you do both? I am basically just looking for a more thorough description of what was done to get this working since I am running into the same walls as everyone else seems to have done.
Message 28 of 33
Highlighted
Advisor

Re: CX5500 provisioning issues

Hi, here are more specific steps:

1) I created a new website in IIS called Updates. 

2) I created the folder structure mentioned in my previous post

3) In the IIS config I added the mime types: .bat, .plcm, and .sig  (these are file extensions in the update)

4) in the IIS config, I enabled Anonymous Authentication

5) using the web interface on the CX, went to the Software Update/Custom Server and entered http://server.fqdn.com/updates

6) I hit Update Now and the phone update took off. :)

Message 29 of 33
Highlighted
Visitor

Re: CX5500 provisioning issues

Thanks so much for the info.  I ended up doing things a little bit differently using the actual config files.  Like previous posters, I added the customer server url and polling periods into the config files, but they did not update on the phone.  Previously, one of the Polycom posters responded that this was a known issue and all you had to do was do the "Update Configuration" and everything would take off from there.  Unfortunately, this did not happen.  Even after updating the configuration, the config parameters on the phone did not change.  As soon as I updated on the web server and hit update now, everything worked just fine - the phone updated and is working just fine.  This tells me that the custom.server.url parameter value that I used is valid and that it can be accessed by the phone and it is reading the \millenium file in the root folder.  My main problem is - how do i get it to take the parameters in the config file so that I do not have to remote into all of these devices. We have about 70 globally, so that is not sustainable.

 

Spec information in case it is needed: CX5500 initially running 1.1.2 and upgrading to 1.1.5, using Filezilla FTP server that we use to provision our VVX and Spectralink phones.

Message 30 of 33