Plantronics + Polycom. Now together as Poly Logo

Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

Valued Contributor

Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

I am running 3CX on a Windows 7 Professional OS.  I started with two model 331 phones, which were running SIP and BootROM ver. After getting the system up and running, I upgraded both phones to  I had set the phones up using the web interface, and upgraded them the same way. I then bought another 331 and several 550s.

The first thing I noticed was that the phones I bought second came with BootROM and SIP  While I was able to set up the new 331 and one of the 550s using the web interface, I found no provision for web upgrading in that firmware version.  It appeared that I needed to upgrade using a provisioning server.

I read the FAqs and decided to do this using the procedure outlined in the white paper "How to Provision a Polycom Phone".  That is, I installed an FTP server (FileZilla) ver. 0.9.41.  I created a folder called FTP in the root directory of the computer, and created a user name and password for the 550 and the three 331s in Filezilla, and made them both part of a group called "Polycom Phones".

I then downloaded the latest split files for the 550, labeled "Polycom ® UC Software 4.0.3 RevF for SoundPoint IP, SoundStation IP and Polycom VVX Series [Split]", unzipped them, and put them in the FTP folder.  I installed XML Notepad 2007 and opened the basic sip and reg files for the 550 as well as the file 0000..00.cfg.  I edited them appropriately, saving them directly in the FTP folder (i.e., not in the subfolder Config which contained the above mentioned files).  When saving the sip and reg files, I named them with names appropriate to the extention number of the target phone.  I then edited the 0000..00.cfg file, entering the file names I just created in the entry "CONFIG_FILES" separated by a comma, as instructed.  I then saved the modified 0000..00.cfg file in the same FTP folder renamed <MAC address of target phone>.cfg.

Then, in accordance with the instructions in the paper "Polycom UC Software 4.0.x Upgrade and Downgrade Methods", I downloaded the file SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig from the site, unzipped it, and put the file named 2345-12500-001.bootrom.ld in the root of the FTP folder.  I also moved 2345-12500-001.sip.ld from the 4.0.3 RevF folder  to the FTP root directory.

I then went to the phone.  While there was no "Provisioning Server" option, but rather an option just named "Server ...", I found selecting this led me to a "Server Menu" which appeared to be the same as in the white paper.  I changed the Server Type to

FTP, put in the IP address of my server computer, and the user name and password I had established when setting up the account in FileZilla, and disabled ZTP.   I set up the phone with a static IP (DHCP disabled) and entered the subnet mask and gateway, and my ISP's DNS server's IPs.  I set up the DHCP menu with a Static Boot Server setting.

I then backed out and selected "Save Config".  The phone rebooted.  After an initial delay, it gave a countdown to autoboot, which I allowed to expire.  It then gave a welcome message, and reported that it was Updating the initial configuration, and after several minutes, the message "Could not contact bootserver, using existing configuration" appeared.

I searched the forums for this message, and got quite a few hits.  Reading through them, it appears that most were by users that were using Option 66 with their DHCP server to point to the server, rather than modifying the phone settings as indicated in the white paper.  Several of these post had responses indicating that one should read the Administrator's Guide for

the software version of the phone, a very sensible suggestion.  So I downloaded this, and it would appear to have the same instructions as the white paper, with a few additional details. 

I entered the default values in areas where I was unsure of the correct setting.

I have tried numerous combinations, including allowing the DHCP server (my router) to serve an IP address to the phone, and enabling ZTP.

But, no matter what I seem to do, I always get the message "Could not contact bootserver, using existing configuration".

Can anyone suggest what I should do next?

Message 1 of 5
Polycom Employee & Community Manager

Re: Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

Hello richs,


the faq holds its own post for this message:


Oct 7, 2011 Question: I get the error Message “Could not contact boot server” on my phones screen
Resolution: Please check => here <=


Above simply means that the phone cannot connect to the FTP server running probably behind a firewall on your Windows 7 machine.


Try from another PC to connect to this PC.


I seriosely doubt that a home soho router has the capability to set DHCP options so you are most likely out of luck there.

Best Regards

Steffen Baier

Polycom Global Services

<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 5
Valued Contributor

Re: Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

Thank you for your help.  I tried to research the FAQs before bothering others with a post, and naturally came across the one you referenced.  As it uses the DCHP option method, and (as you point out) my router cannot handle this, it did not work for me.


I stupidly forgot to open the firewall to the FTP server, and quickly proceeded to do so after reading your reply.  Unhappily, it made no difference; the phone gave me the same message.  So it appears that there is something else that is preventing me from using the method outlined in Engineering Advisory 64731.


I'll have to sleep on it to see if I can come up with something else to try.


Aloha from Maui



Message 3 of 5
Valued Contributor

Re: Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

Hello again,


I thought about it a bit and decided to just turn off Windows Firewall altogether for the time required to access the files. 


This worked.  The 550 is now updated to the latest software, and I've turned the Firewall back on.  When I get a chance I will find out exactly how to set it up so that I still have some firewall functionality but the phones can communicate with the server.


Thanks again for your help.

Message 4 of 5
Occasional Advisor

Re: Can't seem to upgrade IP550 from 3.3.3 to 4.0.3

Windows Firewall and Microsoft FTP servers are both notorious for problems.  Avoid them especially when testing or trying to setup for the first time.

Message 5 of 5