Plantronics + Polycom. Now together as Poly Logo

Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

SOLVED
Highlighted
Occasional Advisor

Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

FYI, I just updated UCS firmware from 5.8.2 to 5.9.0 and noticed that I am not able to set EHS mode to Plantronics.  Comparing UCS Admin Guide, 5.8.1 and 5.9.0, I noticed the default up.analogHeadsetOption value is changed from No EHS-compatible headset is attached to Plantronics EHS-compatible headset is attached.

 

With 5.8.1, reboot is not required, but 5.9.0 is.  Interesting thing is the phone with UCS 5.9.0 default is "No EHS-compatible hedset is attached" setting, not Plantronics EHS, and if I select Plantronics, the phone reboots, but it set back to "No EHS ~" setting after reboot.


Just curious whether this is known issue or not. 

At this moment, I rolled back UCS firmware to 5.8.2.4732 and the headset setting works flawlessly.

 

- UCS Admin Guide: 5.8.1

https://documents.polycom.com/bundle/ucs-ag-5-8-1/page/r-ucs-ag-headset-and-speakerphone-parameters....

 

- UCS Admin Guide: 5.9.0

https://documents.polycom.com/bundle/ucs-ag-5-9-0/page/r-ucs-ag-headset-and-speakerphone-parameters....

15 REPLIES 15
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hi Domosute

 

I don't see this issue here but curious of a few things:

 

Was the phone fully configured with desired configuration before the upgrade to 5.9.0? Or was the upgrade done and then the configuration was applied (and caused the failure)? If the phone is on 5.9.0 and reset to default, then all the same config applied, does the issue still happen?

 

Thanks for your time.

Message 2 of 16
Occasional Advisor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hi Chad_A,


Thanks for your reply.  I noticed the setting properly remained once I factory resetted the phone manually.  I confirmed Plantronics EHS setting was the default setting and select it explicitly with  up.analogHeadsetOption="2" in my provisioning file.

 

Best regards,

Message 3 of 16
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

The issue is likely that you have the serial port enabled. To use EHS you'll need to disable the serial port on 5.9.0. We changed this for an intermittent issue we found internally.

 

To resolve you should make sure to disable the serial port.

device.set="1"

device.serial.enable.set="1"

device.serial.enable="0"

 

We'll sort out the knowledgebase to better clarify this. Since customers don't typically use the UART on the serial port so disabling it should have no negative impact.

Message 4 of 16
Occasional Advisor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Once again thank for sharing the knowledge!
In my provisioning file, I see "device.set="1" but neither "device.serial.enable.set" nor "device.serial.enable" are defined, I am assumning I should explicitly define them to prevent EHS issue?

Also I noticed that Acoustic fence feature can co-exsist with EHS setting with 5.9.0, I am happy for that. (I used to have looping issue with previous release)

 

https://community.polycom.com/t5/VoIP-SIP-Phones/VVX-601-reboot-loop-when-up-analogHeadsetOption-is-...

Message 5 of 16
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

"I am assumning I should explicitly define them to prevent EHS issue?"

 

You can do this to prevent the issue yes but ultimately you shouldn't need to do this. The parameter may have been in config at some point previously and never disabled/removed. The factory reset removed it. Either way disabling will prevent the issue from showing up again and will keep you from having to factory reset any other phones.

Message 6 of 16
Occasional Visitor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

I have a VVX411 running 5.5.2, and I recently purchased a Plantronics CS540 with an APP-51 EHS.

 

After connecting everything, and changing the hookswitch mode from "Regular" to "Plantronics EHS", the phone reboots and after rebooting, the system reverts back to "Regular". 

 

Any help is appreicated. 

Message 7 of 16
Polycom Employee & Community Manager

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hello @bduncan ,

 

welcome to the Polycom Community.

Both the community's Must Read First and the community's FAQ reference the basic minimum information a new or follow up post should contain.

As you have not attached any kind of log or a backup we can only assume that the issue is caused by a configuration being used.

 

The suggested configuration was already provided and I attached a file which you should be import using the Web Intereface:

 

Utilities > Import & Export Configuration > Import Configuration

 

In addition UC Software 5.5.2 is no longer a supported version so please upgrade to something more current like UC Software 5.9.1


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 16
Visitor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

@domosute

 

Had the same issue. Rollback resolved it for me too. Not clear if Polycom recognizes the problem in the firmware, though. Their responses are always incomprehensible. 

Message 9 of 16
Polycom Employee & Community Manager

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hello @hochmand ,

 

welcome to the Polycom Community.


As already explained by my colleague this is a firmware issue in later releases aka 5.9.0 and 5.9.1 and can be corrected with the configuration he explained and provided.

 

  • Please download the DisableSerialPort.zip file attached to this reply
  • Unzip the file so you have DisableSerialPort.cfg
  • Import this via the Web Interface on your phone browsing to Utilities > Import & Export Configuration > Import Configuration and select the DisableSerialPort.cfg

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.