Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

SOLVED
Occasional Advisor

Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

FYI, I just updated UCS firmware from 5.8.2 to 5.9.0 and noticed that I am not able to set EHS mode to Plantronics.  Comparing UCS Admin Guide, 5.8.1 and 5.9.0, I noticed the default up.analogHeadsetOption value is changed from No EHS-compatible headset is attached to Plantronics EHS-compatible headset is attached.

 

With 5.8.1, reboot is not required, but 5.9.0 is.  Interesting thing is the phone with UCS 5.9.0 default is "No EHS-compatible hedset is attached" setting, not Plantronics EHS, and if I select Plantronics, the phone reboots, but it set back to "No EHS ~" setting after reboot.


Just curious whether this is known issue or not. 

At this moment, I rolled back UCS firmware to 5.8.2.4732 and the headset setting works flawlessly.

 

- UCS Admin Guide: 5.8.1

https://documents.polycom.com/bundle/ucs-ag-5-8-1/page/r-ucs-ag-headset-and-speakerphone-parameters....

 

- UCS Admin Guide: 5.9.0

https://documents.polycom.com/bundle/ucs-ag-5-9-0/page/r-ucs-ag-headset-and-speakerphone-parameters....

5 REPLIES
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hi Domosute

 

I don't see this issue here but curious of a few things:

 

Was the phone fully configured with desired configuration before the upgrade to 5.9.0? Or was the upgrade done and then the configuration was applied (and caused the failure)? If the phone is on 5.9.0 and reset to default, then all the same config applied, does the issue still happen?

 

Thanks for your time.

Message 2 of 6
Occasional Advisor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Hi Chad_A,


Thanks for your reply.  I noticed the setting properly remained once I factory resetted the phone manually.  I confirmed Plantronics EHS setting was the default setting and select it explicitly with  up.analogHeadsetOption="2" in my provisioning file.

 

Best regards,

Message 3 of 6
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

The issue is likely that you have the serial port enabled. To use EHS you'll need to disable the serial port on 5.9.0. We changed this for an intermittent issue we found internally.

 

To resolve you should make sure to disable the serial port.

device.set="1"

device.serial.enable.set="1"

device.serial.enable="0"

 

We'll sort out the knowledgebase to better clarify this. Since customers don't typically use the UART on the serial port so disabling it should have no negative impact.

Message 4 of 6
Occasional Advisor

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

Once again thank for sharing the knowledge!
In my provisioning file, I see "device.set="1" but neither "device.serial.enable.set" nor "device.serial.enable" are defined, I am assumning I should explicitly define them to prevent EHS issue?

Also I noticed that Acoustic fence feature can co-exsist with EHS setting with 5.9.0, I am happy for that. (I used to have looping issue with previous release)

 

https://community.polycom.com/t5/VoIP-SIP-Phones/VVX-601-reboot-loop-when-up-analogHeadsetOption-is-...

Message 5 of 6
Polycom Employee

Re: Can't set Electronic Hookswitch (EHS) mode with UCS 5.9.0

"I am assumning I should explicitly define them to prevent EHS issue?"

 

You can do this to prevent the issue yes but ultimately you shouldn't need to do this. The parameter may have been in config at some point previously and never disabled/removed. The factory reset removed it. Either way disabling will prevent the issue from showing up again and will keep you from having to factory reset any other phones.

Message 6 of 6