Plantronics + Polycom. Now together as Poly Logo

Cannot sign Polycom VVX into Lync 2013 through Edge server

James Frost
Occasional Advisor

Cannot sign Polycom VVX into Lync 2013 through Edge server

Hi there,

 

I'm evaluating the Polycom VVX devices, the BToE addon, and the subsequent integration with Microsoft Lync 2013. I'm running the latest version of the Polycom UC software 5.0.1.4608.

 

For the most part, it all looks good (ignoring video calls from Lync 2013 clients which don't work in this version) when connecting to an on-premise Lync 2013 deployment.

 

However, I'm wondering whether it's possible for the VVX devices to be able to connect remotely through a Lync Edge Server? I've done some testing with and without BToE, but am getting sign-on errors (see below). We have scenarios where these devices would be used outside the corporate network and would need to signin via the Edge. Any assistance would be good.

 

Regards, James

 

0303070710|so   |4|00|[soRegistrationC] Login Credentials valid causing SoRegEventLine Added
0303070711|app1 |*|00|SoRegistrationEventLast - new AppRegLineC, szUser = jfrost@contoso.com.au
0303070711|sip  |*|00|Sip Register Usr:jfrost@contoso.com.au Dsp:jfrost Auth:'Using Login Cred' Inx:0
0303070714|sip  |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'contoso.com.au' found no records
0303070714|sip  |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'contoso.com.au' found no records
0303070714|sip  |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'contoso.com.au' found no records
0303070714|sip  |4|00|doDnsListLookup(tls): doDnsSrvLookupForARecordList 'sipinternal.contoso.com.au' found no records
0303070714|sip  |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipinternal.contoso.com.au' found no records
0303070714|sip  |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipexternal.contoso.com.au' found no records
0303070715|sip  |4|00|TLS-DSK: Setting of Client Certificate failed due to (33558530) error:02001002:system library:fopen:No such file or directory
0303070715|sip  |4|00|TLS-DSK: Setting of Client Private key failed due to (537346050) error:20074002:BIO routines:FILE_CTRL:system lib
0303070715|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/sip.usr doesn't exist or is empty
0303070715|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/sip.usr doesn't exist or is empty
0303070715|sip  |4|00|CTcpSocket::Abandon connected socket. Send Message 0x40e39e88
0303070715|cfg  |4|00|RT|SIP is settting Login Credentials to invalid
0303070715|so   |4|00|[soRegistrationC] Login Credentials invalid causing SoRegEventLine Deleted
0303070715|app1 |4|00|Exchange Client: Failed to retrieve login credentials (timeout = 0)
0303070715|sip  |4|00|Registration failed User: jfrost, Error Code:480 Temporarily not available
0303070715|sip  |4|00|SSL_get_error Error code=5
0303070715|sip  |4|00|TLS Listen Thread Exit
0303070716|app1 |*|00|SoRegistrationEventLineDeleted - new AppRegLineC, Default user
0303070716|sip  |*|00|Sip UnRegister Usr:jfrost@contoso.com.au Dsp:jfrost Auth:'' Inx:0
0303070716|sip  |*|00|SipUserRemove: user 0 being removed.
0303070716|sip  |*|00|Sip Register Usr:VVX410 Dsp:VVX 410 Auth:'Using Login Cred' Inx:0
0303070721|sip  |*|00|User removed
0303070733|tickt|4|00|soWebTicketTicketGet: Failed, result 401
0303070733|tickt|4|00|soWebTicketTicketGet: Could not get ticket for https://cspool02.contoso.com.au/WebTicket/WebTicketService.svc
0303071513|app1 |4|00|BT login is Started: exsisting line details m_lineIx=1  credType =2  

 

Message 1 of 6
5 REPLIES 5
SteffenBaierUK
Polycom Employee & Community Manager

Re: Cannot sign Polycom VVX into Lync 2013 through Edge server

Hello James Frost, 

welcome to the Polycom Community.

The answer is in your logs. The phone cannot find the DNS entries for your Domain and therefore is unable to authenticate.

 

A wireshark trace filtered on DNS would show you what the phone is looking for and cannot find.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
James Frost
Occasional Advisor

Re: Cannot sign Polycom VVX into Lync 2013 through Edge server

Hmm that's the thing. There are DNS records for both of the following:

 

- External SRV records for the domain.

- A record for sip.contoso.com.au

 

My Lync 2013 client signs on fine. The only record that's missing is sipexternal. According to the MS Lync DNS requirements, both of these DNS records should take priority. Anyway, I'll arrange to have it created and will report back if the VVX starts signing on.

 

 

Message 3 of 6
James Frost
Occasional Advisor

Re: Cannot sign Polycom VVX into Lync 2013 through Edge server

I now have the VVX signing on via the Edge.

 

It doesn't seem able to use UPN to sign-on to the Edge, and insists on the user's NETBIOS domain and SAMAccountName also being populated in the Domain and User fields. In this particular hosted Lync environment, the users UPN (user@contoso.com.au) wasn't a direct match to their NETBIOS domain and their SAMAccountName attributes, which prevented it from working.

 

What was interesting, was that the BToE add-on automatically populates these fields... in this case with the wrong details. I had to stop BToE, then manually populate the Domain and User fields, then sign-on, then start BToE pairing. After that it worked fine.

 

I'll confirm whether this is expected behaviour with Polycom support.

 

Cheers, James.

Message 4 of 6
tvoelcker@epitomenetworks.com
Occasional Visitor

Re: Cannot sign Polycom VVX into Lync 2013 through Edge server

I am just starting with the VVX 600 phones and am having the same issue that you were. I cannot log into the VVX 600 phone externally but works fine internally. I have a sip.domain.com record. It is a cname pointed at my A record for my edge. I cant find any documentation on what the autodiscovery process is supposed to look like. WHen I look at the log on the phone the only record that shows it is searching for is sipinter.domain.com. If i am plugging this into a small remote office on even in someones home office how is the divice supposed to work if the required DHCP options connect be emplented on the device handing out ip addresses? Any help would greatly be appriciated.

Message 5 of 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Cannot sign Polycom VVX into Lync 2013 through Edge server

Hello tvoelcker@epitomenetworks.com,

welcome to the Polycom Community.

A DHCP entry would not be required as Option 43 and 120 is not a functionality that is needed when using the Username sign in process.

 

  • Does the phone have a valid certificate for your LYNC setup ?

  • Does the phone display the correct time ?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6