Plantronics + Polycom. Now together as Poly Logo

Corporate ldap listing goes missing after search

Highlighted
Advisor

Corporate ldap listing goes missing after search

I've set up ldap corporate directory.  I go into the menu, then features, then corp dir.  A list from the ldap directory is then displayed.

 

If I then search for an entry, and back out of the menues to the main idle screen, then go back to features and corp dir, the corp dir listing will display the last search results, not the main index of all results.

 

Is there a way to get the entire list back without rebooting?

 

My Config

-------------

<dir.corp
      dir.corp.address="ldap://192.168.35.127"
      dir.corp.transport="TCP"
      dir.corp.port="389"
      dir.corp.user="cn=Manager,dc=example,dc=com"
      dir.corp.password="password"
      dir.corp.baseDN="DC=example,DC=com"
      dir.corp.filterPrefix="(!(sn=ldapuser))"
      dir.corp.autoQuerySubmitTimeout="0"
      dir.corp.backGroundSync="1"
      dir.corp.bindOnInit="1"
      dir.corp.cacheSize="128"
      dir.corp.domain=""
      dir.corp.pageSize="32"
      dir.corp.scope="sub"
      dir.corp.sortControl="0"
      dir.corp.viewPersistence="1"
    >
      <dir.corp.attribute
        dir.corp.attribute.1.filter=""
        dir.corp.attribute.1.label="LastName"
        dir.corp.attribute.1.name="sn"
        dir.corp.attribute.1.searchable="0"
        dir.corp.attribute.1.sticky="0"
        dir.corp.attribute.1.type="last_name"

        dir.corp.attribute.2.filter=""
        dir.corp.attribute.2.label="FirstName"
        dir.corp.attribute.2.name="givenName"
        dir.corp.attribute.2.searchable="0"
        dir.corp.attribute.2.sticky="0"
        dir.corp.attribute.2.type="first_name"

        dir.corp.attribute.3.filter=""
        dir.corp.attribute.3.label="Number"
        dir.corp.attribute.3.name="telephoneNumber"
        dir.corp.attribute.3.searchable="0"
        dir.corp.attribute.3.sticky="0"
        dir.corp.attribute.3.type="phone_number"
      />
      <dir.corp.auth dir.corp.auth.useLoginCredentials="0"/>
      <dir.corp.backGroundSync dir.corp.backGroundSync="1" dir.corp.backGroundSync.period="60"/>
      <dir.corp.vlv dir.corp.vlv.allow="1" dir.corp.vlv.sortOrder="sn givenName telephoneNumber"/>
    </dir.corp>
    <dir.local dir.local.readonly="0">
      <dir.local.contacts
        dir.local.contacts.maxNum="9999"
        dir.local.contacts.maxNum.SPIP235T="99"
        dir.local.contacts.maxNum.SPIP321="99"
        dir.local.contacts.maxNum.SPIP331="99"
        dir.local.contacts.maxNum.SPIP335="99"
        dir.local.contacts.maxNum.SSIP5000="99"
        dir.local.contacts.maxNum.SSIP6000="99"
        dir.local.contacts.maxNum.SSIP7000="99"
        dir.local.contacts.maxNum.VVX500="500">
      </dir.local.contacts>
    </dir.local>
   <dir.search dir.search.field="0">
    </dir.search>
  </dir>

 




Message 1 of 27
26 REPLIES 26
Highlighted
Polycom Employee & Community Manager

Re: Corporate ldap listing goes missing after search

Hello markm,

 

welcome to the Polycom Community.

 

We encourage all users to check the SIP / UCS Admin Guide.

 

Quote:

 

LDAP.png

 

Please check above Parameter and see if this resolves your issue.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 27
Highlighted
Advisor

Re: Corporate ldap listing goes missing after search

I've played with that as well before I posted.

 

viewPersistence = 0  and viewPersistance = 1 make no difference in the behavior of the listing showing upon return.

 

viewPersistance = 1 will show the previous search, viewPersistance = 0 will show an unpopulated search screen upon return to the menu

Message 3 of 27
Highlighted
Advisor

Re: Corporate ldap listing goes missing after search

This is version 4.0.1b of the sip firmware

Message 4 of 27
Highlighted
Polycom Employee & Community Manager

Re: Corporate ldap listing goes missing after search

Hello markm,

 

I am not sure if I fully understand your query.

 

What Information is being displayed ?

 

A standard LDAP Integration via the Corporate Directory Feature just shows the Search Bar at the Top and nothing else.

 

CorpDirectory.png

 

Please describe your issue in more detail or raise this via your Polycom Reseller.

 

All functionalities are described => here <=

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 27
Highlighted
Advisor

Re: Corporate ldap listing goes missing after search

This is what I see when have a cold boot and enter corporate directory.

 

When I enter in a string to search, exit the directory, and then go back to the directory.  I will see the screen you pasted above.

The only way I can get to this 'index' display again, is to reboot and then enter corp directory.

Highlighted
Polycom Employee & Community Manager

Re: Corporate ldap listing goes missing after search

Hello markm,

 

using my own LDAP configuration I am unable to reproduce this running UCS 4.0.1 on a SoundPoint IP 331.

 

Please check this post => here <= where I added my example.

 

If you still have issues when using above instead of your configuration please contact your Polycom Reseller for further support.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 27
Highlighted
Occasional Visitor

Re: Corporate ldap listing goes missing after search

The list of the corporate directory entries appears only after a cold reboot and only the first time the user enter the corporate directory, il the user enter again in the corporate directory only the quick search box is displayed.

 

Oddly this strange behaviour is triggered by setting "dir.corp.backGroundSync" to "1".

 

A few weeks ago we have upgraded 1600 polycom phone of an our custom from 3.1.3 to 4.0.2b and in release 3.1.3 the corporate listing was displayed every time the user enter the corporate directory.

 

We had found this behaviour on ip331, ip450 and ip670.

Message 8 of 27
Highlighted
Polycom Employee & Community Manager

Re: Corporate ldap listing goes missing after search

Hello dbusacca,

welcome to the Polycom Community.

If this is an issue that you feel is caused by the Phone's latest Software I can only advise you to contact your Polycom reseller so a case with Polycom support can be raised.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 27
Highlighted
Occasional Visitor

Re: Corporate ldap listing goes missing after search

Hi markm,

 

Did you ever resolve this issue?. I'm having the exact same porblem with an 8440 handset connected to CUCM (Call Manager) 8.6.2

 

:) Jas.

Message 10 of 27