Plantronics + Polycom. Now together as Poly Logo

Custom background image on VVX

SOLVED
Valued Contributor

Custom background image on VVX

Hi there

 

I am trying to configure a custom background image for VVX phones (VVX300 is the main one at the moment) however cant seem to get it to work.....

 

In my config I have:

 

  <bg>
    <bg.medRes.gray.selection="3,2" />
    <bg.medRes.gray.bm.2.name="intech1.bmp"/>
  </bg>

 

And have uploaded intech1.bmp to the provisioning server where the 0000000.cfg file is located.  Am I missing anything in the config at all?  I have tried making sense of the documents and FAQ however it is a bit all over the place!

 

FYI am running UCS 4.1.5.3284

 

My ultimate goal is to have the logo (which has been cropped to the required pixel specs) displayed on the handsets without having to select it - at the moment it is not even shown as available in the menu.

 

Thanks in advance for any replies...

 

Dave

Message 1 of 13
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Valued Contributor

Re: Custom background image on VVX

I have solved the issue I was experiencing:

 

in phone%BWDEVICEID%.cfg:

  <bg>
     <bg.color.VVX300.selection bg.color.VVX300.selection="2,2" />
     <bg.color.VVX300.bm.2.name bg.color.VVX300.bm.2.selection="https://dms.ipt.someone.co.uk:443/dms/polycomvvx300/1.jpeg" />
     <bg.color>
      <bg.color.selection bg.color.selection="2,2" />
      <bg.color.bm.2.name bg.color.bm.2.name="https://dms.ipt.someone.co.uk:443/dms/polycomvvx300/1.jpeg" />
    </bg.color>
    <bg.VVX300>
      <bg.VVX300.color.selection bg.VVX300.color.selection="2,2" />
      <bg.VVX300.color.bm.2.name bg.VVX300.color.bm.2.name="https://dms.ipt.someone.co.uk:443/dms/polycomvvx300/1.jpeg" />
    </bg.VVX300>
    <bg.hiRes>
      <bg.hiRes.color>
        <bg.hiRes.color.bm.2.name bg.hiRes.color.bm.2.name="https://dms.ipt.someone.co.uk:443/dms/polycomvvx300/1.jpeg" />
        <bg.hiRes.color.bm.2.em.name bg.hiRes.color.bm.2.em.name="" />
      </bg.hiRes.color>
    </bg.hiRes>
  </bg>

Then upload the 1.jpeg under the specific Identity/Device Profile Type as a new file (Broadworks).

 

This worked for me - hope this helps others........just dont forget to get the jpeg image right depending on VVX model.

 

Cheers

 

Dave

View solution in original post

Message 11 of 13
12 REPLIES 12
Highlighted
Valued Contributor

Re: Custom background image on VVX

Hi there, just an update...

 

I now have the following in my config:

 

  <bg>

    <bg.VVX300>
      <bg.color.VVX300.selection bg.color.VVX300.selection="3,2">
      <bg.color.bm.2.name bg.color.bm.2.name="intechnology208x104.jpeg" />
    </bg.VVX300>

    <bg.hiRes>
      <bg.hiRes.gray.selection bg.hiRes.gray.selection="3,2">
      <bg.hiRes.gray.bm.2.name bg.hiRes.gray.bm.2.name="intechnology208x104.jpeg" />
      <bg.hiRes.gray.bm.2.adj bg.hiRes.gray.bm.2.adj="3">
    </bg.hiRes>

    <bg.medRes>
      <bg.medRes.gray.selection bg.medRes.gray.selection="3,2">
      <bg.medRes.gray.pr.2.adj bg.medRes.gray.bm.2.adj="3">
      <bg.medRes.gray.bm.2.name bg.medRes.gray.bm.2.name="intechnology208x104.jpeg" />
    </bg.medRes>

  </bg>

 

its my understanding that the 2 at the end of the 3,2 selects the 2nd image available on boot to show - I can see the image in the phone menu to select however it is not showing after a phone restart is there something I am missing??

 

Many thanks

 

Dave

Message 2 of 13
Highlighted
Valued Contributor

Re: Custom background image on VVX

Have also tried:

 

<bg>
    <bg.color/>
      <bg.color.selection bg.color.selection="2,2" />
        <bg.color.bm.2.name bg.color.bm.2.name="intechnology208x104.jpeg" />
    <bg.color/>
    <bg.VVX300/>
      <bg.VVX300.color.selection bg.VVX300.color.selection="2,2" />
        <bg.VVX300.color.bm.2.name bg.VVX300.color.bm.2.name="intechnology208x104.jpeg" />
    <bg.VVX300/>
    <bg.VVX_1500/>
      <bg.VVX_1500.color.selection bg.VVX_1500.color.selection="2,2" />
        <bg.VVX_1500.color.bm.2.name bg.VVX_1500.color.bm.2.name="intechnology208x104.jpeg" />
    <bg.VVX_1500/>
    <bg.hiRes>
      <bg.hiRes.color>
        <bg.hiRes.color.bm.2.name bg.hiRes.color.bm.2.name="intechnology208x104.jpeg" />
          <bg.hiRes.color.bm.2.em.name bg.hiRes.color.bm.2.em.name="" />
        </bg.hiRes.color.bm>
      </bg.hiRes.color>
      <bg.hiRes.gray.selection bg.hiRes.gray.selection="2,2" />
        <bg.hiRes.gray.bm.2.name bg.hiRes.gray.bm.2.name="intechnology208x104.jpeg" />
        <bg.hiRes.gray.bm.2.adj bg.hiRes.gray.bm.2.adj="-2">
          <bg.hiRes.gray.bm.2.em.name bg.hiRes.gray.bm.2.em.name="" />
        </bg.hiRes.gray.bm>
      </bg.hiRes.gray>
    </bg.hiRes>
    <bg.medRes>
      <bg.medRes.gray>
        <bg.medRes.gray.bm bg.medRes.gray.bm.2.adj="-2" bg.medRes.gray.bm.2.name="intechnology208x104.jpeg" />
      </bg.medRes.gray>
    </bg.medRes>
  </bg>

 

however in the phone logs it is still selecting the default:

 

bg.color.selection="1,1"

 

Please can someone point me in the right direction as to where I may be going wrong??.....

 

Many thanks

 

Dave

Message 3 of 13
Highlighted
Polycom Employee & Community Manager

Re: Custom background image on VVX

Hello Dave,

this actually seems to be a current bug. The phone is not able to show the picture after a reboot if it has been added for example via the Web Interface.

 

Example from a log:

 

1030134042|res  |4|00|[ResFinderC]: Download - Failed to download file polycom-logo.jpg, errno 0x2.
1030134042|app1 |4|00|Background retrieve failed: (polycom-logo.jpg): File find error.
1030134042|app1 |4|00|Selected background bitmap: polycom-logo.jpg failed to download

 

If you specify the location as a FQDN instead it will survive a reboot.

 

Example

 

bg.color.bm.1.name="http://10.252.122.117/polycom-logo.jpg"

 

Please raise a case via your Polycom reseller and quote 1-443173039 / VESC-3731


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 13
Highlighted
Valued Contributor

Re: Custom background image on VVX

Hi Steffen

 

Thanks for the reply....

 

I accept that there is currently a bug however is this bug attributing to the fact that the image is not being displayed at all?  I dont see any errors in the logs so its hard to determine....

 

Is the config I am using correct?  As stated I can see that the image is available to select in the phone menu however I would like the phone to boot with the image automatically - I am using auto provision via DMS (Broadsoft)

 

Many thanks

 

Dave

Message 5 of 13
Highlighted
Polycom Employee & Community Manager

Re: Custom background image on VVX

Hello Dave,

 

any troubleshooting should come from your Polycom reseller and/or Polycom support directly as we voluntary contributors simply do not have the time and would be outside the scope for Polycom employees.

 

I still went ahead and copied and pasted your configuration from => here <= into an XML file but am unable to open this due XML errors.

 

Please go ahead and raise this as a bug as instructed and as a workaround correct your XML structure and use a full URL so the phone can load this from a server.

 

Above will work as I tested this in my lab.

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 13
Highlighted
Valued Contributor

Re: Custom background image on VVX

Hi Steffen

 

I will raise the bug gladly, I have re-done the xml:

 

  <bg>
    <bg.color>
      <bg.color.selection bg.color.selection="3,2">
      <bg.color.bm.2.name bg.color.bm.2.name="intechnology208x104.jpeg">
    <bg.color>
    <bg.VVX300>
      <bg.VVX300.color.selection bg.VVX300.color.selection="3,2">
      <bg.VVX300.color.bm.2.name bg.VVX300.color.bm.2.name="intechnology208x104.jpeg">
    <bg.VVX300>
    <bg.VVX_1500>
      <bg.VVX_1500.color.selection bg.VVX_1500.color.selection="3,2">
      <bg.VVX_1500.color.bm.2.name bg.VVX_1500.color.bm.2.name="intechnology208x104.jpeg">
    <bg.VVX_1500>
    <bg.hiRes>
      <bg.hiRes.color>
        <bg.hiRes.color.bm.2.name bg.hiRes.color.bm.2.name="intechnology208x104.jpeg">
        <bg.hiRes.color.bm.2.em.name bg.hiRes.color.bm.2.em.name="">
      <bg.hiRes.color>
      <bg.hiRes.gray>
        <bg.hiRes.gray.selection bg.hiRes.gray.selection="3,2">
        <bg.hiRes.gray.bm.2.name bg.hiRes.gray.bm.2.name="intechnology208x104.jpeg">
        <bg.hiRes.gray.bm.2.adj bg.hiRes.gray.bm.2.adj="-2">
        <bg.hiRes.gray.bm.2.em.name bg.hiRes.gray.bm.2.em.name="">
        <bg.hiRes.gray.bm>
      <bg.hiRes.gray>
    <bg.hiRes>
  <bg/>

 

are you able to check in your lab if that is now ok?  This is what my initial post was for as I am not totally confident that the XML config was/is right and needed help with that particular bit......

 

I have tried editing the selection from 3,2 to 2,2 as again I am unsure as to what background it will be ie solid or background image....

 

Can you please advise on the config/XML - I have followed the Admin guide and http://support.polycom.com/global/documents/support/technical/products/voice/Custom_Background_VVX_T... and    http://support.polycom.com/global/documents/support/setup_maintenance/products/voice/spip_ssip_vvx_A...

 

and also http://support.polycom.com/global/documents/support/technical/products/voice/Custom_Backgrounds_TB62...

 

but none of which make it clear or easy to follow - a little bit of help would be great....

 

Many thanks

 

Dave

 

 

Message 7 of 13
Highlighted
Polycom Employee & Community Manager

Re: Custom background image on VVX

Hello Dave,

 

the above still has XML errors.

 

Just download XML Notepad from => here <=

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 13
Highlighted
Valued Contributor

Re: Custom background image on VVX

Hi

 

I have correted the XML issues:

 

  <bg>
    <bg.VVX_1500>
     <bg.VVX_1500.color bg.VVX_1500.color.selection="2,2" />
     <bg.VVX_1500.color.bm bg.VVX_1500.color.bm.1.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
     <bg.VVX_1500.color/>
    </bg.VVX_1500>
    <bg.color>
      <bg.color.selection bg.color.selection="2,2" />
      <bg.color.bm.2.name bg.color.bm.2.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
    </bg.color>
    <bg.VVX300>
      <bg.VVX300.color.selection bg.VVX300.color.selection="2,2" />
      <bg.VVX300.color.bm.2.name bg.VVX300.color.bm.2.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
    </bg.VVX300>
    <bg.VVX_1500>
      <bg.VVX_1500.color.selection bg.VVX_1500.color.selection="2,2" />
      <bg.VVX_1500.color.bm.2.name bg.VVX_1500.color.bm.2.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
    </bg.VVX_1500>
    <bg.hiRes>
      <bg.hiRes.color>
        <bg.hiRes.color.bm.2.name bg.hiRes.color.bm.2.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
        <bg.hiRes.color.bm.2.em.name bg.hiRes.color.bm.2.em.name="" />
      </bg.hiRes.color>
      <bg.hiRes.gray>
        <bg.hiRes.gray.selection bg.hiRes.gray.selection="2,2" />
        <bg.hiRes.gray.bm.2.name bg.hiRes.gray.bm.2.name="http://10.81.253.91/bw/broadworks/fileRepos/DMS-Polycom-VVX300/intechnology208x104.jpeg" />
        <bg.hiRes.gray.bm.2.adj bg.hiRes.gray.bm.2.adj="-2" />
        <bg.hiRes.gray.bm.2.em.name bg.hiRes.gray.bm.2.em.name="" />
        <bg.hiRes.gray.bm />
      </bg.hiRes.gray>
    </bg.hiRes>
  </bg>

 

and set the image to the full URL however the image is still not displaying!!!

 

Is this caused by the bug or am I still missing something???

 

All I need to know is how to get the phone to pull down the image from the server...if its the bug that is stopping it then fine I can live with that, if not can you point out exactly what is wrong/ or why it is not doing so???

 

There are no errors in the logs and I can manually select the image via the phone settings so the phone can see the image.......

 

Cheers

 

Dave

 

Message 9 of 13
Highlighted
Polycom Employee & Community Manager

Re: Custom background image on VVX

Hello Dave,

 

the bug I described is when you manually load an individual image via the Web Interface.

 

If I specify the Image via an URL my phone loads the image.

 

You would need to span a port to get a wireshark trace or set the COPY and CURL logs to event 1 or 2 to check the phone is actually able to load the images.

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 10 of 13