Plantronics + Polycom. Now together as Poly Logo

Customize the base config or firmware file

SOLVED

Re: Customize the base config or firmware file 161

Yes I understand that. I was more asking your opinion as you have been a huge help to me and a great value to the community. I’m just stuck. 

update. I took a non lync edition and put it on a private external network to test ztp. Factory reset It, set it with lync base and 161. Restarted. Ztp worked fine. 

so I this has to either be 1 of 2 things. 1. Something on my corp net. 2. Something with the lync edition phones. I will take one with me tomorrow  and  do the same test. 

and again thanks for all the help so far. I like passing on knowledge as well. You have a great resource and I have profited heavily off of your posts ! 

Message 11 of 14
SteffenBaierUK
Polycom Employee & Community Manager

Re: Customize the base config or firmware file 161

Hello @IsThisTheKrustyKrab ,

 

I must correct my original statement as ZTP is always last after the DHCP options. It sounds like your network has option 161 set somehow.

 

A log would show this or you can simulate this using this tool >here<


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 12 of 14

Re: Customize the base config or firmware file 161

You sir are a god amongst SIP men. We should call you the sorcerer SIPreme. 

 

that is exactly what i needed. And come to find out, 161 in my dhcp was causing the issue. This was an insane amount of hair pulling but hopefully someone can profit from this one day. 

 

What i found out using that tool, there was a 161 option it was getting. However when i went to DHCP there was no trace of option 161. I took note of the name of the 161 option using that tool. And sure enough it was labeled "unknown" 

 

So i go back into my dhcp settings and sure enough there is an entry all the way at the bottom labeled "unknown". The crazy part of it is, when you double click it or go to properties, the string/IP field was completely blank. So i go to my predefined options for the ipv4 in DHCP. and i manually add back 161. and low and behold that option that was saying "unknown" all of a sudden has an IP address ( that i didnt give it. it just showed on its own). 

 

Digging into windows server, there is a known bug with a certain update, and a corruption issue that can happen, that will basically turn your custom options into a "ghost record". aka it shows unknown, and the ip/string details that you once entered in, just shows blank. and the only way to make the ghost record show itself, is by manually recreated the option in the predefined options. What it looks like happens is the predefined option gets corrupt, but it doesn't necessarily remove it from your list of scope/server options. It just changes it to that stupid "unknown" value. 

 

That tool literally was a life saver, as i was about to give up and just manually provision all the lync edition phones. 

Message 13 of 14

Re: Customize the base config or firmware file 161

update for anyone wondering. i was able to recreate this. 

 

I created 161 in the ipv4 predefined options. then went to the scope options and created a entry for 161. 

Then i went back to the ipv4 predefined options and deleted 161. 

 

And sure enough. on my scope options i now have an "unknown". 

 

Curse old IT people who delete stuff not knowing what they are doing! Someone for sure deleted that predefined options long before i came along. but they didn't clean it from scope options. 

 

What a finish to a Friday. Dont get much better than this. 

 

Thanks again for all your help. I profited heavily from you. So much PROFITTT. It almost feels like i bought bitcoin at the bottom and sold the top haha. I am so relieved. 

Message 14 of 14