Plantronics + Polycom. Now together as Poly Logo

Directory.xml transfer fails on Trio 8800

SOLVED
Occasional Contributor

Directory.xml transfer fails on Trio 8800

Hello,

 

I have setup about 10 new 8800 Trio out of the box version 5.7.1.4179.

5 of those 10 gathered their xxxxxxxxxxxx-directory.xml without any issues from the ftp server but the other half fails with following message. They are all based in the same location within the same network. What could cause this issue?

 

01-23 03:20:18.630 E/PLCM ( 426): 000030.261|clist|4|00|dbSet::srv2mem:'64167fb8e192-directory.xml' File transfer failed, trying to get local file
01-23 03:20:18.630 E/PLCM ( 426): 000030.262|dns |4|00|doDnsLookupForList: DNS not yet initialized, skipping lookup.
01-23 03:20:18.630 E/PLCM ( 426): 000030.262|copy |4|00|DNS lookup failed for 10.91.232.12

I have also attached the whole log to this post.

 

Thanks

Stefan

Message 1 of 7
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: Directory.xml transfer fails on Trio 8800

Hi @Wenharts 

 

a bug in the community prevents at present to delete attachments. Once this is fixed I will delete. No private data should be exposed in the logs.

 

Steffen

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 7 of 7
6 REPLIES 6
Highlighted
Polycom Employee & Community Manager

Re: Directory.xml transfer fails on Trio 8800

Hello @Wenharts 

 

welcome to the Poly community.

 

The log seems very clear that it cannot connect.

 

  • How is the phone provisioned aka is this a manual setting to the server or a DHCP option?
  • Do the FTP server logs show any activity?
  • Does this only affect directory or also other files?

I suggest you change the logging to:

 

  • Settings > Logging > Global Settings > Global Log Level Limit > Log File Size (Kbytes) > Trio or CCX 10240
  • Settings > Logging > Module Log Level Limits > Copy Utilities > Event 3

 

Then reboot and check once booted up via:

 

  • Diagnostics > View & Download Logs > UCS Application > Export

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
Highlighted
Occasional Contributor

Re: Directory.xml transfer fails on Trio 8800

Hello Steffen,

 

thanks for your answer.

All new phones are using DHCP but the provisioning server is added manually of course.

I checked the FTP server logs but freeFTPd does not really provide a log on connection base.

The directory.xml is the only file I push to these phones.
One thing i noticed though. The new 8800 which managed to gather the directory file without issues are running 5.4.5.9658 instead of 5.7.1.4179 and it says Realpresence Trio 8800 instead of Trio 8800.

 

I will perform your suggested steps and provide feedback.


Thanks
Stefan

Message 3 of 7
Highlighted
Occasional Contributor

Re: Directory.xml transfer fails on Trio 8800

Hello Steffen,

 

so i applied your suggested logging settings but it does not seem to provide more clarity in why this file transfair fails. Maybe you can see something?

 

Best Regards

Stefan

Message 4 of 7
Highlighted
Polycom Employee & Community Manager

Re: Directory.xml transfer fails on Trio 8800

Hello @Wenharts ,

 

Use FileZilla as shown => here <=

 

The name was changed in later releases as we dropped the RealPresence bit as this was a bit of a mouthful.

 

I suggest you check this post:

 

Mar 08, 2013 QuestionWhat files does my phone download or upload and why?

Resolution: Please check => here <=

 

and

 

Oct 7, 2011 Question: What is the relevance of the 000000000000.cfg or <mac>.cfg?

Resolution: Please check => here <=

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 7
Highlighted
Occasional Contributor

Re: Directory.xml transfer fails on Trio 8800

Hi Steffen,

 

i managed to fix it.

Very mysterious typo with the provisionig server on my end....

Would it be possible to delete my Logs in this post?

 

Best Regards

Stefan

Message 6 of 7
Highlighted
Polycom Employee & Community Manager

Re: Directory.xml transfer fails on Trio 8800

Hi @Wenharts 

 

a bug in the community prevents at present to delete attachments. Once this is fixed I will delete. No private data should be exposed in the logs.

 

Steffen

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 7 of 7