Plantronics + Polycom. Now together as Poly Logo

Disable or remove the DND Softkey

Occasional Visitor

Disable or remove the DND Softkey

My customer wants us to disable or remove the DND feature on the VVX 300 phone.  How do I do that?

Message 1 of 15
14 REPLIES 14
Highlighted
Polycom Employee & Community Manager

Re: Disable or remove the DND Softkey

Hello b cannon

Please check the FAQ

Jul 11, 2014 Question: How can I disable the Do not Disturb / DND and/or Call forwarding options on the Phone?
Resolution: Please check => here <=

Send from a mobile device




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 15
Advisor

Re: Disable or remove the DND Softkey

hello

 

you can do it just by addind this line :

 

<feature
feature.doNotDisturb.enable="0"
/>

 

it will remove sofkey and menu icon

 

for icon only, it is :

           

 homeScreen.doNotDisturb.enable="0"

 

 

and for softkey only, it is :

 

 softkey.feature.doNotDisturb="0"

 

 

 

 

Message 3 of 15
Advisor

Re: Disable or remove the DND Softkey

I am trying this code in a vvx 300 and the DND softkey is still showing.

 

feature.doNotDisturb.enable="0"
softkey.feature.doNotDisturb="0"
homeScreen.doNotDisturb.enable="0"

  

UC Software Version

5.1.1.2986

 

Message 4 of 15
Advisor

Re: Disable or remove the DND Softkey

here is the only line I put on my config file :

 

<feature
feature.doNotDisturb.enable="0"
/>

 

 

you don't need the 3 lines together, only 1 of them, following the thing you want to do.

I have the same version as you.

 

check that you don't have elsewhere this command activated :

 

divert.dnd.1.enabled="1"

 

if yes, remove it or change the value to "0"

 

Message 5 of 15
Polycom Employee & Community Manager

Re: Disable or remove the DND Softkey

Hello all

My initial reply detailed the FAQ post which explains this in detail and also mentions the required software version in order to be able to utilise the feature.

So far no software version that is being used was mentioned.

Send from a mobile device



<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 15
Occasional Advisor

Re: Disable or remove the DND Softkey

Using UC Software Version 5.2.0.8330 on the VVX 310 and FreePBX 12 with EPM 12.0.0.27 I was able to add softkey.feature.doNotDisturb="0" and that works but as noted it doesn't remove the MENU icon and functionality, so I tried adding:
features
feature.doNotDisturb
enable="0"
but I can't get it to add the entry... in fact I see syntax differences with this article http://community.polycom.com/t5/VoIP/FAQ-How-can-I-disable-the-Do-not-Disturb-DND-and-or-Call/td-p/6... and my current cfg file

Message 7 of 15
Polycom Employee & Community Manager

Re: Disable or remove the DND Softkey

Hello OPTN,

the syntax as described in my FAQ article is:

 

feature.doNotDisturb.enable="0"

If the above does not work for you please contact your Polycom reseller so they can raise a ticket with Polycom support.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 15
Occasional Advisor

Re: Disable or remove the DND Softkey

You are 100% correct and now looking at it with a fresh eye today I got it... Thanks

 

For those that need a little extra, this is how I added it with FreePBX EPM:

 

Message 9 of 15
Occasional Visitor

Re: Disable or remove the DND Softkey


First of all, understand that I'm a completely non-technical business owner so forgive me if I get the language wrong.

 

We use a Polycom VVX310 and have had continuous problems with it autonomously going into DND mode.  Needless to say, this substantially interferes with the conduct of business because calls are not answered.  We've got the phone set for call forwarding to my cell phone when I'm not in the office and that works fine when the phone is not in DND mode.

 

Provisioning server is Phone Power and the supplier of the phone is VOIP Supply, both of which have been very responsive but unable to fix the problem.  I've spent hours doing conference calls with both tech support people on conference calls and remote access to my computer.

 

Most recently, Phone Power tech inserted the following into the feature doNotDisturb.enable="0" into the config file and then rebooted the phone but the DND feature still works manually.  We'll have to wait and see if it autonomously goes into DND mode.

 

VOIP Supply tech thinks the problem is with Phone Power's provisioning software on their servers so not interested in raising a ticket with Polycom.  Phone Power says they have not had this problem with other customers using the VVX310.

 

Anybody have any insight into this issue that has not been discussed in this thread yet?  Any suggestions for a fool proof way to permanently delete or disable the Do Not Disturb function of this phone?

 

Thanks a bunch!

 

 

Message 10 of 15