Plantronics + Polycom. Now together as Poly Logo

Downgrading SpIP650 with 4.x firmware

Hellmark
Occasional Advisor

Downgrading SpIP650 with 4.x firmware

Ok, I just got in some new SpIP650s, and they have really recent firmware (date given for them is August 24th, 2012). When I try to boot them up on my asterisk system they complain that the sip.cfg file has pre-3.3.0 references, and just reboot. Now, since I have older phones that aren't supported after 3.3.0, I kinda want to keep everything on the same page and downgrade. Figure, no problem. I check with the website, and there's a document with instructions on downgrading. I download what it says to, put it on my file server, plug the phones in, and they then complain that the firmware files are not compatible, followed by "Error! Application not present!" and reboots. I then try to use one of the several other firmware packs that I have that have files for the 650 (I always keep the old files on hand after an upgrade), and all have the same issue.

 

Now, what can be done? If I cannot downgrade these phones, they're pretty much useless to me. The company doesn't have it in the budget to replace the older phones, and we also do not want the expense of headache of a separate SIP server for just the new phones. That pretty much gives the options as some how downgrade these phones, or return the phones.

Message 1 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrading SpIP650 with 4.x firmware

Hello Hellmark,

returning the phones seems a bit extreme.

 

Simply follow the advise on above link as shown on page 6.

 

You will need UCS 3.3.2 and the downgrader files unzipped on the Provisioning server you are pointing your phones to.

 

Once the phone is downgraded from UCS 4.x.x to UCS 3.3.2 you can then downgrade it further to any Version still using sip.cfg / phone1.cfg.

 

As the phones are brand new your Polycom reseller should assist you or raise a case for you with Polycom support in case you still struggle to do so.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
Hellmark
Occasional Advisor

Re: Downgrading SpIP650 with 4.x firmware

I have followed those steps, to the T, and it starts to download the UCS3.3.2 files, and reports that it is not compatible. I will attempt to download load again, incase of corruption.

 

Update: Yup, same as before. Keeps complaining that the files aren't compatible.

Message 3 of 7
Hellmark
Occasional Advisor

Re: Downgrading SpIP650 with 4.x firmware

Since I have followed the steps listed, but still cannot get these phones working, what can I do?

Message 4 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrading SpIP650 with 4.x firmware

Hello hellmark,

I had already provided you with the next step:

 

As the phones are brand new your Polycom reseller should assist you or raise a case for you with Polycom support in case you still struggle to do so.

 

If there is an issue in the field we need to capture this via a support ticket.

 

Usually checking the <mac>-boot.log should be sufficient to ensure why these phones are not downgrading.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 7
Hellmark
Occasional Advisor

Re: Downgrading SpIP650 with 4.x firmware

And they've been difficult to get a hold of. In the US, we've just had a major holiday, and many businesses have been closed for the week.

Message 6 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrading SpIP650 with 4.x firmware

Hello,

 

try these details below:

 

 

<Removed due server must not be used for external users>

 

Best regards

 

Steffen Baier

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 7