EFK not working on Polycom SPIP331 with 4.0.11 firmware

SOLVED
Highlighted
Occasional Advisor

EFK not working on Polycom SPIP331 with 4.0.11 firmware

Hello,

I've upgraded my Polycom SPIP331 phones to the latest available fimware release (4.0.11).

 

After upgrading, EFK stopped working.

 

Here's my config:

 

<efk>
<efk.efklist efk.efklist.1.label="Pickup" efk.efklist.1.mname="mypickup" efk.efklist.1.status="1">
<efk.efklist.1.action efk.efklist.1.action.string="$Changup$*78$P1N4$$Tinvite$" />
</efk.efklist>
<efk.efkprompt efk.efkprompt.1.label="Pickup: " efk.efkprompt.1.status="1" efk.efkprompt.1.type="numeric" />
</efk>

 

In the phone logs I've found the following lines:

 

0329094623|efk |1|03|Got call state change: [1]
0329094623|efk |1|03|EFK is in dialtone state.
0329094624|efk |1|03|Macro [$Mmypickup$] is valid.
0329094624|efk |1|03|Action [$Mmypickup$] looks good.
0329094624|efk |1|03|Label is 'Pickup'.
0329094624|efk |1|03|Creating new menu...
0329094625|efk |1|03|New menu has been created...
0329094628|efk |1|03|User entered [8032].
0329094628|efk |1|03|No more input...
0329094628|efk |1|03|Efk exec engine: adding token [Changup]
0329094628|efk |1|03|Efk exec engine: adding token [*78]
0329094628|efk |1|03|Efk exec engine: adding token [8032]
0329094628|efk |1|03|Efk exec engine: adding token [Tinvite]
0329094628|efk |1|03|Executing [hangup].
0329094628|efk |1|03|User buffer contains [*78].
0329094628|efk |1|03|User buffer contains [*788032].
0329094628|efk |4|03|Can't execute [invite], can't create new call.
0329094628|efk |1|03|EFK Exec engine said we are done and will stop.

 

Is it a firmware bug?

 

Thanks,

 

Massimo

Message 1 of 8
7 REPLIES
Polycom Employee & Community Manager

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

Hello Massimo,

welcome to the Polycom Community.

 

If the above worked prior to the upgrade you need to raise a service ticket.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you.

 

If the unit(s) are out of warranty please be prepared to pay per incident / PPI.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 2 of 8
Occasional Advisor

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

I send you the mac address of one of 445 phones we've recently purchased: 0004f25b6f42.

 

We are currently using about 1400 SPIP331 phones, they worked correctly with 4.0.8 firmware release, so I think I'll downgrade all phones to that firmware release.

 

Massimo

 

Message 3 of 8
Polycom Employee & Community Manager

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

Hello Massimo,

Allnet Italia S.p.A. sold this back in 12/02/2016 so it should still be in warranty for them to open a case with Polycom support for you.

 

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 4 of 8
Occasional Advisor

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

As a side note, the problem does not affect Polycom SPIP650 phones with the same firmware release.

 

Massimo

Message 5 of 8
Occasional Advisor

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

Allnet Italia S.p.A. should have opened a case for this problem.

 

At the moment we stll using rev. 4.0.8C with our Soundpoint phones.

 

Thanks,

 

Massimo

Message 6 of 8
Polycom Employee & Community Manager

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

Hello @mvignone,

 

A quick search internally did not turn up anything so without any kind of reference to look for I personally doubt it.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 7 of 8
Occasional Advisor

Re: EFK not working on Polycom SPIP331 with 4.0.11 firmware

I could not tell you...

We sent the request at the time of the problem, giving the assertion that the request for notification had been sent to Polycom.
As already mentioned, the problem has been solved using version 4.0.8C.

Message 8 of 8