Plantronics + Polycom. Now together as Poly Logo

Firmware 4.0.0: phone doesn't register when loging out an user profile

SOLVED
SF
Occasional Contributor

Firmware 4.0.0: phone doesn't register when loging out an user profile

I'm testing the 4.0.0 firmware and user profiles on a SPIP335 phone.

 

The admin manual for 4.0.0 implies a phone can work in regular mode and have user profiles attached as well.

 

So I added prov.login.enable="1" on a registered SIP phone and copied another config file to user.cfg with prov.login.localPassword="1234".

 

The login phase works ok, the phones registers and I'm able to use it nicely, but when logging out the original extension doesn't register and I'm unable to use the phone. It actually doesn't seem to try at all until I reboot the phone.

 

So I'm wondering, is it a bug in the new firmware or shall I set a default profile / default password to have the phone use its default profile instead ?

 

Another bug I encounter when logging out is that it cycles asking whether it should log out or not, but if I say "yes" the first time and "no" the second time the phone is logged out (but unregistered, as explained above).

 

Also, would it be possible for 4.0.1 to have the ability to tell the phone that its username will be all-digits, to ease the process of loging in?

 

Thanks;

Message 1 of 8
7 REPLIES 7
Polycom Employee & Community Manager

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hello Steve,

 

as stated in the Forum Read First and FAQ the Community is not a replacement for the Polycom Support process.

 

In order to verify your separate statements I would need to work with you via the Process we have already established outside this Community. Please ensure that you provide a MAC Address and matching <mac>-app.log and <mac>-boot.log and all configurations files you have used.

 

Have you tried:

 

prov.login.defaultUser String Null


The username for the default user. If present, the user is automatically logged in when the phone boots up and logged in after another user logs out.

 

Any changes to the Phones current behavior should be logged via a Feature request.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 8
SF
Occasional Contributor

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Well I don't really get how I'm supposed to interact with Polycom here. Our distributor told us to report issues through the community forums, which seemed quite out of place tbh. And the service request system doesn't handle the 4.0.0 firmware.

 

Would you prefer me to send you directly emails about issues we uncover?

 

BTW I thought my question of "am I doing it wrong?" was perfectly valid here, as the documentation is not very clear about whether or not the login system still allows you to use regular registrations or not.

 

Regards,

Steve

Message 3 of 8
Polycom Employee & Community Manager

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hello Steve,

 

as we already have a working relationship (if I am thinking of the right Steve) then please go ahead and email me directly and I will raise the Ticket and work with you on this case.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 8
Polycom Employee & Community Manager

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hello Steve,

 

I have just tested this in my lab and it works as I would expect this to work.

 

Please see this new FAQ entry I have created => here <=

 

If you still struggle please go ahead and raise this issue with me.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 5 of 8
Polycom Employee & Community Manager

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hello Steve,

 

did above suggestion fix your issue?

 

If yes please be so kind and mark this as a fixed Solution so other community Users can profit from this post.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 8
Highlighted
SF
Occasional Contributor

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hi,

 

Your FAQ looks like what I did, and it somehow didn't work on my IP335 at the time. I didn't test it further because I switched to using only profiles, and setting a default profile. It works nice, despite a little graphical glitch at startup.

 

Regards,

Steve

Message 7 of 8
Polycom Employee & Community Manager

Re: Firmware 4.0.0: phone doesn't register when loging out an user profile

Hello Steve,

 

please report any issues you are finding via the correct channels. If you are the Steve that I have dealt with before please contact me with your findings so we can escalate this internally.

 

Best Regards

 

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 8