Plantronics + Polycom. Now together as Poly Logo

Firmware upgrade error VVX311

Highlighted
Occasional Visitor

Firmware upgrade error VVX311

So I got a few VVX311 phones I want to use with 3CX, but in order to get them to work they need to be updated to 6.1.2

 

I have tried through the GUI - its not working I get i cant download a .CFG file eror and it will keep looping until I reset it to factory defaults again. 

 

Then I found a guide where I go through the phone and change under server settings and provisioning server, and it seems the phone is downloading but it keeps looping again !!

 

I have configured more than 1,000 of another brand with firmware updates as well, why is Polycom phones so complicated.

 

Not even their own firmware server can update the phones. I hope there is an easy answer or Polycom will not be a part of our offerings moving forward. To much an hassle....

 

Sorry but we have spent way to much time and money on something very simple that other vendors handle with EASE .....

 

Current phone is:

 

Phone InformationPhone Model VVX 311

Part Number 3111-48350-001 Rev:A

MAC Address 64:16:7F:0C:64:40

IP Address 192.168.200.85

UC Software Version 5.4.5.6840

Updater Version 5.6.5.6003

 

Message 1 of 2
1 REPLY 1
Highlighted
Polycom Employee & Community Manager

Re: Firmware upgrade error VVX311

Hello @Knudsen_DK ,

Your post ended up in the Spam Filter so I moved this here.

 

You state you are getting an error and you are using configuration but you have not shared this with us.

 

From our FAQ:

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

Mar 30, 2012 Question: Can I host my own upgrade Server?
Resolution: Please check => here <=

 

Apr 21, 2015 Question: Unable to upgrade the Phone via the built in Software Upgrade Web Interface utility

Resolution: This was a bug and was addressed.Please setup a local provisioning server as shown => here <=. Check the release notes for VOIP-97822 and was fixed in 5.5.2 or 5.3.1 or later.

 

May 11, 2018 Question: Why do I get a "Failed to fetch available software from the Poly hosted server" error message or able to download list but unable to upgrade/downgrade?

Resolution: Please ensure your firewall allows outbound network traffic as shown  => here <=


If you would attach some logs we could try and see if we could help


Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 2