Plantronics + Polycom. Now together as Poly Logo

Help needed factory reset - phone resets to Ring Central rooms phone

Highlighted
Visitor

Help needed factory reset - phone resets to Ring Central rooms phone

This has been driving me crazy and has not been anything that Poly has been able to assist with to date.

 

When we got our phones we got everything going between the visual plus, the camera and everything else.  Upon calling Ring Central customer support, they told we could us the phone with the Trio because we did have rooms and needed to configure the phone to use it.  One of the team found a .xml or .cfg file on a RingCentral forum purporting to solve the issue we were experiencing.  We download the file to a USB, plugged it in and rebooted the phone. The configuration was overwritten and when the phone powered back up, it was a RingCentral Rooms phone and was asking us to sign in. Not having a Rooms account, we couldn't and reset the phone back to factory spec.

 

Phone reboots as a phone (it doesn't work) but as soon as the network connects, it starts downloading updates and, before you know it, it's back to being a Rooms phone.  I have tried to update the configuration files, load different versions, do multiple factory resets and each time, the phone resets and then starts updating back to a Rooms phone.  I even exported the configuration off one of our other 8800's but could not figure out how to load all those files into the stricken phone.

 

I've called RingCentral and they said call Poly so I called Poly and they had me do a factory reset again but then the updates start and I'm right back where I started.  I can get to the interface online but am unable to force changes on the phone because the reboot commands don't do anything.

 

I desperately need some help getting this thing back to being a usable phone. I can attach or link to the config file if that would be of any help to see what we did, but I hate to think that we just created a $300 brick.

 

Thanks in advance.

 

green6001

Message 1 of 4
3 REPLIES 3
Highlighted
Polycom Employee & Community Manager

Re: Help needed factory reset - phone resets to Ring Central rooms phone

Hello @green6001 ,

 

Welcome to the Poly Community.

It is always useful to provide us with some form of background on how you came to this phone.Is this purchased brand new and or what is the relationship with RingCentral?

 

Our phones automatically contact the Poly Zero Touch Provisioning server and will download their 1st configuration from there if the serial was added by one of our partners like RingCentral.

 

Another option could be that you have a local provisioning server and the phone backed up its configuration and therefore after a factory reset will simply load this.

 

I suggest you isolate the phone aka no Internet access and the power it up and set the logging as follows:

 

  • Settings > Logging > Global Settings > Global Log Level Limit > Debug
  • Settings > Logging > Global Settings > Global Log Level Limit > Log File Size (Kbytes) > Trio or CCX 10240
  • Settings > Logging > Module Log Level Limits > DHCP Client > Debug
  • Settings > Logging > Module Log Level Limits > CURL > Event 2
  • Settings > Logging > Module Log Level Limits > Copy Utilities > Event 2

 

Re-enable internet access and power up the phone and provide us with:

 

  • Diagnostics > View & Download Logs > UCS Application > Export
  • Diagnostics > View & Download Logs > System Log > Export

If you cannot proceed with the above please work with the reseller to get this into support.


In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 4
Highlighted
Visitor

Re: Help needed factory reset - phone resets to Ring Central rooms phone

I'll give that a try once I get into the office on Monday.  We use POE to power the phone, so I'll change a network port so there is not outbound network connection. 

 

We purchased the phone new on Amazon so there really isn't a reseller per se for us to refer too.  We do not have a local provisioning server but I had been wondering if it would help if we asked our RingCentral support to remove the record they have in place so we could re-register the phone after the factory reset and avoid the subsequent update that changes the phone to a Rooms phone. I don't what if RingCentral registers their phone with Poly but there has to be a setting somewhere that is telling that phone to add additional updates once it resets.

 

I'll attach the logs I can get along with images of what the phone is doing as most people do not seem to be familiar with what we are referring to as a Rooms phone.

Message 3 of 4
Highlighted
Visitor

Re: Help needed factory reset - phone resets to Ring Central rooms phone

I was actually able to resolve it finally. The idea of the device being provisioned on another server got me to thinking and the upshot was that I completely deleted the phone from our system. Waited a few minutes and then added it back and set the whole thing up. Did another factory default reset and when it started to download updates, I was sure I was going to get the Rooms device back.

 

But the phone came up and has been stable now for about 5 minutes.  Can call out and in, so it looks like that did it.

 

Thanks for all the tips on the logs - that could prove to be very helpful in the future.

Message 4 of 4