Plantronics + Polycom. Now together as Poly Logo

IP 321 cannot recieve calls after approx 6 mins of reboot

Occasional Visitor

IP 321 cannot recieve calls after approx 6 mins of reboot

Hi everyone,

 

I have 4x IP321's configured via an internal ftp provisioning server. They are now all running 4.0.1.13681 with the BootROM 4.4.0 Upgrader. All phones are registered correctly on an externally provided hosted PBX running Freeswitch.

 

On reboot all phones can make and recieve calls and function as expected. (the log shows "0812162205|so   |4|03|[SoNcasC]: Icon(7)Set - State 39 - OOR." after successful extension ring). After approx 6 minutes (tested by calling said extension every 15 seconds) the phones simply stop responding to incoming calls, they are still showing as registered and can make outgoing/internal calls - just not receive anything!

 

Also I am seeing phones loosing details entered via the web interface (all sip/line is entered this way not via config). "Sip/Outbound Proxy/Port" and "Line/Line1/Server 1/Port" has been seen to reset from my entered value of 5060 to 0.

 

Having spent two days on this now I feel that I should ask if anyone has any ideas, they seem like good phones and as we were given them we are keen to recycle technology and make them work for us!

 

Alex

Message 1 of 7
6 REPLIES 6
Polycom Employee & Community Manager

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

Hello Alex,

welcome to the Polycom Community.

The FAQ shows a standard registration and all the settings needed. There is no need to change the 0 to 5060 as 0 represents the standard port 5060.

 

Your issue sounds like a timer or firewall and I would recommend the following:

 

  • Upgrade the phone to UCS 4.0.2 Rev B (the current latest Software)
  • Run a Wireshark Trace via a spanned port and check out what is happening in the network.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
Occasional Visitor

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

Hi Steffen,

 

Thanks for your reply.

 

Woudl you recommend using the provisioning server to upgrade to the latest version or upgrading from within the web interface?

 

Alex

Message 3 of 7
Polycom Employee & Community Manager

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

Hello Alex,

 

a local provisioning server is recommended as it will allow Log files be written back.

 

These may be needed in case you need to involve our support team.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 7
Occasional Visitor

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

Thanks again Steffen,

 

Can i just check what the process is for doing a clean install from the provisioning server. I imagine it should be as follows.

 

1. Download UC_Software_4_0_2B_release_sig_split.zip

2. Remove all other files in ftp server for that user and replace with new unzipped files

3. Perform a "Reset web config" and a "Reset local config" from the phone

4. Reboot phone and wait for upgrade to complete

5. Login to web admin and add sip/line config details

 

Is this correct? I am keen to do a completely clean install incase there are any issues from previous upgrades/configs. 

 

Currently the phones are running BootROM Software Version 5.0.1.10553, will this be upgraded as part of the new UCS 4.0.2 Rev B upgarde?

 

I have looked at Wireshark but as I don't have a manged switch or two network cards I don't believe I can use it in this case.

 

Appreciate your help so far.

 

Alex

Message 5 of 7
Polycom Employee & Community Manager

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

Hello Alex,

 

that sounds about ok. I can only suggest you lower your SIP logging via the Phones Web Interface to a Event 2 and then ensure that your FTP server allows append and writing to the directory to receive the log file.

 

Once you reproduce you issue you can check the log for SIP error messages.

 

If you require support from Polycom you would need to contact your support team directly but would get charged PPI.

 

This is all explained in the community FAQ but other members are more than welcome to look at your issue in detail.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 7
Occasional Visitor

Re: IP 321 cannot recieve calls after approx 6 mins of reboot

I 'may' have solved the issue.

 

After much hunting around the interweb and also testing the same accounts on a softphone but without the issues experienced I decided to investigate the NAT issue.

 

I have now added

 

nat.keepalive.interval="20" into sip-interop.cfg and included it in the 000000000000.cfg file.

 

So far it seems to be working but I will leave it overnight and see if it all still works ok. Out of interest I am moving files out of the config folder to then list them by file name in 000000000000.cfg. Should I leave them be and simply call them via "config/sip-interop.cfg" instead?

 

Alex

Message 7 of 7