Plantronics + Polycom. Now together as Poly Logo

IP 650 Attendant Problem

Sc00by
Occasional Advisor

IP 650 Attendant Problem

I am currently trying to set up an IP650 to remotely monitor another extension.

 

I have the line key registered, it shows when the line is busy, available and ringing however I have a few issues with regards to callerid and ringing.

 

I am running Asterisk 11 and by default the IP650 will ring, the line key will flash but on the screen I see the following (The line being monitored is 3008)

 

To: 3008 (3008@10.10.0.10)

From:

 

 

The CallerID is missing.

 

THe other issue I have is that when they press the button to pickup the display changes to 'Unknown Party'.  The call picks up correctly.

 

 

I have hunted around and found reference to notifycid and setting it to yes and ignore-context.

 

Setting either results in NO callerID (to or from) being shown and the phone does not ring however the line key flashes and the call can be picked up.  Instead of Unknown Party the correct CallerID is shown.

 

The issue with the second problem is that to get the CallerID to show on pickup I loose the ability to have the phone ring.

 

My config:

 

<attendant
  attendant.reg="1" attendant.ringType="ringer6"
 attendant.behaviors.display.remoteCallerID.automata="1"
 attendant.behaviors.display.remoteCallerID.normal="1"
 attendant.behaviors.display.spontaneousCallAppearances.automata="1"
 attendant.behaviors.display.spontaneousCallAppearances.normal="1"

  attendant.resourceList.1.address="sip:3008@10.10.0.10"
  attendant.resourceList.1.label="3008"
  attendant.resourceList.1.type="automata"

/>

 

I am running SIP 4..0.7.2514

Message 1 of 2
1 REPLY 1
SteffenBaierUK
Polycom Employee & Community Manager

Re: IP 650 Attendant Problem

Hello Sc00by,

I have today updated the community's VoIP FAQ  post here:

Nov 4, 2011 Question: How can I setup a Busy Lamp Field / BLF with an Digium Asterisk SIP Server?

Resolution: Please check => here <=

 

Above should include enough details to troubleshoot your setup.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 2