Plantronics + Polycom. Now together as Poly Logo

Issues upgrading 501

Darek007
Occasional Advisor

Issues upgrading 501

Having a very strange issue when trying to upgrade a vvx501 with firmware 5.4.1.16215 

 

 

We use a Cisco 1941 setup with a 2960 POE. With the 1941 connected directly to a static IP - NAT that IP internally to the phone, I cant get the phone to upgrade or register.. I tried a local TFTP setup, the phone just sits there.. I have a vvx 500 plugged in on the same TFTP, it upgrades, downgrades to what ever i want.. So i know it's setup correctly... 

 

Now here is the really strange part.. I set up a double NAT in my office, dont ask me why.. That works.. The phone gets out and registerers to both my broadsoft switch and the Polycom upgrade server..

 

I'm thinking it's a DNS issue or the way the FW is looking @ the NAT.. But the stranger part is that we have another Broadsoft switch we bought not to long ago and the phone registeres to that just fine with the single NAT connection. 

 

So single NAT dosent work, Double NAT works.. I can't explain it.. 

 

 

Any help would be greatly appreciated.. 

Message 1 of 9
8 REPLIES 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Issues upgrading 501

Hello darek007,

welcome to the Polycom Community.

  • Have you got any logs we could look at?
  • What software Version is on the VX500 in comparison to the VVX501?
  • Any wireshark traces?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 9
Darek007
Occasional Advisor

Re: Issues upgrading 501

Attached arethe PCAP and APP Logs. I also have core dumps off a phone that was upgraded which might be a seperate issue. 

 

As far as the 500 phone, I dont recall what it was, but any IOS i try to upgrade it too, it takes.. the 501 just sits there.. Kinda hard to troubleshoot becasue once the 501 upgrades, I cant replicate the issue..

SteffenBaierUK
Polycom Employee & Community Manager

Re: Issues upgrading 501

Hello Darek007,

According to your logs there is nothing on the server:

 

000058.002|cfg  |*|00|Prov|Starting to update 3111-48500-001.mtm8.sip.ld
000058.096|copy |*|00|Server 'p.hpbx.telepacific.net' said 'dms/polycom/3111-48500-001.mtm8.sip.ld' is not present
000058.097|cfg  |*|00|Prov|Starting to update mtm8.sip.ld
000058.106|clist|4|00|dbSet::srv2mem:'000000000000-directory.xml' File transfer failed, trying to get local file
000058.190|copy |*|00|Server 'p.hpbx.telepacific.net' said 'dms/polycom/mtm8.sip.ld' is not present

Can you use the URL and test if there is anything there ?


The next step would be to get your Polycom reseller to open a ticket with Polycom support.

 

This VVX501 was sold via SCANSOURCE COMMUNICATIONS back in 02/06/2016.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 9
Darek007
Occasional Advisor

Re: Issues upgrading 501

Ok, but same result when pointed to the Polycom Servers. http://140.242.64.35/545

 

 

Attached are the APP and BOOT logs..

 

 

 

Darek007
Occasional Advisor

Re: Issues upgrading 501

this is odd..  when i enter http://downloads.polycom.com/voice/software/3111-44500-001.xml  into the custom server under upgrade software, it returns back with "Failed to communicate with the phone".

 

 

Message 6 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: Issues upgrading 501

Hello Darek007,

The log does not really show anything due it not being long enough:

 

000021.012|copy |*|00|Server '140.242.64.35' said '545/64167f026418-directory.xml' is not present
000021.016|clist|4|00|dbSet::srv2mem:'64167f026418-directory.xml' File transfer failed, trying to get local file

In addition the VVX501 needs http://downloads.polycom.com/voice/software/3111-48500-001.xml and not http://downloads.polycom.com/voice/software/3111-44500-001.xml

 

Your next step is to work with your reseller as already highlighted in my original reply or simply setup a local provisioning server instead.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 9
Darek007
Occasional Advisor

Re: Issues upgrading 501

Not being long enough? It says the same thing in your prior reply. 

 

XXXXXXXX is not present

 

As far as seting up a local provisioning server, If you read my first entry, I've done that with 2 phones. A vvx500 and vvx501.

 

The vvx500 works and upgrades while the vvx501 sits there doing nothing. 

 

 

http://downloads.polycom.com/voice/software/3111-48500-001.xml brings back "Failed to communicate with phone".. 

Message 8 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: Issues upgrading 501

Could you go ahead with the next step as advised?

Replied via a mobile device
----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 9