Plantronics + Polycom. Now together as Poly Logo

LLDP SoundPoint IP 331 Dell Powerconnect 3458

Occasional Visitor

LLDP SoundPoint IP 331 Dell Powerconnect 3458

My company is in the process of switching over to VOIP and we're using Polycom SoundPoint IP 331 phones and Dell Powerconnect 3548 switches. We are trying to use LLDP to assign a VLAN to the phones however the phones will not take the LLDP configure broadcast by the switch.



The phones have been updated to the latest firmware and LLDP is an option within the phone setup. We are currently manually setting the phones to the corresponding VLAN but in the future would prefer to have them grab what they need via LLDP instead.



My guess is that I may be missing some tlv information from my switch LLDP configuration but I can't figure out what.



If anyone has any ideas on how to get LLDP to work with my phones and switches I would be very appreciative!



- Thanks

Message 1 of 4
3 REPLIES 3
Polycom Employee & Community Manager

Re: LLDP SoundPoint IP 331 Dell Powerconnect 3458

Hello xJackiexDaniels,

 

welcome to the Polycom Community.

 

I would advise to provide the Software Revision and BootROM / Upgrader Version in follow up post's as we are unaware as what you class the latest Software.

 

Have you checked page 370 onwards on the UCS 4.0.1 Admin Guide => here <= if UCS 4.0.1 is the Software you are running?

 

Did you check with DELL as there seems to be a few post regarding LLDP with Polycom Phones using a popular search engine ?

 

One example is => here <= or => here <=

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 4
Valued Contributor

Re: LLDP SoundPoint IP 331 Dell Powerconnect 3458

I realize that this is an old-ish thread, but I ran into exactly the same issue: SPIP 335/450/650 running BootROM 4.4.0 and UC 4.0.2B would not accept the LLDP advertisement from our Dell PowerConnect 35XX switch containing the voice network policy.  I tried everything under the sun, and nada.

 

I was using the following switch configuration (boiled down to its essence):

 

vlan database
vlan 100
exit
lldp med network-policy 1 voice vlan 100 vlan-type tagged
interface ethernet g4
description TrunkPort
switchport mode trunk
switchport trunk allowed vlan add 100
exit
interface range ethernet e(1-48)
switchport mode general
switchport general allowed vlan add 100
lldp notifications enable
lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy
lldp med enable network-policy location poe-pse inventory
lldp med network-policy add 1
exit

 

Finally, in frustration, I mirrored the traffic to another port and snooped on it with Wireshark.  All of the TLVs that UC Administrator's Guide listed as "mandatory" were present in the switch's advertisement, plus a few more (since I specified the "lldp optional-tlv" parameter).  The one thing that caught my eye, though, was that one of the optional TLVs the switch was sending ("System Name") was being sent with a null value.

 

The Dell PowerConnect 35xx series apparently takes its LLDP System Name from whatever you have configured as the "hostname" string.  So I added a "hostname blahblahblah" to the switch's running config, and voila: the SoundPoint phones finally switched to the right VLAN on boot.  Apparently the SoundPoint BootROM does not like it if you pass it a TLV (even an optional one) with a null value.  You don't have to pass the optional TLVs, but if you do choose to include them, they must contain non-null values.

 

This isn't documented anywhere, of course.

 

Since I am not intimately familiar with the standards documents that govern LLDP, I cannot say for certain whether TLVs with null values are allowed or not, and so I don't know who is at fault here: Dell or Polycom.  I also never got around to trying it with "sys-name" eliminated from the list of 'optional-tlv's in the Dell config, but I suspect that solution would have worked, as well.

 

Hope this helps someone else avoid needlessly wasting the same kind of time on this as I did,

 

-- Nathan

Message 3 of 4
Highlighted
swy
Occasional Visitor

Re: LLDP SoundPoint IP 331 Dell Powerconnect 3458

Nathan,

 

I wanted to say THANK YOU for posting this: years after doing this, you provided the answer to a problem I was having with a phone deployment this week.  

 

Know that your hope of someday solving someone's problem by posting this came true, and that I am grateful for your effort.

 

I really hope that this board has a "alert of new posts" feature that you're subscribed to...

Message 4 of 4