Plantronics + Polycom. Now together as Poly Logo

Manually configure IP550 CIP

Occasional Visitor

Manually configure IP550 CIP

I have a IP550 CIP telephone connected to a APP5 Plantronics adapter. The other end of the adapter is connected to a Plantronics CS70NC headset base. I contacted Plantronics because the CS70NC drops the headset connection after about a minute. Long story short, this is what they said ''your phone may not be configured correctly, you need the Electronic Hook Switch to be enabled. Verify that both the headset jack and hook switch features are enabled for your extension. Specify whether or not the electronic hook switch feature is enabled and what type of headset (attribute up.analogHeadsetOption set to 2) is attached by changing the phone1.cfg in the boot server. I am at a remote location and my phone communicates over the internet with Trixbox/Astrix server about 10 miles away. My phone has some manual configurations already set, like the IP of the phone server etc.. but for some reason it can not see the boot server located in the same facility the Trixbox/Astride server is in. With this said, can I setup a TFTP or some sort of other server and set my IP550 to look to it for it's configuration settings noted above?
Message 1 of 4
3 REPLIES 3
Advisor

Re: Manually configure IP550 CIP

There isn't really a need to do this through a provisioning server.  You can do this if you want but the phone's local settings will override the provisioning server anyway. You can access the settings via this menu sequence:

 

Menu > Settings > Basic > Preferences > Headset > Analog Headset

 

Make sure it's set to 3. Plantronics Mode; make sure you have the cable plugged into the 5 pin serial header properly and connected to your headset base and you should be in business.

Message 2 of 4
Occasional Visitor

Re: Manually configure IP550 CIP

I guess that is the problem, I do not have the Plantronics option only "Regular" or "Jabra".  Can I rev the phone to give it Plantronics option?  Is there something else I should be doing?

 

Confirmed all cable connections and they are correct.  I can use the headset and it works just fine but drops the connection to the base after ~1 min.  If I unplug the cables from the phone to the base, then initiate a connection from the headset to the base, it never drops the connection.  To test I left it connected for 5 minutes.  If I tried the same scenario with the cables connected between the phone and the base, the headset-to-base connection will drop in ~1 minute.  This leads me to believe the IP550 sends the base some sort of signal and/or command (assume through the mini plug looks like a iPod headphones plug). Since I do not have the Plantronics option, I assume the signal the phone is giving the base is either not of the correct format or the wrong command or....

 

See attached pics for my current version(s)

 

Thanks

 

Jason

 

 

Advisor

Re: Manually configure IP550 CIP

Your phone has to be running at least BootRom 4.1.0 (which you have) and SIP 3.1.0RevB (Which you don't -- you are 3.0.1) to support Plantronics headsets with electronic hookswitch. 

 

If you were to update your phone by setting up a local provisioning server, you could not ever point it back at your provider's provisioning server as it would simply downgrade to the software hosted on the provisioning server. To keep your phone working you would have to enter and maintain all settings manually or by using your local provisioning server. Honestly, this is a course of action I cannot really advise. It is complicated and requires quite a bit of knowledge to make work.

 

You should discuss with your provider or admin about updating the software revision and configration on the provisioning server. This is the most reasonable and sensible course of action. Honestly it should probably be done anyway for many reasons unrelated to the lack of support for Plantronics EHS.

Message 4 of 4