Plantronics + Polycom. Now together as Poly Logo

Opus Negotiation not happening

SOLVED
Occasional Visitor

Opus Negotiation not happening

Just updated to the latest UC firmware for my VVX600.  Version is UC Software Version 5.8.0.12848.

 

On my pbx, I have enabled the opus codec, and found that it works with all our other phones in the office (sounds awesome).  For some reason, I can't get my polycom phone to negotiate the Opus codec when making any calls.

 

I set my Settings->Codec Priorities "In use" area to have:

Opus

G.711Mu

 

And it negotiates 'ulaw' every time.  If it have just 'opus' I can't make any calls.  I'm using the same extension as another phone that's a different brand and it uses opus just fine.

 

Any idea why I'm not getting my phone to make an opus call?  G722 works but it's just not as good and it sounds like it's 'underwater' intermittently.  Again, this issue seems to be exclusive to our polycom phones and every other phone in the shop is working.

 

 

Message 1 of 5
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Visitor

Re: Opus Negotiation not happening

Okay, totally figured it out.

 

If you go to Preferences/Video Processing and change "Video" to "Disable", opus will start working.  I noticed that video + opus is not supported, and assumed that was something that would be negotiated on the fly (if a call requested video, the opus codec would not be selected and the next down on the priority list would be).  This is not the case!  If video is enabled on the phone in any way, you won't be able to negotiate opus.

 

Hope this helps someone else.

View solution in original post

Message 2 of 5
4 REPLIES 4
Highlighted
Occasional Visitor

Re: Opus Negotiation not happening

Okay, totally figured it out.

 

If you go to Preferences/Video Processing and change "Video" to "Disable", opus will start working.  I noticed that video + opus is not supported, and assumed that was something that would be negotiated on the fly (if a call requested video, the opus codec would not be selected and the next down on the priority list would be).  This is not the case!  If video is enabled on the phone in any way, you won't be able to negotiate opus.

 

Hope this helps someone else.

View solution in original post

Message 2 of 5
Highlighted
Polycom Employee & Community Manager

Re: Opus Negotiation not happening

Hello @Negative,

welcome to the Polycom Community.

Not having seen any logs to verify this it may be a limitation of your yet unknown SIP switch.

 

Does your other yet unknown Phone manufacturer support Video Calls?

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 5
Highlighted
Occasional Visitor

Re: Opus Negotiation not happening

While I have an accepted solution, you have questions, and I'm happy to answer.

 

We're running asterisk 14.7.5, on FreePBX 14.  The other phone models are a mix of Unifi VoIP phones, and Grandstream 21xx series phones.  We also have a couple of Grandstream GXV 32xx phones, which can do both opus and video simultaneously (though I'm not a fan of the firmware/interface, personally).

Message 4 of 5
Highlighted
Polycom Employee & Community Manager

Re: Opus Negotiation not happening

Hello @Negative,

From the UC Software 5.4.0 Release Notes page 6:

 

  • The Opus codec is not available when you enable video on the VVX 500 or VVX 600 business media phones. If you want to use the Opus codec, disable video using the configuration file parameter video.enable.VVX500=0 or video.enable.VVX600=0. By default, these two parameters are enabled ‘1’, and you must manually set the value to ‘0’ to disable.


Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 5