Plantronics + Polycom. Now together as Poly Logo

Paging (i.e. auto answer) not working after upgrade to 4.x.x

SOLVED
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello SamF,

This post and the follow up references all discuss a completely different method and Parameters.

 

The UCS Admin Guide list:

 

call.autoAnswer.SIP

as follows:

 

VVX 1500 only. If 0, auto-answer is disabled for SIP calls. If 1, auto-answer is enabled for all SIP calls.

 

Above actually needs updating as it work for all VVX phones but not any of the other phones. 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 11 of 29
Frequent Advisor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Correct, it works on all VVX but not on the "legacy" Polycoms.

 

Message 12 of 29
Occasional Visitor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

On the Polycom SoundPoint IP SIP 3.2.x we used the following alert-info header value:

 


Alert-Info: Ring Answer.

 

 

We set our voip.prot.sip.alertinfo.1.value="Ring Answer" and then proceeded to set the se.rt. parameters.

 

Steffen is indicating that the SIP header should look like:

 

Alert-Info: info=Auto Answer

 

My question is if we wish to run both SIP 3.2.x and UC phones on the same system, will the older phones support the new Alert-Info: info=value header? Can anyone confirm this? It is disappointing Polycom would cease to support something so difficult to change. Any help is appreciated.

Message 13 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello gastonxpander,

welcome to the Polycom Community.

 

I am unsure if there is some kind of miss understanding but I do not understand your reply.

The community's VoIP FAQ contains this post here:

 

Oct 25, 2011 Question: How can I change my Ringtone or Ring in a special manner for a certain incoming call?

Resolution: Please check => here <=

 

Above clearly explains that the voIpProt.SIP.alertInfo.x.value is simply a text string and can be anything so you should see no difference between older SIP and newer UCS releases.

 

If this is still not clear please work with your Polycom reseller for further support.


Please ensure you always check the community FAQ and/or utilize the community search before posting any new topics or follow up post’s.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 14 of 29
Occasional Contributor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello,

 

I have been trying to use the auto answer feature. I am using Polycom 321's with firmware 4.1.0.85402.

I have added the following lines to my config files:

 

call.autoAnswer.H323="1"
call.autoAnswer.SIP="1"
call.autoAnswer.ringClass="answer"

 

 

For some reason it works intermittently, about one in a hundred calls will be auto answered.

Message 15 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello The Commodore,

welcome to the Polycom Community.

The last post before you replied explains in detail how to use the Auto Answer Feature.

 

The Parameter:

 

call.autoAnswer.H323="1"

as stated in the Admin Guide:

 

  • You can use this parameter for the VVX 500, 600, and 1500. If 0, auto-answer is disabled for H.323 calls. If 1, auto-answer is enabled for all H.323 calls. 

The Parameter:

 

call.autoAnswer.SIP="1"

 as stated in the Admin Guide:

 

  • You can use this parameter on the VVX 500, 600, and 1500. If 0, auto-answer is disabled for SIP calls. If 1, auto-answer is enabled for all SIP calls.

So both Parameters are completely irrelevant for this type of phone.


In addition UCS 4.1.0 for the SPIP is for LYNC only. The same is applicable for UCS 4.1.1

 

If you use standard SIP please use UCS 4.0.7


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 16 of 29
Occasional Contributor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello,

 

I added:

 

voIpProt.SIP.alertInfo.1.class="ringAutoAnswer"
voIpProt.SIP.alertInfo.1.value="Auto Answer"

 

to my config file and it soved my issue.

Message 17 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello all,

 

In case this ever comes up again the community's VoIP FAQ contains this post here:

Oct 25, 2011 Question: How can I change my Ringtone or Ring in a special manner for a certain incoming call?

Resolution: Please check => here <=


The above explains this in detail.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 18 of 29
Occasional Advisor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

FWIW, FreePBX now sends:

Alert-Info: Ring Answer

 

So if you are using that, then the incantation for your config file is:

 

 

<se>
    <se.rt>
      <se.rt.ringAutoAnswer se.rt.ringAutoAnswer.timeout="1" />
    </se.rt>
</se>
<voIpProt>
    <voIpProt.SIP>
        <voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="Ring Answer" />
    </voIpProt.SIP>
</voIpProt>

 

Note that the first bit is to set the ring before it autoanswers to 1 millisecond (essentially nothing), otherwise it rings once and then autoanswers.

 

Just in case anyone is trying to figure out why UC4 and FreePBX won't do Paging/Intercom any more. 

Message 19 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello wpns,

as already outlined in detail in my original reply with the link to the FAQ post using a SIP Header of ringAutoAnswer already instigates that the phone would "ring" before auto answering.

 

Simply using autoAnswer as described in the various Admin Guides would no longer ring.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 20 of 29