Plantronics + Polycom. Now together as Poly Logo

Parameters (such as cdp.enabled) not always changed via central provisioning

SOLVED
Highlighted
Occasional Advisor

Parameters (such as cdp.enabled) not always changed via central provisioning

Hello,

I am using a Polycom VVX 400 running 5.6.0.17.325.

My VVX 400 receives the correct VLAN ID via DHCP Option 129 and the Provisioning Server URL via DHCP Option 66.

I have been experimenting with the two values below in the provisioning file of my 3cx server:

        <device.net device.net.cdpEnabled.set="X">
        <device.net device.net.cdpEnabled="Y">

I noticed that some changes on the provisioning file are actually applied on the Polycom phone only after a factory reset, and not after a reboot or after I trigger a re-provisioning (via a check-sync event).

The scenario is the following:

1. Factory reset Polycom

2. <device.net device.net.cdpEnabled.set="1">  and  <device.net device.net.cdpEnabled="0">

3. After the initial provisioning-configuration, my VVX 400 has CDP set to "Disable". So far so good.

4. I change some setting on the provisioning file (MAC.cfg) on the server, so now we have:

<device.net device.net.cdpEnabled.set="0">
<device.net device.net.cdpEnabled="0">

5. Reboot the VVX 400. What i would expect, is that after the reboot the VVX 400 will request the provisioning files, ignore the CDP value (since <device.net device.net.cdpEnabled.set="0">) and use its default value for CDP, which is 1 / Enabled. But still, CDP remains disabled.

 

I tried the exact same steps for another value, <reg.1.lineKeys="4"> and the VVX 400 actually applied that value. Instead of registering the same extension once, it registered it 4 times. But it seems to ignore the values it receives for CDP, from time to time.

 

As per the UC 5.6.0 admin guide, Device Parameters, page 210:

"Note that some parameters may be ignored. For example, if DHCP is enabled, it will still override the value set with device.net.ipAddress"

I am wondering if CDP is one of those parameters, or if something else happens.

Any ideas what is going on?

 

Thank you,

George

 

Message 1 of 3
1 ACCEPTED SOLUTION

Accepted Solutions
Polycom Employee & Community Manager

Re: Parameters (such as cdp.enabled) not always changed via central provisioning

Hello @GeorgeT,

welcome to the Polycom Community.

The community's VoIP FAQ contains this post here:

 

Jul 25, 2013 QuestionHow can I setup certain Device parameters on my phone via a configuration file?

Resolution: Please check => here <=


Any device.X parameter combination requires at least at one point to have set the device.set="1" or it will not work.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 3
2 REPLIES 2
Polycom Employee & Community Manager

Re: Parameters (such as cdp.enabled) not always changed via central provisioning

Hello @GeorgeT,

welcome to the Polycom Community.

The community's VoIP FAQ contains this post here:

 

Jul 25, 2013 QuestionHow can I setup certain Device parameters on my phone via a configuration file?

Resolution: Please check => here <=


Any device.X parameter combination requires at least at one point to have set the device.set="1" or it will not work.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 3
Highlighted
Occasional Advisor

Re: Parameters (such as cdp.enabled) not always changed via central provisioning

Thank you for your prompt response Steffen.

Yes, this answer was actually the solution.

Please let me elaborate:

 

After the factory reset, the VVX 400 received the following parameters:

<device.net device.net.cdpEnabled.set="1">  and  <device.net device.net.cdpEnabled="0">

 

This forced the VVX 400 to set CDP to Disable.

During the next provisioning, it received <device.net device.net.cdpEnabled.set="0"> from the configuration server.

It makes more sense that in such case the VVX 400 keeps the previous value (CDP=0) than the default (CDP=1) which I would expect, this is why its value was not changed.

Order matters!

Best regards,

George

Message 3 of 3