Plantronics + Polycom. Now together as Poly Logo

Phones don't register in failover situation

JohnSeville
Visitor

Phones don't register in failover situation

Hi all.

 

Using DNS and SRV records for failover scenario (see attached file with screenshots and config files). Phones are all Polycom VVX310 with 5.4.3.2036 firmware version.

Phones should register via UDP in normal mode and when main SBC server fails, should register to secondary SBC server via TCP.  This is not working. We are getting the following messages when the primary SBC is OOS:

 

 

 
0613100159|app1 |4|00|Event: Unrecognizable key - appKeyFunc = 327, scan code 0
0613100505|sip  |4|00|Registration failed User: 112998, Error Code:480 Temporarily not available
0613100505|sip  |4|00|Failed to connect to [10.25.226.3:5060] : Error[Bad file descriptor]
0613100542|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
0613100614|cfg  |5|00|Prm|Parameter voIpProt.SIP.allowTransferOnProceeding requested type 2 but is of type 0
0613100614|sip  |5|00|listsize is 0
0613100614|sip  |5|00|CUser::CallNew Call SubscribeDialogBla absent
0613100619|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
0613100710|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
0613100750|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
0613100834|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
0613100925|sip  |4|00|Failed to connect to [10.25.226.3:0] : Error[Bad file descriptor]
 
Would appreciate any ideas/help.
 
TIA
1 REPLY 1
SteffenBaierUK
Polycom Employee & Community Manager

Re: Phones don't register in failover situation

Hello John,

welcome to the Polycom Community.

A working failover scenario is this configuration:

 

<failover voIpProt.server.1.address="sip.test" 
	voIpProt.server.1.retryTimeOut="500" 
	voIpProt.server.1.retryMaxCount="3" 
	voIpProt.SIP.tcpFastFailover="1" 
	voIpProt.SIP.authOptimizedInFailover="1" 
	voIpProt.SIP.failoverOn503Response="1" 
	voipProt.server.1.address="sip.test" 
	voipProt.server.1.port="0"
	voipProt.server.1.transport="DNSnaptr" 
	voipProt.server.1.failOver.reRegisterOn="1" 
	voipProt.server.1.failOver.onlySignalWithRegistered="1" 
	voipProt.server.1.failOver.failBack.mode="newRequests" 
	voipProt.server.1.failOver.failBack.timeout="600" 
	voipProt.server.1.failOver.failRegistrationOn="1" /

Please replace the sip.test with your DNS entry.

 

The voipProt.server.1.failOver.failBack.mode="newRequests" can be changed to "duration" in order for the voipProt.server.1.failOver.failBack.timeout="600" to come into play.

 

Using an SBC simply swap with voIpProt.SIP.outboundProxy.failOver

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 2