Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Occasional Visitor

Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

I have a few Polycom Soundpoint 501's that still are functional (about 15 or so in the back) and would like to use them, so far I have provisioned them using Option 66 with my internal provisioning link.

So far so good, phone I have added can call other extensions and can call out etc.
I see the phone is not officially supported, but a provisioning file exists already called Polycom SPIP (3.1.X) so I figured all would be well.

One pretty major issue, no button tone sounds whatsoever, no dialtone, no ringing while dialing.
The only real thing I am concerned about is the button tones, you can't make any selections if you hit an IVR if you can't tone.

I am certainly not a pro at this level of config for phones, can anyone point me in the right direction to what I can/should change or have a working provisioning file I can edit? The actual version of the phone is 3.1.3
 
What sections define dial sounds and do I need to load those onto the phone via tftp or are they already present but not configured?
 
Message 1 of 10
9 REPLIES
Polycom Employee & Community Manager

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Hello tgsfvs,

welcome to the Polycom Community.

 

The latest supported version for these end of life phones was SIP 3.1.8

The community's VoIP FAQ contains this post here:

 

Oct 7, 2011 Question: Phone unable to send DTMF to an IVR system or how to troubleshoot DTMF issues

Resolution: Please check => here <=

 

The above provides information on how to troubleshoot DTMF issues. You may want to check with a 3CX community on anything else.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 2 of 10
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

I've done some more looking into it and this does not appear to be a DMTF problem, the phone just literally is not loading any tones, even just testing the ringtones in the menu is completely silent but calls work.

 

I can silently call someone, when it connects I can hear them and they can hear me.

 

I was looking at the legacy files but am not sure which files contain the tones, is it the cfg or .ld files?

 

http://support.polycom.com/PolycomService/support/us/support/voice/soundpoint_ip/soundpoint_ip501.ht...

Message 3 of 10
Polycom Employee & Community Manager

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Hello tgsfvs,

the phone does not "load" any call progress or dial tones, it generates this locally via the DSP.

 

I suggest you do sa following:

 

  • Download the SIP 3.1.8 release
  • Factory restore the phone and provision from a separate FTP server and do not load any additional configuration
  • Test the phone

Please remember that the SPIP501 phones are very old now (if you provide the MAC I tell you when it was sold) so maybe its time to move on and purchase a modern phone before spending to much time on this.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 4 of 10
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Did you ever find a solution to this? I have the exact same problem. 

Message 5 of 10
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

The Legacy Polycom templates that 3CX ships are completely hosed. 

 

I've built a set of templates that resolved this issue for me. You can look at them, and modify for your own use:

https://github.com/tony722/3CXPolycomLegacy

 

Hope this helps,

 

Tony

Message 6 of 10
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

SOLVED: I was experiencing this very same issue, until i did this.

 

Factory default polycom 501 with 3.1.8 firmware | Dial Tones and key Tones Work

 

Provisioned with 3CX | Can make calls to extensions but No Dial or RingTones

 

Goto 3CX templates folder (C:\ProgramData\3CX\Instance1\Data\Http\Templates\phones)

 

Identify code within <se> </se> and <tone> </tone>

 

Repace with the code between <tone> </tone> and <sound_effects> </sound_effects> from the original 3.1.8 firmware sip.cfg file

 

Works instantly !

i noticed without the template fie loaded the phone tones worked great. so i identified and copied the potion of code which deals with tone/sounds and pasted over the tempate code.. works like a charm. 

 

hope it helps someone spend ess time than I spent tryign to figure it out. 

 

Message 7 of 10
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Dudes, thank you so much for the findings. 

i stuck at the same situation and with limited knowledge on sip.cfg config.

contacted 3CX support, CSR, head of support / training, nobody can tell me the answer / point me to this post.

 

they should know this and update the legacy Polycom template reather than confusing people.

 

now my legacy 301s / 501s can live for another few months before we ready to migrate to newer phones.

 

 

 

Message 8 of 10
Polycom Employee & Community Manager

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Hello @Andy-1 and all,

welcome to the Polycom Community.

The SoundPoint IP 501 was being discontinued and was no longer available for purchase since 08/20/2009. Support for the product was available until 08/20/2014. 

 

This was 9 years ago. Support for the 301 was stopped even earlier than this.

 

In addition the 3CX Version quoted by the original poster was also replaced by various newer versions since then.

 

Polycom and 3CX can only ensure to provide a certain level of compatibility with these old legacy phones.

 

A simple solution provided by myself was to provision the VVX phone from an FTP server and simply register to 3CX.

 

Using any currently supported models aka the VVX phones have no restrictions binding them to any files from the 3CX side.


Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 9 of 10
Highlighted
3CX
Occasional Visitor

Re: Polycom 501 Provisioning with 3CX v14 - No dialtones or touch tones but calls function

Hi all

First of all thank you for your feedback although some if it is trolled and unfair. So I will take the opportunity to clarify some things.

 

We at 3CX, are at the forefront to save costs. So not only we symphatise, but we also encourage users to keep stretching their working devices - servers, phones, network devices, mobiles anything that still works - for as long as it is an acceptable standard for normal operations. Also we encourage a strategy for this purpose together with Polycom for the simple reason that we all know the build quality of a Polycom phone is superior and that Polycom phones are built to last - so we know that users will attempt to squeeze as much as they can from their Polycom phones for long after they have been discontinued. This has been a historical fact in the VoIP World ever since. Heads down, we agree with trying to make the most of your phone so I would like to start off with the notice that we are on the same page on this one. 

@Andy-1

 

they should know this and update the legacy Polycom template reather than confusing people.

 

Polycom discontinued their device and stopped making firmware updates. But the integrator (3cx) is expected to go and magically update these templates for phones because Andy is using a combination of discontinued phones and 3CX versions which are technology of 2014. Does this sound right to you?  

 

There are 2 categories which all the engineers and developers worldwide have accepted (at least the majority have it seems). Supported and Community Driven. Your environment makes you 100% part of the community driven so please don't expect anything more. Just like we do with netcore, with github etc. Example: You cannot go to Ford or a Ford garage with an escort mk4 and expect or demand parts.

 

The right way to go about this, if you really want to make an improvement and reduce the confusion, is that you go back to the ticket you opened with 3CX support, show them  that you fixed the problem and propose a template modification. Then we will check, double check with Polycom, and if sustained, we might consider adding it to the main download. Like this other users like you can get the template with the fix and then you will be the driving force to help reduce the confusion. You become a valid contributor. This post does not qualify as valid contribution imo. 

 

Don't blame 3CX support. You chose to save costs and use the devices - fine, given you did not learn the sipcfg. You cannot then expect the same level of support and assistance as if the devices were still continued and in production. 3CX support did not not help you because you presented a discontinued device and to demotivate support more, a pbx version superseded by 2 full new modern versions-15 and 15.5. Maybe .. yes, you should have learnt the sip.cfg by now - why not? Many users had to get their hands dirty to extend the lifespan of their devices. Some food for thought.. 

 

Message 10 of 10