Plantronics + Polycom. Now together as Poly Logo

Polycom 670 Auto Answer

qasimkhans
Occasional Advisor

Polycom 670 Auto Answer

i have Polycom soundponint 670. 3288 ext is registered on line 1, which is standard line. 5801 on line 2 (which is auto answer) line. when 3288 line 1 on call and a call comes on 5801 line 2. it shows on phone and after 1 min phone put 3288 on hold and answer 5801. i am using UC Software Version 4.0.8.1608. please help me out here. Thakns.

Message 1 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom 670 Auto Answer

Hello qasimkhans,

welcome to the Polycom Community.

How are you resolving the Auto-Answer ? Via a SIP Header?

 

I did a quick test with this and normally a phone does not even ring for longer than a minute as it would send back a 603 Decline back to the calling party unless the call.offeringTimeOut parameter was changed.

 

I would suggest you contact your Polycom reseller so they can help you with the 1st Level troubleshooting and then open a case with Polycom support for you.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
qasimkhans
Occasional Advisor

Re: Polycom 670 Auto Answer

my dialplan is as below.

 

exten => 5801,1,SIPAddHeader(Alert-Info: info=Auto Answer)
exten => 5801,n,Dial(SIP/5801)
exten => 5801,n,HangUp()

 

please see following of my sip.cfg. please let me know if i am doing anything wrong in it. Thanks.

 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- PlcmConversionCreatedFile version=1.2 converted=Tue Aug 23 16:59:18 2011 -->
<polycomConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="polycomConfig.xsd">
<se>
<se.rt>
<se.rt.ringAutoAnswer.name="Auto Answer" se.rt.ringAutoAnswer.type="ring-answer" se.rt.ringAutoAnswer.timeout="500" se.rt.ringAutoAnswer.ringer="2" se.rt.ringAutoAnswer.callWait="6" se.rt.ringAutoAnswer.mod="1"/>
</se.rt>
</se>
<voIpProt> <voIpProt.SIP> <voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="Auto Answer"/> </voIpProt.SIP> </voIpProt> </polycomConfig>
Message 3 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom 670 Auto Answer

Hello qasimkhans,

As already replied in my previous post you should really contact your Polycom reseller so they can help you with the 1st Level troubleshooting and then open a case with Polycom support for you.

 

Stating the above I quickly loaded your configuration on a test phone and the 2nd call rings until I clear the first call.

 

It does not automatically place the first call on hold after one minute and I let it ring for about 1 minute and 30 seconds before clearing the 1st call.

 

In a standard configuration the phone would not ring for more than 1 minute as prior to that the call.offeringTimeOut parameter would kick in and send a 603 back to the SIP server.

 

So please work this with your Polycom reseller.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 7
qasimkhans
Occasional Advisor

Re: Polycom 670 Auto Answer

Thanks for your reply, Please note that i am using 2 different extensions. 3288 on Line 1 and 5801 on Line 2. Line 1 is standard extension and Line 2 is auto answer extension. If Line 1 is already on call and a call coming on Line 2 (auto answer line) then new call rings on phone for 1 min, after 1 min phone put 3288 Line 1 on hold and auto answer 5801 line 2. I have tested my above config on 3 phones but same result. please note that i am using UC software 4.0.8 Thanks. 

Message 5 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom 670 Auto Answer

Hello qasimkhans,

I used two different extensions and cannot reproduce this in my quick test.

 

As already mentioned twice now in my previous post you must contact your Polycom reseller so they can help you with the 1st Level troubleshooting and then open a case with Polycom support for you.

 

So please work this with your Polycom reseller.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 7
qasimkhans
Occasional Advisor

Re: Polycom 670 Auto Answer

i used following config which resolved the issue. so the actual problem with Auto Answer (case sensitive). i used auto-asnwer and now phone does not answer line 2. Thanks for your help.

 

 
 <se.rt.autoAnswer se.rt.autoAnswer.callWait="callWaiting" se.rt.autoAnswer.micMute="0" se.rt.autoAnswer.name="auto-answer" se.rt.autoAnswer.ringer="ringer2" se.rt.autoAnswer.timeout="1000" se.rt.autoAnswer.type="answer">     
</se.rt.autoAnswer>
 
<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="autoAnswer" voIpProt.SIP.alertInfo.1.value="auto-answer" voIpProt.SIP.alertInfo.2.class="default" voIpProt.SIP.alertInfo.2.value="">
     </voIpProt.SIP.alertInfo>

 

Message 7 of 7