Plantronics + Polycom. Now together as Poly Logo

Polycom Soundpoint 335 and TLS 1.2

Occasional Visitor

Polycom Soundpoint 335 and TLS 1.2

Hi,

 

I have some polycom 335s that we are trying to provision with TLS 1.2. Is this possible? 

Works with 1.0 but we are not sure if the 335s support 1.2. I have looked throught the forum and have not seen a definitive answer. Thank you. 

 

-Scott

Message 1 of 2
1 REPLY 1
Polycom Employee & Community Manager

Re: Polycom Soundpoint 335 and TLS 1.2

What software version is your IP 335 running?  UCS 4.0.13 introduced some options allowing you to configure the lowest TLS/SSL version to use for handshake negotiation for various applications (including provisioning).

 

If you are running UCS 4.0.13 or later you can use the following parameter and value to configure your phone to negotiate a minimum of TLS 1.2 for provisioning:

 

device.sec.TLS.protocol.prov="TLSv1_2"

 

If you want to configure this parameter via the WebUI (UCS 4.0.13 or later), navigate to Settings > Network > TLS, then expand TLS Applications, then change the TLS/SSL version for Provisioning to TLS 1.2:

 

2019-07-26_15-49-46.pngChanging minimum TLS version for provisioning.

The full parameter description from the UCS 4.0.13 release notes:
Configure the lowest TLS/SSL version to use for handshake negotiation between phone and provisioning. The phone handshake starts with the highest TLS version irrespective of the value you configure.

 

Here's a link to the UCS 4.0.13 release notes: https://support.polycom.com/content/dam/polycom-support/products/voice/business-media-phones/release...

Message 2 of 2