Plantronics + Polycom. Now together as Poly Logo

Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

BRM
Advisor

Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Hi,

 

I hope the informtion in the subject line is sufficient to initiate this discussion.

 

I've been trying to use SIP Authentication for BroadSoft XSI directory (we're on BW release 20 i.e. a supported platform for this feature) without any  luck. I have the below config in place:

 

 

dir.broadsoft.xsp.address="https://<correct_server_fqdn>"
reg.1.broadsoft.userId="<correct_user_id>"
feature.broadsoftUcOne.enabled="1"
reg.1.broadsoft.useXspCredentials="0"
feature.broadsoftdir.enabled="1"
feature.qml.enabled="1"

 

The server receives a request from the device without a username incorporate in the request uri:

 

10.217.11.20 - - [07/Dec/2015:15:57:20 +1100] "GET //com.broadsoft.xsi-actions/v2.0/user//directories/enterprise?firstName=Djm*&lastName=&number=&extension=&mobileNo= HTTP/1.1" 401 917 0 808 "-" "Microbrowser/1.1 PolycomVVX-VVX_500-UA/5.4.0.5841 Type/Application"

 

Is there something that I'm missing or if it's a known issue wherein the userid is not sent when using reg.1.broadsoft.useXspCredentials="0"?

 

The same set up works when using the xsp.username and xsp.password with reg.1.broadsoft.useXspCredentials="1". Moreover, devices of other brands, i.e. non-Polycom are able to access BW directory using  sip auth for xsi.

 

Please advise.

 

Regards

BRM

Message 1 of 18
17 REPLIES 17
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Hello BRM,

welcome back to the Polycom Community.

Using:

 

reg.1.broadsoft.useXspCredentials="0"

 

Unfortunately this parameter is missed in the Admin Guide but:

 

  • If enabled (default) the phone will use Broadsoft XSP credentials.
  • If disabled the phone will use SIP credentials from dir.broadsoft.regMap


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 18
BRM
Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Hi Steffen,

 

Thanks for the reply.

 

dir.broadsoft.regMap does fix the issue. However, can you please confirm that the broadsoft directory feature only allows access to the Enterprise directory and not the Group directory (more specifically in a Service Provider model)? If not, is it on the roadmap (and an ETA if possible, please)?

 

Regards

BRM

Message 3 of 18
VoIPonaught
Frequent Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Do we need to make any adjustments on BW to have authentication (SIP vs xsp) working?

 

May I ask for config with all parameters?

 

PS great to have this feature on Polycoms (as i has broadsoft directory on yealinks a while ago).

Message 4 of 18
VoIPonaught
Frequent Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

I got it working.

 

Sharing working config with the community:

 

 

<dir.broadsoft dir.broadsoft.regMap="1"
dir.broadsoft.xsp.address="[XSP_ADDRESS]"
dir.broadsoft.use XspCredentials="0"
reg.1.broadsoft.userId="[BWLOGINID]"
 reg.1.auth.userId="[BWAUTHUSER]"
reg.1.auth.password="[BWAUTHPASSWORD]" />

 

Also looks like we need 5.4 for the authentication to work properly (it didn't work for me on 5.3).

And SIP authentication has to be enabled in BW.

 

Message 5 of 18
VoIPonaught
Frequent Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Also is there a way to show all directory when entering * in the search field?

I noticed there's a limit of 50 contacts that would show.

Message 6 of 18
VoIPonaught
Frequent Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Looks like with the latest software (5.5.0) we can't authenticate anymore using this method.

Rolling back to 5.4.x solves the problem.

 

Is it a bug, or something must have changed?

Message 7 of 18
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Hello VoIPonaught,

In your last reply I could not see this:

 

reg.x.broadsoft.useXspCredentials 0 or 1

 

  • Set to 0 if registering lines with a server running BroadWorks R19 SP1 or later.
  • Set to 1 if registering lines with a server running BroadWorks R19 or earlier.

If this parameter is disabled, the phones use standard SIP credentials to authenticate.

 

Did you set this?

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 18
VoIPonaught
Frequent Advisor

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Steffen, thank you for the tip.

 

I have added this parameter:

reg.1.broadsoft.useXspCredentials="0"

 

to the phone's config.

On 5.4.4 Boradsoft directory works fine, but on 5.5.0 exactly same config causes authentication failure (I see 401 response on XSP).

 

Could it be a bug and in this case should I try to contact Polycom reseller to open an trouble ticket?

 

Thank you!

Message 9 of 18
SteffenBaierUK
Polycom Employee & Community Manager

Re: Polycom VVX 500 UCS 5.4.0 broadsoft directory using sip authentication for XSI

Hello VoIPonaught,

Yes please go ahead and get this raised.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 10 of 18