Plantronics + Polycom. Now together as Poly Logo

Polycom VVX Reboots and Loses Config

Occasional Advisor

Polycom VVX Reboots and Loses Config

Hi,

We've been having this issue for a while, and as we add additional endpoints, we are noticing it more, and would really love to finally solve it.

 

We have a combonation of 400 phones deployed to customers at the moment, using SIP. They consist of: VVX300, VVX301, VVX310, VVX311, VVX400, VVX401, VVX410, VVX411. All currently contain firmware 5.7.3.1797, but I noticed this issue since firmware 5.5. I cannot tell you if it happened prior to 5.5, we didn't have many Polycom phones deployed.

 

For provisioning, we set the phones to poll every 12 hours:

<prov.polling
prov.polling.enabled="1"
prov.polling.mode="rel"
prov.polling.period="43200">
</prov.polling>

About once a day, I end up finding out that about 3-5 phones rebooted on their own, right after they polled, and they boot up to where it just shows "VVX410" with an X to the left of it. Replace VVX410 with the appropriate model of the phone. When I try to login with the GUI, the administrator set password works, but everything else is pretty much left at factory default settings. All my entries are empty or default.

I don't know what to do anymore. I suspected maybe it was a provisioning server overload issue of some sort, but I ran httperf and had no issues. We also have no issues with any other phone manufacturers.

 

I attached app.log, boot.log, and audit.log and replaced my URL with a fake domain for security. We are provisioning with HTTP. I hit a dead end at this point, and don't know what more I can do to find the smoking gun and fix the issue. 

 

I also attached my nginx log file and applied a filter to only show results of my MAC address. You can see that the phone indeed contacts the provisioning server successfully around 11:46 AM and downloads the correct files, but at 9:45 am it only requests the main mac address cfg file and nothing more. The phone then rebooted to the 'frozen' state

 

I also attached an app.log from a phone that polled correctly and was wondering if this line of code is a reason for suspicion:

240214.704|osd  |4|00|CoreCom Error Detected: The remote host closed the connection. Note that the client socket (i.e., this socket) will be closed after the remote close notification has been sent. for the app:osd

If someone can help inch me closer to a solution, it would be fantastic

 

Thank you

3 REPLIES 3
Highlighted
Polycom Employee & Community Manager

Re: Polycom VVX Reboots and Loses Config

Hello @ja133,

 

welcome back to the Polycom Community.

Some or a couple of your old post(s) or reply(s) to them => here <= are still open / pending as you have not marked these as "Accept as a solution" or at least provided some form of feedback or answer.

If they are in this state nobody finding them via a community search will know if an answer or advice provided was useful and has maybe helped you.

Could you therefore kindly go over them and mark or answer as appropriate ?

If they are marked as "Accept as a solution" other users can find these easier and it helps them to utilise the community more efficiently. Please do not simply mark them without any type of feedback.
 

For your new issue not knowing what type of server or if this is any secure setup one thing that can be found is the failing phone has no NTP for a long period.

 

In addition the logs shows:

 

240148.254|cfg  |*|00|Prov|Starting to provision
1218064419|cfg  |4|00|Prov|File transfer failed due to curl error code:22 and respCode:456
1218064419|ec   |4|00|Got new timezone PST8PDT,J70/2:0:0,J308/2:0:0
1218064419|cfg  |4|00|Prov|File transfer failed due to curl error code:22 and respCode:456
1218064419|cfg  |4|00|Prov|Download of master configuration file failed
1218064419|cfg  |4|00|Prov|Trying to boot from existing configuration
1218064419|cfg  |4|00|Prov|Update configuration failed

Probably lowering Configuration and CURL and COPY to Event 3 provides more details to this but there is something with your server.

 

A wireshark trace via a spanned port may prove additional details.

 

If other community members or the community search won't provide you any further the next step is to raise a ticket.

In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

Westcon sold both the 0004f2d60693 and 0004f2c12fab back in around 31/03/2015 so the units are no longer within warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 4
Occasional Advisor

Re: Polycom VVX Reboots and Loses Config

Thank you, I updated my previous post with a solution. Back to this, however, I will consult with my developers regarding this being a possible server issue and will report back with additional questions. Doubt it's related to the time though, and regular HTTP is in use.


One question that does come to mind is the time. Looking through the admin manual, it states that by default, sntp syncs every 86400 seconds (24 hours) so I therefore do not have a setting for tcpIpApp.sntp.resyncPeriod in my config. Where/how can you tell that the time of the phone was way off? The time on my server was in a different time zone. The times on all the phones also show the correct times.

Message 3 of 4
Polycom Employee & Community Manager

Re: Polycom VVX Reboots and Loses Config

240148.254|cfg  |*|00|Prov|Starting to provision

This is Unix time

 

Replied from a mobile device 




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 4