Plantronics + Polycom. Now together as Poly Logo

Push error 405

SOLVED
jgranade
Occasional Contributor

Push error 405

I'm trying to get Push working on VVX 500 & 600 but both return "405 Method Not Allowed".  UCS version is 5.4.2.2834.  Below is what I'm passing which I took right from the community posts on what should work.

 

curl --digest -u push:push -d "<PolycomIPPhone><Data>tel:\\1234567890</Data></PolycomIPPhone>" --header "Content-Type: application/x-com-polycom-spipx" http://192.168.x.x/push

I've tried getting logging to give some clue but so far nothing.  I changed /push logging to Debug and set global logging level to Debug but nothing is recorded when it returns that "405 Method Not Allowed".    I've set "Allow Push Messages" to 'All' and set a user/pass.  

 

apps.push.messageType="5"
apps.push.username="push"

 

It gives that"405 Method Not Allowed" immediately and even if I put the wrong password, it still give the 405 error rather than "401 Unauthorized".  Am I missing a step to get Push Applications to work?

Thanks,


John

Message 1 of 5
1 ACCEPTED SOLUTION

Accepted Solutions
jgranade
Occasional Contributor

Re: Push error 405

I figured this out.  It actually works with https but not http.  I couldn't find a setting in the GUI for this but in provisioning you need to set <apps apps.push.secureTunnelRequired="0" />.  The Web Application Developer's Guide says 0 is the default but that must have recently changed.  So your options are either use https to push or set the secureTunnelRequired to 0 so you can use http.

 

I hope that helps someone else.

 

John

View solution in original post

Message 2 of 5
4 REPLIES 4
jgranade
Occasional Contributor

Re: Push error 405

I figured this out.  It actually works with https but not http.  I couldn't find a setting in the GUI for this but in provisioning you need to set <apps apps.push.secureTunnelRequired="0" />.  The Web Application Developer's Guide says 0 is the default but that must have recently changed.  So your options are either use https to push or set the secureTunnelRequired to 0 so you can use http.

 

I hope that helps someone else.

 

John

View solution in original post

Message 2 of 5
Joe T
Frequent Visitor

Re: Push error 405

John,

 

Thanks for posting the problem, and solution to it.

 

It helped me troubleshoot a similar problem I was having with a VVX 410. Was trying to poll the phone state (and use push messages) and was receiving 404: Page Not Available on every page I requested. Switched to HTTPS, and it started working. Checking the config now.

 

Thanks,

 

Joseph

Message 3 of 5
Andrey Zakharov
Frequent Visitor

Re: Push error 405

Did anyone figure out how to make VVX-500 with 5.4.3.1014 work with HTTP?

HTTPS seems to work, but not HTTP, although I set up apps.push.secureTunnelEnabled apps.push.secureTunnelRequired to 0 and enabled HTTP/HTTPS on my phone (Settings - Advanced - Web Server Configuration).

Message 4 of 5
SteffenBaierUK
Polycom Employee & Community Manager

Re: Push error 405

Hello Andrey Zakharov,

welcome to the Polycom Community.

As already explained this needs the following to be enabled if CURL via HTTP is being used:

 

apps.push.secureTunnelRequired="0"


You can check your Logs for errors as a wrongly formatted URL may cause this 405 Error:

 

0805160522|push |4|00|PushParserC::parseDoc: Bad document - priority attribute is not proper: <Data priority=All>Key:Status</Data></PolycomIPPhone>

 

It is important that the string is correctly formatted and my FAQ => here <= shows some examples.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 5