Plantronics + Polycom. Now together as Poly Logo

Pushing Play action to VVX 600 Does Not Work

Highlighted
Occasional Contributor

Pushing Play action to VVX 600 Does Not Work

Good Evening,

 

I'm attempting to push the following to a VVX 600 running 5.3.0.12074 with a content-type of application/x-com-polycom-spipx :

 

<PolycomIPPhone><Data priority="Critical">Play:tm4_test.wav</Data></PolycomIPPhone>

 

I see the VVX request the file from the server and the server returns a 200 status. However, the Polycom has the following in the logs:

 

0812212833|brow |4|00|Download file name error 299

 

Other types of pushes work fine on the VVX 600 (such as pushing HTML to the mb). Also, the above works on a Polycom 650 running 4.0.5.4233.

 

Any advice or information about what the error 299 actually means would be greatly appreciated.

 

Thanks,

Dave

Message 1 of 9
8 REPLIES 8
Highlighted
Polycom Employee & Community Manager

Re: Pushing Play action to VVX 600 Does Not Work

Hello Dave,

welcome to the Polycom Community.

The MicroBrowser on the SPIP Phones is different to the one on the VVX Phones.

 

I would suggest you lower the log.level.change.brow="0" and the general logging level log.render.level="0" to see if this offers any more details.

 

I could not find anything internally with such error message.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 9
Highlighted
Occasional Contributor

Re: Pushing Play action to VVX 600 Does Not Work

Steffen,

 

Thank you for the reply. I got some additional information by setting the push logs to Debug.

 

After the initial failed attempt to push the Play action, if I try again, I get the following message:

 

-------
 
0814232009|push |2|5546|wappPushHandlerC::Handle: <PolycomIPPhone><Data priority="Critical">Play:tm4_test.wav</Data></PolycomIPPhone>
0814232009|push |2|5546|PushManagerC::processPushObject: Play:tm4_test.wav

0814232009|push |3|5546|Pushing URIs: Play:tm4_test.wav
0814232009|app1 |1|5546|AppC::turnOnBacklight: IsUserInput: 1
0814232009|push |3|5546| Last push message is in process, current message with priority 3 is in queue
0814232009|push |3|5546| Last push message is in process, current message with priority 3 is in queue
0814232009|push |3|5546| Last push message is in process, current message with priority 3 is in queue
0814232009|brow |0|5546|webLayoutMgr CWebLayoutMgr::event 43
0814232009|brow |0|5546|[CWebNetworkAccessManager::createRequest] Requested url is http://<hostname>/polyapp/tm4_test.wav
0814232009|brow |4|5546|Download file name error 299
0814232010|push |3|5546| Last push message is in process, current message with priority 3 is in queue
0814232010|push |3|5546| Last push message is in process, current message with priority 3 is in queue
0814232011|push |3|5546| Last push message is in process, current message with priority 3 is in queue
 
-------

 

While it says priority 3 in the above message, previous instances of this say priority 1 and it was pushed with the "Critical" priority.

 

Regards,

Dave

Message 3 of 9
Highlighted
Polycom Employee & Community Manager

Re: Pushing Play action to VVX 600 Does Not Work

Hello Dave,


nothing jumps out.

 

Maybe try the file name without the underscore ?

 

The next step would then be to raise this via your Polycom reseller with Polycom support.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 9
Occasional Contributor

Re: Pushing Play action to VVX 600 Does Not Work

Steffen,

 

Isn't it odd that the notification is in queue if it's already been processed (and failed), not to mention there are multiple messages instead of just one?

 

Regards,

Dave

Message 5 of 9
Highlighted
Polycom Employee & Community Manager

Re: Pushing Play action to VVX 600 Does Not Work

Hello Dave,

 

  • Last push message is in process, current message with priority 3 is in queue for example is Critical or High priority. 
  • Last push message is in process, current message with priority 1 is in queue for example is Normal priority

Important would be 2.

 

I would not pay to much attention to the log messages as usually they need to be looked at by our developers.

 

Would you be able to attach the WAV file you have used successfully ?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 9
Highlighted
Occasional Contributor

Re: Pushing Play action to VVX 600 Does Not Work

Steffen,

 

Sorry for the delay. Attached is the wav file.


Regards,

Dave

Message 7 of 9
Highlighted
Polycom Employee & Community Manager

Re: Pushing Play action to VVX 600 Does Not Work

Hello Dave,

 

prior to you attaching the file I had a quick play using FTP and HTTP and could only replicate using FTP.

 

Could you kindly raise a ticket via your Polycom reseller so we can look at this ?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 9
Highlighted
Occasional Visitor

Re: Pushing Play action to VVX 600 Does Not Work

Hi,

 

We are also trying to play wav file using VVX 500 simulator but it's not working.

We used "XML API Web Testing Tool" for this. Pushing text is working fine.

 

Also paging is not working, we have done all configuration.

 

Our simulator is registered with Cisco CUCM and audio is woking fine for call.

 

Regards,

Umesh

Message 9 of 9