Plantronics + Polycom. Now together as Poly Logo

SRTP....resume from hold causes no audio (related to RTP sequence numbers)

Occasional Contributor

SRTP....resume from hold causes no audio (related to RTP sequence numbers)

I have a Polycom 670/450 which does TLS/SRTP on the Internet leg of a call.   An SBC receives the SRTP and decodes it to RTP to transit to our PBX.

When I place a call on hold and later resume....the RTP sequence numbers restart.    I'm assuming that this confuses the SRTP decoding on the SBC and causes him to not decode or decode incorrectly.

I did some additional testing to confirm my theory.    I did normal RTP instead of SRTP and we don't experience the problem.

I'm working with the SBC vendor to look at this problem, but wonder if there is anything on the phone to change the sequence number/RTP flow to not exhibit this problem.

 

Thanks for any input

Message 1 of 6
5 REPLIES 5
Highlighted
Polycom Employee & Community Manager

Re: SRTP....resume from hold causes no audio (related to RTP sequence numbers)

Hello Scott,

what Software Version are you running ?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
Highlighted
Occasional Contributor

Re: SRTP....resume from hold causes no audio (related to RTP sequence numbers)

4.02b

 

More data....I'm sending the SRTP to the SBC.   When I look at the unencrypted side of the SBC, he's not forwarding the RTP.   I think this helps prove my point that the SBC doesn't like something about the SRTP.

Message 3 of 6
Highlighted
Polycom Employee & Community Manager

Re: SRTP....resume from hold causes no audio (related to RTP sequence numbers)

Hello Scott,

 

as this is quite complex please raise a case with Polycom support.

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 6
Highlighted
Polycom Employee

Re: SRTP....resume from hold causes no audio (related to RTP sequence numbers)

I got same problem. But, i solve this on different way.

 

Did you check type of hold option?

 

Changing option that (voIpProt.SIP.useRFC2543hold="0" voIpProt.SIP.useRFC3264HoldOnly="1" voIpProt.SIP.useSendonlyHold="1") can be useful for you.

 

Best regards.

 

Message 5 of 6
Highlighted
Frequent Visitor

Re: SRTP....resume from hold causes no audio (related to RTP sequence numbers)

I solved similar issue(no voice after resume) with following options:

 

sec.srtp.holdWithNewKey="0" sec.srtp.resumeWithNewKey="0"

Message 6 of 6