Plantronics + Polycom. Now together as Poly Logo

Second Incoming Call Beep While On Phone

SOLVED
Highlighted
Occasional Advisor

Second Incoming Call Beep While On Phone

I can't seem to be able to silence the beep sound you hear when on 4.0.6 while on a call and a second call comes in on your line.  My client doesn't like the beep because it mutes the inbound audio of the person for about a second on the other end.

 

I tried changing call.callWaiting.ring="silent" to silent but it still creates a beeping sound; regardless which value I select.  The only way I have been able to get rid of it is by changing call.callWaiting.enable="0" (like below) but this now prevents the phone from ringing at all even when not inuse.

 

<call.callWaiting call.callWaiting.enable="0" call.callWaiting.ring="silent">

 

I assume I am modifying the wrong parameter.  What parameter should I be changing to get ring of the beep sound you hear (on speakerphone or handset) while the phone is in use and a second call comes inbound?

 

Message 1 of 5
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: Second Incoming Call Beep While On Phone

Hello Aeudian,

 

thanks for clarifying this.

 

In this case the se.rt.<ringClass>.callWait parameter is being used.

 

The permitted values in this pecial case are callWaiting, callWaitingLong or precedenceCallWaiting or as mentioned in the Admin guide the call waiting should match one defined in Call Progress Tone Pattern Names.

 

The default call waiting tone is callWaiting. .

Above is, to my knowledge, working as designed and would require a feature request. This is described in the FAQ.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 4 of 5
4 REPLIES 4
Highlighted
Polycom Employee & Community Manager

Re: Second Incoming Call Beep While On Phone

Hello Aeudian,

welcome back to the Polycom Community.

  • Are you sure that your configuration file is actually accepted by the Phone ?
    Did you make a backup and check that it is there?

  • What Phone are you testing this agains ?

I just did a quick test using UCS 4.0.6.0711 using:

 

<callWaiting call.callWaiting.ring="silent" />

On a second call the phone  (SPIP650) does not play any tone.

 

If this is not the case for yourself please raise this via Polycom support.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 5
Highlighted
Occasional Advisor

Re: Second Incoming Call Beep While On Phone

 

Steffen,

 

Thanks for responding.  We are using SPIP650 with UCS 4.0.6.0711.

 

I figured out what the cause of the issue is however I'm not sure how to fix it.  The settings I had and you provided are correct and work.  The problem is being caused by me adjusting the SIP Header information to change the ring on the phone to be unique. 

 

 

exten => 1,n,SIPAddHeader(Alert-Info: Receptionist)

 

If I comment out this line the beep goes away and becomes silent.  How can we honor the silent while changing the ring to be unique if the phone is idle?  I assume my issue is here se.rt.custom9.callWait="callWaiting" but I am not sure what to set the values to?

 

<se.rt.custom9 se.rt.custom9.callWait="callWaiting" se.rt.custom9.micMute="0" se.rt.custom9.name="Receptionist" se.rt.custom9.ringer="ringer16" se.rt.custom9.timeout="2000" se.rt.custom9.type="ring">
</se.rt.custom9>

 

<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="10" voIpProt.SIP.alertInfo.1.value="Inbound Ring Alert" voIpProt.SIP.alertInfo.2.class="4" voIpProt.SIP.alertInfo.2.value="Ring Answer" voIpProt.SIP.alertInfo.3.class="custom9" voIpProt.SIP.alertInfo.3.value="Receptionist">
</voIpProt.SIP.alertInfo>

 

Thanks.

 

 

Message 3 of 5
Highlighted
Polycom Employee & Community Manager

Re: Second Incoming Call Beep While On Phone

Hello Aeudian,

 

thanks for clarifying this.

 

In this case the se.rt.<ringClass>.callWait parameter is being used.

 

The permitted values in this pecial case are callWaiting, callWaitingLong or precedenceCallWaiting or as mentioned in the Admin guide the call waiting should match one defined in Call Progress Tone Pattern Names.

 

The default call waiting tone is callWaiting. .

Above is, to my knowledge, working as designed and would require a feature request. This is described in the FAQ.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 4 of 5
Highlighted
Occasional Advisor

Re: Second Incoming Call Beep While On Phone

Removing se.rt.<ringClass>.callWait worked.

 

I didn't know if it would default to on if the command wasn't there.

 

Thanks again.

Message 5 of 5