Plantronics + Polycom. Now together as Poly Logo

SoundPoint 320 stuck

SOLVED
Highlighted
Occasional Contributor

SoundPoint 320 stuck

I just plugged an older SountPoint 320 into my new network where I have a new provisioning server and DHCP option set for autoconfiguration. It upgraded to the latest boot rom, but now is in a reboot loop saying "Error, application is not present!"

 

Logs on the HTTP-based provisioning server show that it downloads the boot rom and a config file (and that, combined with having auto-upgraded to the latest boot rom suggests that it is successfully getting the DHCP option), but doesn't attempt to load the SIP application.

 

10.10.155.212 - - [21/Oct/2016:15:57:28 -0700] "GET /provision/2345-12200-002.bootrom.ld HTTP/1.1" 200 107215 "-" "FileTransport PolycomSoundPointIP-SPIP_320-UA/4.3.1.0440"
10.10.155.212 - - [21/Oct/2016:15:57:28 -0700] "GET /provision/0004f21da7ab.cfg HTTP/1.1" 200 24 "-" "FileTransport PolycomSoundPointIP-SPIP_320-UA/4.3.1.0440"

10.10.155.212 - - [21/Oct/2016:15:57:28 -0700] "PUT /provision/0004f21da7ab-boot.log HTTP/1.1" 405 172 "-" "FileTransport PolycomSoundPointIP-SPIP_320-UA/4.3.1.0440"

 

A bunch of 650s on the same network have no problem.

 

 

Message 1 of 5
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: SoundPoint 320 stuck

Solved - Once I got the log file successfully saved, I found "Prov|Could not get application name" in there.

 

Apparently the new provisioning server was missing:

 

<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="" MISC_FILES="" LOG_FILE_DIRECTORY="" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="">
</APPLICATION>


in the config files...

 

But for some reason the 650s didn't care.

View solution in original post

Message 2 of 5
4 REPLIES 4
Highlighted
Occasional Contributor

Re: SoundPoint 320 stuck

Solved - Once I got the log file successfully saved, I found "Prov|Could not get application name" in there.

 

Apparently the new provisioning server was missing:

 

<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="" MISC_FILES="" LOG_FILE_DIRECTORY="" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="">
</APPLICATION>


in the config files...

 

But for some reason the 650s didn't care.

View solution in original post

Message 2 of 5
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint 320 stuck

Hello matthewk4,

welcome to the Polycom Community.

The SPIP650 can upgrade to UC Software  4.0.x or 4.1.1 where the SPIP320 can only upgrade to UC Software 3.3.5 latest

 

Not knowing what Software you upgraded we are unable to comment.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 5
Highlighted
Occasional Contributor

Re: SoundPoint 320 stuck

The 320 had upgraded to BootRom 4.3.1.0440 and wiped the app. It failed to attempt to download the release 3.3.5 application "2345-12200-002.sip.ld" (or a combined "sip.ld") until the <mac>.cfg file contained <APPLICATION APP_FILE_PATH="sip.ld"/>

 

The 650s are also running BootRom 4.3.1.0440 and were somehow able to successfully load the release 4.1.1 application "2345-12600-001.sip.ld" without the APP_FILE_PATH set in the corresponding <mac>.cfg file(s)... which is why the missing APP_FILE_PATH had not been previously detected.

Message 4 of 5
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint 320 stuck

Hello matthewk4,


All official downloads come with a 000000000000.cfg which always contains this so I am somehow surprised.

 

In addition 4.1.1 is for LYNC only so please downgrade to 4.0.11 as I assume you want to run SIP

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 5