Plantronics + Polycom. Now together as Poly Logo

SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Highlighted
Occasional Advisor

SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

I have a SoundPoint 670 running 4.0.4.

 

After initial deployment it will download the <MACaddress>-directory.xml and load contacts into the phone. If I make changes on the phone it uploads the changes to the <MAC>-directory.xml to my FTP provisioning server just fine. However if I make changes on the provisioning server to the <MAC>-directory.xml file and reboot the phone the changes don't appear on the phone. In 3.X versions I could do this no problem.

 

This seems similar to this case: http://community.polycom.com/t5/VoIP/UC-4-01-directory/td-p/8134 but a little different.

 

Any ideas anybody?

 

This is the same for VVX500 650 and 670.

 

Message 1 of 11
10 REPLIES 10
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Hello TNT,

welcome to the Polycom Community.

We would need to see a ftp log to confirm that the phone is downloading the <mac>-directory file on a reboot.

 

I suggest you change the configuration log level to an event2 and then check your logs again.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 11
Highlighted
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Steffen,

 

Thanks for the reply. As strang as it sounds there is nothing in the logs about *-directory.xml.. nothing. I have changed logs to Level 2 as well as debug and rebooted the phone... nothing.

Message 3 of 11
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Hello TNT,

 

the cfg log level on the phone will show you the numbers being parsed in the phone.

 

Checking your Provisioning Servers logs should show you if the phone is actually attempting to load the directory.

 

An example from a case I recently troubleshot:

 

Line 298: 000026.138|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 301: 000026.142|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 310: 000026.154|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 318: 000026.168|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 336: 000026.202|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 337: 000026.202|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 352: 000026.232|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 355: 000026.236|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 368: 000026.266|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 370: 000026.270|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 372: 000026.272|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 386: 000026.304|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 393: 000026.320|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 396: 000026.324|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 397: 000026.324|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 400: 000026.332|cfg  |3|03|Dir|0x955dc380|Cannot add contact 
Line 404: 000026.340|cfg  |3|03|Dir|0x955dc380|Cannot add contact 

Above issue had duplicate numbers in the directory. This is shown at level 3 but level 2 is needed to show the numbers being imported.

 

For more details you may need to work with your Polycom reseller and/or Polycom support directly.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 11
Highlighted
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

I think I am making progress here...

 

When my phone boots up for the first few seconds it says NETWORK IS DOWN then that dissapears and the phone works perfectly.

 

Comparing this to the boot/app logs the network really should be up at this point because it is downloading CFG files that I am able to change and take effect on the phone.

 

Here is the gotcha, if I set the phone with a static IP, there is no NETWORK IS DOWN displayed and the <MAC>-directory.xml is updated.

 

This either.

Message 5 of 11
Highlighted
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Welp... that is it.....

 

If DHCP is enabled the phone boots and shows "network is down" for about 3 seconds then it goes away. The <MAC>-directory.xml is not downloaded as it seems it does it at this time.

 

If a static IP is set, everything works fine.

 

I can tell that it is in fact getting an IP before it shows "network is down" and it is pulling config files down off the prov server.

 

Any ideas anybody?

Message 6 of 11
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

I assume this is a bug?

Message 7 of 11
Highlighted
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

ok, even with that it nolonger works:

 

000012.396|cfg |5|03|Prm|Parameter acd.reg requested type 0 but is of type 2
000012.406|sip |*|03|Fast Boot Measurement Point: Ready for Call, uptime: 12.406 sec.
000012.408|app1 |*|03|Ctx [0] Registered [false]
000012.528|dns |4|03|doDnsLookupForList: given NULL hostname in task tSntpGet
000012.558|app1 |*|03|Ctx [0] Registered [true]
0618152509|copy |4|03|Error ending zlib (-3)
0618152509|utilm|4|03|uBLFCompressed: StdError 0 when decompressing file /ffs0/local/local-directory_xml.zzz
0618152509|cfg |4|03|Edit|Error 0x3d0002 loading local cfg /ffs0/local/local-directory_xml.zzz
0618152510|utilm|4|03|uBLFCompressed: StdError 0 when decompressing file /ffs0/local/local-directory_xml.zzz
0618152510|cfg |4|03|Edit|Error 0x3d0002 loading local cfg /ffs0/local/local-directory_xml.zzz
0618152511|cfg |*|03|Prov|Starting to update 2345-12670-001.sip.ld
0618152512|cfg |*|03|Prov|Starting to update sip.ld
0618152520|cfg |*|03|Prov|Setting device parameters from configuration files.
0618152520|cfg |*|03|Prov|Finished updating configuration

Message 8 of 11
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Hello TNT,

 

I did a quick test with a SPIP650 running UCS 4.0.4

 

  • Factory defaulted the phone and booted the Phone and it loaded a prepared <mac>-directory.xml and showed the 3 contacts

  • Manually added a contact via the phone and it uploaded its modified <mac>-directory.xml

  • Manually modified the <mac>-directory.xml on the Provisioning Server and rebooted the phone via Menu => Settings => Basic => Restart the Phone

  • Manually modified the <mac>-directory.xml on the Provisioning Server and rebooted the phone via Menu => Settings => Advanced => Reboot the Phone

  • Manually modified the <mac>-directory.xml on the Provisioning Server and rebooted the phone via unplugging of the Ethernet cable

In all the above , if the Phone was restarted, it would display the Network Message and then simply load the file.

 

I believe there is an issue on your end and as already mentioned the next step would be contacting your Polycom reseller and/or Polycom support directly.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 11
Highlighted
Occasional Advisor

Re: SoundPoint 670 <MAC>-directory.xml RE-Download OR Update after initial

Well it seems like it is something on my end.... I only have two files plus the directory file.

 

------------<MAC>.cfg--------------------------

<?xml version="1.0" standalone="yes"?>

<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="sip-basic.cfg, site.cfg" MISC_FILES="" LOG_FILE_DIRECTORY="logs" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="" USER_PROFILES_DIRECTORY="" CALL_LISTS_DIRECTORY="">

------------<MAC>.cfg--------------------------

 

------------<MAC>-phone.cfg--------------------------

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Mink 4.0.4.2906 17-Apr-13 23:21 -->
<!-- Created 18-06-2013 15:23 -->
<PHONE_CONFIG>
<OVERRIDES
device.auth.localAdminPassword="456"
device.auth.localAdminPassword.set="1"
device.set="1"
device.sntp.gmtOffset="-25200"
device.sntp.serverName="0.pool.ntp.org"
dialplan.digitmap="[2-9]11|0T|+011xxx.T|0[2-9]xxxxxxxxx|+1[2-9]xxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxxT"
dialplan.digitmap.timeOut="3|3|3|3|3|4|4|5|5|5|5|5"
feature.presence.enabled="1"
feature.urlDialing.enabled="0"
pres.idleSoftKeys="0"
tcpIpApp.sntp.address="0.pool.ntp.org"
tcpIpApp.sntp.daylightSavings.enable="0"
tcpIpApp.sntp.gmtOffset="-25200"
tcpIpApp.sntp.gmtOffset.overrideDHCP="1"
up.idleBrowser.enabled="1"
call.missedCallTracking.1.enabled="0"
msg.mwi.1.callBack="*1"
msg.mwi.1.callBackMode="contact"
reg.1.address="101"
reg.1.auth.password="mypassword"
reg.1.auth.userId="101"
reg.1.bargeInEnabled="1"
reg.1.displayName="Ext. 101"
reg.1.label="Ext. 101"
voIpProt.server.1.address="123.123.123.123"
voIpProt.server.1.expires="100"
bg.hiRes.color.selection="3,3"
/>
</PHONE_CONFIG>

------------<MAC>-phone.cfg--------------------------

Message 10 of 11