Plantronics + Polycom. Now together as Poly Logo

SoundPoint IP 550 - Primary Image Corrupt

Highlighted
Occasional Visitor

SoundPoint IP 550 - Primary Image Corrupt

My IP550 was running 3.x SIP software, and I decided to upgrade to the newer 4.x software. Part of what prompted this is that the provisioning host previously used no longer exists, and I didn't have my current configuration files, so I decided to start over.

 

Steps taken:

 

1. A new, empty FTP root was created, and the phone settings updated to use the new host.

2. I extracted _only_ the contents of https://downloads.polycom.com/voice/voip/uc/Polycom-UC-Software-4.0.15-rts22-release-sig-combined.zi... in side of it.

3. I observed the new SIP application being downloaded, but after it self rebooted, this process would repeat indefinitely. I checked the logfile it uploaded, and saw a "Error: file does not contain a compatible image" error.

4. After googling my error message, I read that an "Upgrader" was needed for the upgrade to 4.x UC software to work. That led me to downloading this: http://downloads.polycom.com/voice/voip/uc/SoundPoint_IP_BootROM_4_4_0_Upgrader_release_sig.zip

5. I extracted the upgrader, noting that BootROM images were contained within.

6. After rebooting, I observed the BootROM update process begin. Shortly after, the phone now continually cycles every few seconds displaying:

 

"Primary Image Corrupt!

Reflashing Image from Backup!"

 

This cycle repeats every few seconds, along with various LED light patterns. No buttons appear to offer any sort of response, and I can confirm from provisioning FTP that no activity is occurring (no logins, file fetches/uploads, etc). Removing power and re-applying, it immediately returns back to this error message, self-restarting every 5-10 seconds.

 

How can I recover the phone?

Message 1 of 3
2 REPLIES 2
Highlighted
Polycom Employee & Community Manager

Re: SoundPoint IP 550 - Primary Image Corrupt

Hello @mcldb ,

 

Welcome to the Poly Community.

In my 12 years with Polycom, I have never seen this go wrong and/or seen this error message. I cannot find any ticket internally with this error. A Google search also does not show any other post with this error and all I can find is the code when we added this.

 

I can only assume there was a loss of power or a firewall issue as for example >here< but to answer your original question there is no way an end-user could fix this.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 3
Occasional Visitor

Re: SoundPoint IP 550 - Primary Image Corrupt

Thank you Steffen. Yes, I thought it was strange that there were basically zero Google results for this error message, which led me here. For what it's worth, the FTP service hosting these files is internal on my network, and I was actively engaged with the host watching transfer logs while things were running. I'm confident the phone didn't lose power, at least to the degree that it wasn't physically touched and no other devices had a power interruption.

 

In any event, it sounds like it is not recoverable. Well, I've enjoyed the 10 years or so I've had it!

Message 3 of 3