Plantronics + Polycom. Now together as Poly Logo

SoundPoint IP 650 lockups

SOLVED
Polycom Employee & Community Manager

Re: SoundPoint IP 650 lockups

Hello Nick,

the only way to determine if you are facing the same issue as the original posters is to raise a ticket with Polycom support so we can analyze the data.

 

Without this a fix that you hope for may not address your individual issue.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 31 of 45
Valued Contributor

Re: SoundPoint IP 650 lockups

I am pleased to announce that, by my testing, this issue has been completely resolved in the UC 4.0.7 software released today (issues VOIP-93121 and VOIP-93082 may have both been involved, but it is unclear to me from the descriptions given to them in the release notes which one was ultimately the fix for the issue I reported).

 

I re-ran my stress-test scripts against a 650 with 1 sidecar attached and 19 BLFs configured on it running 4.0.7.2514, and it didn't break a sweat.  The memory usage did not climb and climb and climb as it would before.  With 4.0.6, this same script would crash a phone in a couple of minutes.  I ran the script for over 2 hours and memory utilization didn't budge.  Even more importantly, the phone continued to function perfectly fine after I terminated running the script.  The UC software finally appears to be able to gracefully take a beating insofar as the number of incoming SIP messages per second goes.

 

My thanks to Polycom for delivering a fix.

 

-- Nathan

Message 32 of 45
Polycom Employee & Community Manager

Re: SoundPoint IP 650 lockups

Hi Nathan,

 

thanks for the feedback and the patience.

 

Best Regards

 

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 33 of 45
Occasional Advisor

Re: SoundPoint IP 650 lockups

I am seeing the same problem again in version 4.1.1.  Phone hard locks and you can not even ping it after the phone has been running for about 1-2 minutes.  A hard reset brings the phone back up and it will last another 1-2 minutes.  4.0.3 seems to be the only firmware that will work for us on 3cx...but the EHS headsets do not work.  The fix for the headsets is to upgrade which crashes the phones.

Message 34 of 45
Valued Contributor

Re: SoundPoint IP 650 lockups

I realize that Polycom's software versioning can be confusing (understatement of the year...they really should change/fix this; it's ridiculous), but spending a few minutes on the support web site would answer your question.  The 4.1.x train for Soundpoint 3xx/4xx/5xx/6xx is for Microsoft Lync environments only.  4.0.x continues to be maintained for pure SIP environments.  Steffen also pointed this out in an earlier response in this very same thread to somebody else.

 

As I also thought I made clear in my earlier response in this thread, 4.0.7 is the version that these bugs were finally fixed in.  I tested this myself and am now running 4.0.7 in our organization with no problems.  I am quite sure that if you upgrade to 4.0.7, and the underlying cause for your problems was the same as mine, that you will find your crashes gone as well.

 

4.1.1 is an older release (June 5th) than 4.0.7 (July 25th).  The bug was not fixed before 4.1.1 was released, so therefore it does not have the fix.  Also, you are not using Microsoft Lync, you are using 3CX, therefore you shouldn't be using this release anyway.

 

I cannot speak to the headset problem you bring up.  But odds are good that if the headsets you are using work with 4.1.1, they will probably also work with 4.0.7.

 

-- Nathan

Message 35 of 45
Occasional Advisor

Re: SoundPoint IP 650 lockups

I mention 4.1.1 because that is now the recommended firmware from 3cx.  Though I installed it yesterday on a phone and ended up with a similar problem to 4.0.5....hence why I downgraded to 4.0.3 and asked the question here thinking maybe someone else had tried 4.1.1

 

Sorry to disturb your thread.

Message 36 of 45
Valued Contributor

Re: SoundPoint IP 650 lockups


@CrashDodson wrote:

I mention 4.1.1 because that is now the recommended firmware from 3cx.


Then they are wrong and leading you astray, and as a customer of theirs, you should tell them so and get them to correct/update their recommendation!  4.1.x shouldn't be used by anybody other than Microsoft Lync customers.  Although 4.1.x *can* work with SIP, because it is only certified by Polycom to be used with Lync, I doubt that Polycom extensively tests/QAs 4.1.x releases for non-Lync systems.  3CX is doing themselves (their support department) and their customers a disservice by recommending it.

 

Again, 4.1.1 came out after 4.0.6 but before the bugs in question were fixed, so it doesn't really make sense to expect the problems to be gone in that version. :)  4.0.7 is the release you should be running.  Regardless of what 3CX recommends that you run, please just try 4.0.7.  If it still doesn't work for you, then that would be fascinating to know.

 

Good luck,

 

-- Nathan

Message 37 of 45
Highlighted
Occasional Advisor

Re: SoundPoint IP 650 lockups

I posed the question about 4.1.1 to 3cx...they are now testing 4.0.7.  I have 4.0.7 deployed to one location so far and no lock ups reported.  I have not yet tried the EHS headsets to confirm if it resolves that issue for me as well. 

 

Thanks for your help.

Message 38 of 45
Polycom Employee & Community Manager

Re: SoundPoint IP 650 lockups

Hello CrashDodson,

I forwarded this discussion to my 3CX counterparts and they are interested who from 3CX or where the statement comes from to use UCS 4.1.1 ?

 

Their own support site => here <= only list's UCS 4.0.7


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 39 of 45
Occasional Advisor

Re: SoundPoint IP 650 lockups

Hi I have 4.0.7 on my 650 which has two side cars with speed dials using the BLF feature.  My clients have been complaining of the same issue with Lag and the need to press a button multiple times before it runs so i am not sure why I am still experiencing the issue if 4.0.7 resolved the matter.

 

Note that originally upgraded from a 3.X version, however after the upgrade we did not perform Reformat of the Filesystem.  Is that part of the process 100% necessary, I figured that during the upgrade of the software it formats on its own.  Can someone correct me if I am mistaken.  Is it similar in a Windows installation that doing an upgrade can result in a slower machine as it tried preserving and upgrade things rather than starting fresh?

 

My only doubt about the above is that I am pretty sure during the upgrade process I thought i remember it saying that its formatting the device. So is skipping the Reformatting of the device after upgrade going to cause the preservation of older code and create memory leaks and other issues?

 

Any advice here would be great because 4.0.7 is still happening on both my Polycom 650 devices which are using two side cars each.

 

thank you

Message 40 of 45