Plantronics + Polycom. Now together as Poly Logo

Soundpoint 650 issue

Occasional Visitor

Soundpoint 650 issue

I don't have an idea who can help me with this issue. 
I have Polycom Soundpoint  IP-650 and I'm getting issue when I'm trying to log in web interface.
First I'm getting IP address of the phone. Then I'm putting this address in address bar and it shows me login page. As I know standart password for IP-650 is "456" so I'm entering the password and it redirects me to the blank page (almost blank - see attached picture). I've tried everything including factory reset. Who can help me to figure out what's wrong with this phone?

Message 1 of 3
2 REPLIES 2
Polycom Employee & Community Manager

Re: Soundpoint 650 issue

Hello @false_alarm 

 

we do not know what your current software version is but most likely this is an issue with the browser.

 

Try another browser.

 

Best regards

 

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 3
Occasional Visitor

Re: Soundpoint 650 issue

It's really was a problem with the browser. I tried Chrome, Opera, Firefox, Tor, Yandex Browser and everything the same but it's working fine in Internet Explorer.  Thanks for the hint. I thought my phone is dead.

Message 3 of 3