Plantronics + Polycom. Now together as Poly Logo

Soundstation IP 5000 bootlooping after firmware update

Visitor

Soundstation IP 5000 bootlooping after firmware update

I've recently obtained 2 IP 5000 conference phones. After a little tinkering I've managed to provision one successfully, howeer I'm now trying to provision and register the second and have encountered a problem.

After introducing the device onto the network and logging onto it through the web I changed the admin and user passwords as per best practices, then updated the firmware to 14.0.13.1445, exactly as I did with the other device. For some reason though this device will now repeatedly do the following:

  1. Boot / Polycom Logo
  2. Waiting for network to initialize - Setup / About options
  3. Updating, please wait
  4. Polycom logo
  5. Loading application... option to Cancel
  6. Running...App = 64167f122b51-sip.ld
  7. Welcome Screen
  8. The main home screen with "Initializing network" at the top
  9. After connecting to the network, it will reboot the phone after about 3 seconds, and the process repeats

Having looked around online I've found the 1,3,5,7 method to reset the phone, but my problem is I don't have time to enter the new admin password before the phone reboots itself automatically, nor do I have time to change the password on the web portal before it reboots - Is there any way I can stop thjis happening?

Message 1 of 2
1 REPLY 1
Polycom Employee & Community Manager

Re: Soundstation IP 5000 bootlooping after firmware update

Hello, and welcome to the community!

 

It sounds like you initiated the software upgrade to 4.0.13.1445 via the Web Configuration Utility.  The instruction below assumes that is true.

 

In effort to stabilize the phone without a factory reset:

  1. During the boot procedure while the phone is "Loading application" press the 'Cancel' softkey.
  2. On the next screen press 'Setup' softkey before the phone autoboots.
  3. Use the administrator password to enter the boot setup.
  4. Using the keypad, navigate to the 'Provisioning Server' menu.
    1. Then scroll down and find 'Upgrade Server'.
    2. If 'Upgrade Server' has a value, it should reflect the path to the intended software files.  Edit and clear this value.
    3. Press the 'Exit' softkey until prompted to Save & Reboot.

This will clear the parameter which holds the upgrade server address (which gets configured when attempting a software upgrade via the Web Configuration Utility.)  If that field is already blank, or the above steps do not address the issue, you can factory reset the phone from the boot setup menu.

 

To factory reset the phone from the boot setup menu:

  1. From the main menu of the boot setup (where you end up after entering the admin password):
  2. Using the keypad, scroll down and navigate to the 'Reset to Defaults' menu.
  3. Then choose the 'Reset Settings' option.

If the phone is provisioning and is able to upload logs to the provisioning server, you may want to review the app and boot logs the phone is generating and search for "sip.ld" in those files.  You should find, logged by the curl module, the URL the phone is attempting to retrieve the software package from as well as a reason for any failures.

 

If the phone is attempting to retrieve the files from the Polycom Hosted Server--indicating the software update was initiated through the Web Configuration Utility, the URL will reflect our downloads.polycom.com domain.  Otherwise, you may see your own provisioning server address being used for the request.  If the log does not indicate a clear and resolvable reason for failure please feel free to post sanitized snippets of the log here for analysis (you can either attach a file or use the code tag.)

Message 2 of 2