Plantronics + Polycom. Now together as Poly Logo

Struggling to update IP335 and IP550

MorsePacific
Occasional Visitor

Struggling to update IP335 and IP550

I've tried, I really have. I feel like I've read every linked FAQ on this subject and I am still no closer to updating these phones.

Purchased a refurbished Soundstation IP550 and IP335 to use with Zoom. Gave them an IP, logged in and set the Zoom Provisioning path, but the phones wouldn't do anything.

The 550 is running 4.0.11.0583 and Zoom supports 4.0.14.1580, so I figured we should update the firmware first.

I've now spent most of the day and can't figure what I'm doing wrong.

 

Neither phone will connect to the Polycom Hosted Server.

 

I don't know if this is a problem with the FTP (though it is setup according to documentation) or with the phones themselves. I wish they would just talk to Polycom's Hosted Server and this wouldn't be an issue.

Wireshark shows the device sending a standard query to downloads.polycom.com, but then getting the error in the browser I highlighted above.

The same happens with provpp.zoom.us when set as the provisioning server, but again I don't know if that's just because the firmware is outdated and Zoom don't support it.

Message 1 of 3
2 REPLIES 2
SteffenBaierUK
Polycom Employee & Community Manager

Re: Struggling to update IP335 and IP550

Hello @MorsePacific ,

 

Welcome to the Poly Community.


Without logs we are unable to suggest anything.

 

Please ensure you always check the FAQ's and/or utilize the community search before posting any new topics or follow up posts.

 

May 11, 2018 Question: Why do I get a "Failed to fetch available software from the Poly hosted server" error message or able to download list but unable to upgrade/downgrade?

Resolution: Please ensure your firewall allows outbound network traffic as shown  => here <=


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 3
MorsePacific
Occasional Visitor

Re: Struggling to update IP335 and IP550

Thanks @SteffenBaierUK,

Our firewall wasn't the culprit here but our routing rules were. Posting an update in case anybody runs into similar issues; we have a third party network contractor right now so couldn't look into it directly at the time.

 

We are using Mitel phones which have to exit via Mitel's own egress device, and we had routing rules in place on the switches here that put any SIP device on a VLAN for that egress point.

Even with a manual configuration of the phones, traffic would not route correctly.

 

We had the rules switched off on one port, and the phones are now happily updating themselves.

Message 3 of 3