Plantronics + Polycom. Now together as Poly Logo

Trio USB Passthrough doesn't work for me

SOLVED
Highlighted
Occasional Advisor

Trio USB Passthrough doesn't work for me

Any ideas why I would be having an issue using the Trio USB Passthrough working on my Surface Book 2?   I can confirm that my configuration is correct because I can get the USB passthrough to work on a spare Dell Latitude laptop.  However the software installs, but just sits at "connecting to trio" on my Surface.  Is there a software conflict with other programs?  I've uninstalled every other Polycom app I had installed (Companion, PPCIP, RealPresence Desktop, etc.).  

 

Message 1 of 7
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Advisor

Re: Trio USB Passthrough doesn't work for me

I figured it out.  I didn't realize that the Poly USB application had to have firewall exceptions... I had assumed all network traffic was going through the Trio and it was just a USB Device connection to my PC.  My local firewall was blocking the USB application from accessing the network.  I don't use the Windows Firewall so the application did not write the firewall rules to open the network traffic.  

Something to keep in mind when end-users use other firewall or endpoint security solutions.  

Thanks for that KB article 41117...  not sure why I couldn't locate it before.  

View solution in original post

Message 5 of 7
6 REPLIES 6
Highlighted
Trusted Contributor

Re: Trio USB Passthrough doesn't work for me

Hi @acelis,

 

which software version do you have on your Trio and which version is on you Surface? I have a Surface Book 2, too, and it runs nice and smooth. With all the other nice Apps from Poly in parallel. No issues. 

 

Message 2 of 7
Highlighted
Polycom Employee & Community Manager

Re: Trio USB Passthrough doesn't work for me

Hello @acelis 

 

as outlined by @mshu you have not provided sufficient information for us to try and troubleshoot.

 

I actually just created this:

 

Jan 30, 2020 Question: How can I troubleshoot Poly Passthrough issues using a Poly Trio?

Resolution: Please check >here<

 

The next step would be a service ticket via your Poly reseller.

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 7
Highlighted
Occasional Advisor

Re: Trio USB Passthrough doesn't work for me

@

5.9.2.7553.

On the Visual Pro I'm running the latest available version 6.2.2.1-600016. 

On my Surface Book I'm running the PolyTrioPass-Through version 1.0.0.0067. 

My Surface Book is running Windows 10 v1909.  

 

@SteffenBaierUK , 

I'm actually a reseller, and have had a support ticket open with Polycom but not getting any kind of response which is why I've had to resort to the Community Forums.  My open ticket is SR 1-15300238791. 

 

Message 4 of 7
Highlighted
Occasional Advisor

Re: Trio USB Passthrough doesn't work for me

I figured it out.  I didn't realize that the Poly USB application had to have firewall exceptions... I had assumed all network traffic was going through the Trio and it was just a USB Device connection to my PC.  My local firewall was blocking the USB application from accessing the network.  I don't use the Windows Firewall so the application did not write the firewall rules to open the network traffic.  

Something to keep in mind when end-users use other firewall or endpoint security solutions.  

Thanks for that KB article 41117...  not sure why I couldn't locate it before.  

View solution in original post

Message 5 of 7
Polycom Employee & Community Manager

Re: Trio USB Passthrough doesn't work for me

Hi @acelis 

 

I literally only created it due you posting here.

 

What Firewall are you using and would you mind posting a screenshot for everybody?

 

Did you leave a note in the case as I made the engineer aware that you have not had heard back?

 

Best regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 7
Highlighted
Occasional Advisor

Re: Trio USB Passthrough doesn't work for me

The firewall I was using is McAfee... but I'd assume the same issue would appear for others.  A screenshot of the exemptions I made is attached.