Plantronics + Polycom. Now together as Poly Logo

UCS 4.0.0 - impossible to update?

Frequent Advisor

UCS 4.0.0 - impossible to update?

Uh ok so I downloaded UCS 4.0.0 and was excited to take it for a spin on my IP550 (read the changelog -- whoa!  lot of work went into this one it seems...)

 

Then <whack> I was reading the upgrade procedure and it seems that you need to download the "BootROM 4.4.0 Upgrader" which will get you up to BootROM 5.0.0 ("Updater" is the new "BootROM") and without that you cannot upgrade to UC 4.0.  The catch is, while the sip.ld files are available on the public support page in both split & combined forms, the BootROM update seems to be only available via the PRC which is only for dealers.  Why??

 

I didn't buy my phones from a dealer and I am just using them at home, but I'm smart enough to provision my own stuff thank you.  I have a server set up here at home and all the DHCP/TFTP and FTP set up and working great for UCS3.3.2.  

 

So the question is: how am I supposed to get the Updater that I need to proceed?

Message 1 of 6
5 REPLIES 5
Polycom Employee & Community Manager

Re: UCS 4.0.0 - impossible to update?

Hello Luckman212,

 

neither the EMEA Page for the SPIP550 => here <= or the USA Page => here <= hold the UC Software 4.0.0.

 

This post => here <= and => here <= explains that UC S 4.0.0 can only be downloaded from the portal.polycom.com.

 

End Users do not have access to this and you will need to liaise with a Polycom Reseller.

 

You may have downloaded the Spectralink 8400 Version of the Software instead.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 6
Frequent Advisor

Re: UCS 4.0.0 - impossible to update?

No I am sure I didn't download the SpectraLink version.  You're right that there are no direct links to the software but if you type the URL manually the software is there.  So what are my options for getting UCS4 then?  Am I SOL?

Message 3 of 6
Polycom Employee & Community Manager

Re: UCS 4.0.0 - impossible to update?

Hello Luckman,

 

Polycom’s standard practise for new major feature releases is to provide the software to our Partner Community first by distributing it on the Partner Resource Center PRC.
 
This enables our wide range of partners to evaluate and qualify these releases ahead of their customers. This ensures that the newly implemented features, documentation and procedures (such as upgrading/ downgrading firmware) are at a satisfactory level of quality as well as facilitating their determination to support these releases.
 
Our partners are provided priority so that they can prepare their support organisations before they inform their customers and end-users with a policy and support statement.

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 6
Frequent Advisor

Re: UCS 4.0.0 - impossible to update?

I understand that.  So how does one gain access to the PRC?  Because while I am not a huge seller or anything I use Polycom phones in my office &  I have also  set up a handful of customers with Polycom phones and I do have to support these customers -- I would very much like to have access to this firmware as well because it contains several important features that both I and a couple of customers have been waiting for. 

 

I remember checking out the PRC requirements a few months back and it was too rigorous for what we do.  At the same time, contacting the reseller we bought the phones from to request the firmware has resulted in no response as well.  So I am kind of stuck between a rock and a hard place. 

 

Can you please help?

Message 5 of 6
Polycom Employee & Community Manager

Re: UCS 4.0.0 - impossible to update?

Hello Luckman,

 

as explained above in detail the distribution path for the free Software is as described.

 

As it seems you guessed the file name for the UC Software Releases enabling you to download the files but as this is not the official method I am unable to help.

 

The other files needed are at the same location and are free to download as well only with the restriction for Polycom Partners.

 

I have seen you post in another Forum and just wanted to clarify that this has been the same for previous releases and you just need to wait until your reseller provides you with the Software or until Polycom releases the follow up release.

 

I have no time/date for this future release yet and the Updater/Upgrader/Downgrader is not to stop people from downloading the Software as it is actually needed for the Phone and is just the new name for the BootROM 5.0 as explained => here <=.

 

I can only suggest to be patient or looking for a new Reseller that is able to support you as an end customer.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 6