Plantronics + Polycom. Now together as Poly Logo

UCS 5.0 bug???

bigfish
Advisor

UCS 5.0 bug???

Hello, I'm testing the new firmware and BToE on my VVX500 and noticed the following:

- When set my VVX500 as primary device on Lync client and dial a number from the client, the phone crashes and reboots.  On Lync client,  there is error saying "this call can only be controlled from your desk phone."

- If I set PC mic and speaker as primary device and dial out from Lync, changing the audio device to VVX500 does not do anything.

 

Shawn

Message 1 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: UCS 5.0 bug???

Hello Shawn,

Please gather as much information and follow this up the official channels.

Best regards

Steffen Baier
----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
bigfish
Advisor

Re: UCS 5.0 bug???

OK, BToE doesn't work as expected.  Very disappointed!!

 

Shawn

Message 3 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: UCS 5.0 bug???


@bigfish wrote:

 

- If I set PC mic and speaker as primary device and dial out from Lync, changing the audio device to VVX500 does not do anything.

 

Shawn


Hello Shawn,

 

The Phone does not support Audio redirect and to my knowledge this functionality is neither advertised or documented and therefore not an applicable scenario. Other competitors do not support this either to my knowledge.

 

In order to reply to your other issue I would have expected some more details.

 

You are correct that we would not expect the phone to reboot but several factors need to be considered when posting such statement.

 

  • Is the feature enabled on the phone via the feature.btoe.enabled="1" Parameter ?

  • What operating system are you using on your PC?

  • What version of the OS are you using?
    32 bit or 64 Bit?

  • Are there any firewalls or anti virus active on the PC?

  • What Version of the LYNC client are you using?

  • What Version of LYNC are you using?
    2010 or 2013?

  • Did you check the UCS 5.0.0 and BtoE Release notes against known caveats?
    i.e. for example IPv6 is not supported

  • How did you setup LYNC on your phone?
    The most know issue is people using "old" UCS 4.0.x Parameters instead of simply setting the Lync profile.

  • Are you using multiple LYNC or Sip registrations on your Phone?
    Above is not supported as documented in the release notes

  • Have you checked the Phones app/boot log against any error messages?

  • and last but not least have you got a valid license that entitles you to utilize the UCS software with LYNC for the phones you have setup?

 

As you can see above questions require a bit more feedback than you have so far provided. In order to make this a productive post for others please provide the relevant answers.

 

Again as a reminder your Polycom reseller and/or Polycom support should be contacted in case any support is required.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 7
bigfish
Advisor

Re: UCS 5.0 bug???

Hi Steffen, I tried again with my anti virus and firewall turned off but I still have the same issue.  I set my VVX500 as the primary audio device on Lync client and made an outbound call from Lync, the call failed with an error saying "This call can only be controlled from your desk phone." and then the phone rebooted itself.

 

  • Is the feature enabled on the phone via the feature.btoe.enabled="1" Parameter ?
    Yes

  • What operating system are you using on your PC?
    Windows 7 Pro

  • What version of the OS are you using? 
    32 bit or 64 Bit?
    64bit

  • Are there any firewalls or anti virus active on the PC?
    Anit viruse and firewall are turned off

  • What Version of the LYNC client are you using?
    Lync 2010 version 4.0.7577.4398

  • What Version of LYNC are you using?
    2010 or 2013?
    Hosted Lync 2010

  • Did you check the UCS 5.0.0 and BtoE Release notes against known caveats?
    i.e. for example IPv6 is not supported
    Checked the relese note but didn't help.

  • How did you setup LYNC on your phone?
    The most know issue is people using "old" UCS 4.0.x Parameters instead of simply setting the Lync profile.
    I'm using Lync base profile not UCS 4.0.x parameters

  • Are you using multiple LYNC or Sip registrations on your Phone?
    Above is not supported as documented in the release notes
    No

  • Have you checked the Phones app/boot log against any error messages?
    I'll check for error later

  • and last but not least have you got a valid license that entitles you to utilize the UCS software with LYNC for the phones you have setup?
    No
Message 5 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: UCS 5.0 bug???


bigfish wrote:
  • Have you checked the Phones app/boot log against any error messages?
    I'll check for error later

  • and last but not least have you got a valid license that entitles you to utilize the UCS software with LYNC for the phones you have setup?
    No

Hello Shawn,

 

when downloading the UCS software you have to agree to the terms and conditions.

 

As a reminder:

 

Please be aware of the following when utilizing UCS 4.1.0 or later:

The use of Polycom UC Software versions 4.1.X (“Software”) requires the purchase of a separate Software license for every device that will use the Software in a Lync environment. You may not install, access, or use the Software in a Lync environment on more devices than are listed on your license until additional licenses have been purchased and authorized by Polycom. These licenses should be purchased from the same company from which you purchased the devices. You may operate devices against a Lync server for trial purposes for up to 30 days without purchasing a license. Use of the Software is subject to the terms and conditions of the End User License Agreement.

Polycom reserves the right to audit your deployment to verify that you have sufficient licenses to match the number of devices being used.

 

So two things:

 

  1. Ensure that you follow above for all of your LYNC enabled phones

  2. Contact Polycom support either via your reseller or directly

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 7
KPABA
Valued Contributor

Re: UCS 5.0 bug???

I have the same issue: "When set my VVX500 as primary device on Lync client and dial a number from the client, the phone crashes and reboots.  On Lync client,  there is error saying "this call can only be controlled from your desk phone."

 

This happens if I signed in to the Lync phone using phone number and pin number.  If I use BToE after that, I have theproblem described above.

 

If I do not sign in at all and use BToE to sign in, I do not have this issue, but the phone disconnects if I log off.

Message 7 of 7