Plantronics + Polycom. Now together as Poly Logo

Unable to upgrade IP 6000 firmware

Occasional Visitor

Unable to upgrade IP 6000 firmware

Hi

 

Please can soemone help with the following. We have recently purchased a new IP 6000 conference phone that i would like to upgrade to the same software as our other ones.

The new unit is on 4.0.8.1972, the old one was upgraded to 4.0.10.0689

When we log into the admin page and go to Utilities > Software Upgrade, we select Check for Updates and it just fails

 

'Failed to connecto the Polycom Hosted server. Please try again later or contact your Network Administrator if the problem persists'

 

I have spoken to the network and firewall engineers and they are not seeing any traffic coming back to the phone.

 

Please can you confirm the IP address of the Polycom Hosted Server and what ports we need to open?

Do we need to do anything else to get access to the online updates please?

Message 1 of 6
5 REPLIES 5
Highlighted
Polycom Employee & Community Manager

Re: Unable to upgrade IP 6000 firmware

Hello Andy Bootland,

welcome to the Polycom Community.

The Upgrade is hosted via port 80.

 

Simply set the following logging:

 

  • Settings > Logging > Global Log Level Limit > Event 1
  • Settings > Logging > Module Log Level Limits > Copy Utilities to Event 1
  • Settings > Logging > Module Log Level Limits > CURL Event 1

The Diagnostics > View & Download Logs should then show:

 

1205134630|copy |3|00|Download of 'voice/software/3111-15600-001' succeeded on attempt 1 (addr 1 of 1)


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
Highlighted
Occasional Visitor

Re: Unable to upgrade IP 6000 firmware

Hi Steffen

Thanks for the prompt reply. I have tried the suggested and this is what we get back in the Event 1 log filter

 

1205143307|copy |1|03|Set 'User-Agent: FileTransport PolycomSoundStationIP-SSIP_6000-UA/4.0.8.1972 Type/Application'
1205143307|copy |1|03|Provisioning:Cipher suite = ALL:!DH:!LOW:!EXP:!MD5:@STRENGTH
1205143311|copy |1|03|Set 'User-Agent: FileTransport PolycomSoundStationIP-SSIP_6000-UA/4.0.8.1972 Type/Application'
1205143311|copy |1|03|Provisioning:Cipher suite = ALL:!DH:!LOW:!EXP:!MD5:@STRENGTH
1205143311|curl |1|03|HEADER_OUT: GET /voice/software/3111-15600-001.xml HTTP/1.1
...
1205143311|curl |1|03|HEADER_IN : HTTP/1.1 302 Found
1205143311|curl |1|03|HEADER_IN : Location: http://gblhr01sixppx01a-int-1-0/?cfru=aHR0cDovL2Rvd25sb2Fkcy5wb2x5Y29tLmNvbS92b2ljZS9zb2Z0d2FyZS8zMTExLTE1NjAwLTAwMS54bWw=
1205143311|curl |1|03|HEADER_IN : Cache-Control: no-cache
1205143311|curl |1|03|HEADER_IN : Pragma: no-cache
1205143311|curl |1|03|HEADER_IN : Content-Type: text/html; charset=utf-8
1205143311|curl |1|03|HEADER_IN : Connection: close
1205143311|curl |1|03|HEADER_IN : Content-Length: 660
1205143311|curl |1|03|HEADER_IN :
1205143311|curl |1|03|HEADER_OUT: GET /?cfru=aHR0cDovL2Rvd25sb2Fkcy5wb2x5Y29tLmNvbS92b2ljZS9zb2Z0d2FyZS8zMTExLTE1NjAwLTAwMS54bWw= HTTP/1.1
...

 

is this of any use?

Message 3 of 6
Highlighted
Polycom Employee & Community Manager

Re: Unable to upgrade IP 6000 firmware

Hello Andy Bootland,

1205143311|curl |1|03|HEADER_IN : HTTP/1.1 302 Found

should be a 

 

1205134630|curl |1|00|HEADER_IN : HTTP/1.1 200 OK

Instead.

 

I would suggest you work with your IT department or setup a local server as shown => here <=

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 6
Highlighted
Occasional Visitor

Re: Unable to upgrade IP 6000 firmware

Thanks, but that hasnt really helped.

The IT department have already fully opened the firewall for this device and it still wont work, hence me asking for help.

Message 5 of 6
Highlighted
Polycom Employee & Community Manager

Re: Unable to upgrade IP 6000 firmware

Hello Andy Bootland,


You can always open a ticket with your Polycom reseller but I am not sure they or our support team can help.

 

I would simply setup a local server so it allows you to configure the phones out of the box.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6