Plantronics + Polycom. Now together as Poly Logo

VVX 1500 with ipv6 is totally broken

hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Hi Steffen,

 

thanks to your help, I've managed to revive the phone   So they aren't so easy to brick after all.

 

Last time when I updated the software, I had to also update the boot loader.  That was nowhere to be found, so I had asked on this forum, and after quite while someone (that was probably you?) was able to find it and I updated to the 5.9.2.3446 version it's running now.  It was quite a nightmare and I had to edit some files because it wouldn't work and it was a very difficult process.  If there is anything to improve about these phones, it's updating and provisioning.  There's no straightforward documentation about it, and why can't we just upload the firmware through the web interface and be done with it.  I have a bunch of VVX 301 at work and one here at home, and I can't provision any of them because I don't see how to --- not to mention updating the firmware.  Why can't we just provide a simple file with key-value pairs like

 

John Doe:1000

Jane Doe:1001

 

to add phone book entries?

 

Anyway, from the last update of the VVX 1500 on, I left the ftp server running and the phone was using it until I switched the server from Centos 7 to Fedora and didn't set up the ftp server again.

 

But I kept the whole directory with all the files in it.  So I installed the ftp server, configured the phone to use it, and it sucessfully updated itself to 5.9.2.3446.  I reconfigured the lines, but the phone displays one of them as a 'VVX 1500' button, and it doesn't seem to even attempt to register.  Maybe I can figure that out later ...

 

The software I was trying to upgrade to was the latest version shown in the web GUI: 5.9.6.2996.  I had downloaded it the other day, and today I put it on the ftp server, and the result is the same: The phone says "No room for updater".

 

I'll try one of the previous versions through the web GUI next until I find one that still works and report back here.

 

Ok, there goes nothing:

I have stopped the ftp server.  Using the web gui to update doesn't do anything, not even manually rebooting the phone.

 

But then, according to the release matrix, the last version that works on the VVX 1500, is 5.9.5.0614.  Why does it even show up in the web GUI when it's not supported?

 

I would put that version on my ftp server and see if it works, but it is nowhere to be found.  Is my phone broken now that it doesn't update and doesn't register?

 

Message 11 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw ,

 

First of all, we are talking about the end of life hardware here with the VVX 1500.

Secondly, you are in the Poly community which is hosted by my employer Poly but run by volunteers.

 

In regards to your BootBlock question we state this on the VVX support page:

 

  • Installing UC Software 5.2.0 or later on VVX 1500 phones running earlier versions, you must perform the required Bootblock upgrade to version 3.0.4 – See Technical Bulletin 695

The above Technical bulletin must be followed for it to work and not brick the phone

 

Our FAQ contains this:

Jan 11,2017 Question:Do I ever need to upgrade the BootBLOCK of my Poly phones?

Resolution: The only phone that needs the BootBLOCK updated it the VVX1500 when upgrading to UC Software 5.2.0 or later as explained  => here <=

 

As already stated I made product management aware regarding the 5.9.6 Software as the 5.9.6 release notes mention the VVX 1500 to be supported and our software server hosts the software but the Release Matrix >here< states that 5.9.5 is the last release.

 

This will most likely be corrected.

 

In regards to speed dials please check the FAQ:

 

Dec 19, 2017 Question: How can I import Speed Dials or Numbers via the Web Interface?

Resolution: This is not supported. Only the Poly Trio or CCX can import speed dials via a USB stick in this format => here <= as shown => here <=

 

and

 

Jan 6, 2012 Question: How can I create a local contact directory/phonebook or what is the 000000000000-directory.xml used for?

Resolution: Please check => here <=

 

In regards to general Provisioning etc check the latest official Provisioning Guide please check >here<

 

Also the FAQ:

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

In regards to upgrading the existing VVX 301 see the official guide or the FAQ highlighted above as this can be done using the Web Interface as long as no network restricts the access to the hosted server.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 12 of 13
hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Hi Steffen,

yes, unfortunately the VVX 1500 is EOL. I should have checked the
release matrix and shouldn't have tried to installed the latest
software as you suggested because it's not compatible.

I'm aware that you're doing all this support voluntarly. You're
doing an excellent job, and I appreciate that. Without it, I'd
be pretty helpless.

 

As to the boot block, I updated when I upgraded it in the process of
updating to the 5.9.2.3446 software.

 

Populating a phone book for the phone(s) will be much easier with the
information you provided. That goes for provisioning, too, still is't
very complicated as there is not information and too much information
at the same time.

 

Do you know where I can find the 5.9.5.0614 version of the software?
I would try to update the phone with it and get ipv6 to work.

 

Message 13 of 13