Plantronics + Polycom. Now together as Poly Logo

VVX 410 Microbrowser not working

Advisor

VVX 410 Microbrowser not working

I am using the following in my config template: 

 

<mb.idleDisplay mb.idleDisplay.home="{$agent_status_url}" mb.idleDisplay.refresh="30">
</mb.idleDisplay>

 

When I view-source the http address is there but not displaying on the phone. I use the same context in the VVX 500 phones and my agent status is displayed. Any help would be appreciated.

Message 1 of 12
11 REPLIES 11
Polycom Employee & Community Manager

Re: VVX 410 Microbrowser not working

Hello,

I would suggest to export the configuration of both phones and compare it. Also are you running UCS 4.1.5 on both phones?

Best regards

Steffen Baier
----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 12
Advisor

Re: VVX 410 Microbrowser not working

Yes both the VVX500 and VVX400 are running the same config file on firmware 4.1.5

Message 3 of 12
Polycom Employee & Community Manager

Re: VVX 410 Microbrowser not working

Hello Shamrock,

 

as prior requested can you export both configuration files and verify that the URL is the same?

 

Could you elaborate on your comments in regards of viewing the source of the page?

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 12
Occasional Contributor

Re: VVX 410 Microbrowser not working

Hello,

 

We are having the same problem.

Running 5.0.1.4068 on a VVX410, VVX500 and VVX600.

 

The config file is:

 

<mb>
<mb.idleDisplay mb.idleDisplay.home="http://10.10.10.10/vvx.php" mb.idleDisplay.refresh="10">
</mb.idleDisplay>
<mb.main mb.main.home="http://10.10.10.10/vvx.php">
</mb.main>
</mb>

 

Behaviors:

On the VVX500 and VVX600, the idle screen works fine and refreshes correctly.

On the VVX410, the idle screen never kicks in. However, pressing on [Home]/[Application], the PHP file is being displayed.

Tried to factory reset the VVX410, same issue.

 

It appears as there is a bug with the VVX410 which is not running the URL specified in mb.idleDisplay.home  ...

 

Please advise!

 

Thanks.

Message 5 of 12
Polycom Employee & Community Manager

Re: VVX 410 Microbrowser not working

Hello all,


welcome to the Polycom Community.

The Functionality is actually not provided on the entry level phones like the VVX300/310/400/410.

 

A workaround would be to configure a Screen Saver and point it to the page you would like to display.

 

This was a decision made by the product management team.

 

  • To enable the idle browser go to Settings -> Preferences -> Screen Saver and set the following:
  • Screen Saver -> Enabled
  • Wait Time -> 1
  • Type -> Idle Browser

Wait and the idle browser will display. Touching any key will close the idle browser.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.


Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 12
Advisor

Re: VVX 410 Microbrowser not working

Steffen,

 

Is there any plan on fixing this. I am asking because Polycom is now on 5.2.0.8330 and the VVX 300 and VVX 400 series are still behaving the same way. Unlike the VVX 500 and VVX 600 which shows the information.

Message 7 of 12
Polycom Employee & Community Manager

Re: VVX 410 Microbrowser not working

Hello Shamrock,

welcome back to the Polycom Community.

 

The is not considered a bug and therefore nothing requires fixing.

 

The latest update from myself explains how to use this on the entry level phones.

 

Any change to the above needs a feature request as explained in the FAQ.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 12
Occasional Visitor

Re: VVX 410 Microbrowser not working

Hi,

 

In a lot of official Polycom documentation it is stated that the VVX 300 and above support the home screen URL display. To quote your documentation:

 

"The SoundPoint IP 450, 550, 560, and 650 phones, and SoundStation IP 5000, 6000, and SoundStation Duo phones, support an XHTML microbrowser. The VVX business media phones support a full Web browser. The microbrowser and browser parameters you can configure are listed in Use the Browser and Web Browser Note that the exact functions and performance of the microbrowser and Web browser vary with the model of phone you are using.

You can configure the microbrowser and Web browser to display a non-interactive Web page on the phone’s idle screen, and you can specify an interactive home Web page that you can launch in a Web browser by pressing the Applicationskey on the phone or by navigating to Menu > Applications . On the VVX 1500 phone, you can launch the Web browser by pressing the App key on the phone or by navigating to Menu > Applications . On the VVX 300, 310, 400, 410, 500, and 600 phones, go to Home > Applications. On the VVX only, when you tap on a link that displays on the idle browser the phone will launch that link in the Web browser.

Polycom provides a default microbrowser and browser feature for the phone’s idle screen. My Info Portal is a Polycom-developed application that gives you access to the latest news, sports, weather, stock, and other news. You can sign up for access to My Info Portal through the Polycom VVX 1500 phone or through a computer. Note that the first time you sign in to My Info Portal, you will be asked to accept the Polycom End User Licensing Agreement (EULA)."

 


Given that you state that the VVX 300 and above support this, I would state that this is not intended design and is a business desicion made post-production. This renders your VVX phones practically useless to our company (one of many I suspect) and we are literally now forced to find a competitor that offers this feature, even though we do not want to. Similar tactics were used in a partnership deal between Broadsoft and Polycom some time ago, rendering features unavailable for anyone but Broadsoft.

 

Please could this be addressed in a future firmware update? Thank you.

 

 

 

Message 9 of 12
Occasional Visitor

Re: VVX 410 Microbrowser not working

Hi,

 

I should also point out that this functionality is provided in the VVX 300's web interface, and simply does not work. Clearly not intended design, and I will definitely be looking forward to the firmware fix for this.

 

Thanks!

Message 10 of 12