Plantronics + Polycom. Now together as Poly Logo

VVX 500 - No Power, with clicking sound (repeating every 2 seconds).

Occasional Visitor

VVX 500 - No Power, with clicking sound (repeating every 2 seconds).

Hi there, 

 

I have new polycom vvx 500 which used to power on fine but recently (after some months) - there is no power (no lights, screen not on). There is an odd clicking sound coming from the phone when it is plugged into an outlet. I have tried several outlets and I know the outlet is not the problem.

 

Has anyone else experienced this issue? Please help!?

Message 1 of 3
2 REPLIES 2
Highlighted
Polycom Employee & Community Manager

Re: VVX 500 - No Power, with clicking sound (repeating every 2 seconds).

Hello mstar,

welcome to the Polycom Community.

Are you using PoE or an external Power Supply?

 

I can only assume you need an RMA.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 3
Highlighted
Occasional Visitor

Re: VVX 500 - No Power, with clicking sound (repeating every 2 seconds).

Hi there, I'm using an external power supply that came with phone (that I have plugged into an outlet).

 

Any other suggestions I can try? and have you heard of this clicking sound issue - does this mean the phone is defective or just need a new power chord/supply?

 

Thanks!

Message 3 of 3