Plantronics + Polycom. Now together as Poly Logo

VVX D230 Ring Central Provisioning

SOLVED
Nate007
Visitor

VVX D230 Ring Central Provisioning

I have a VVX D230 I am trying configure on ring central. I looked KB 43976 but that seems to align with VVX phones and not the OBI integrated phone. Received the KB referenced for the D230 is 43493 however, the steps do not allow the phone to come up. Note the D230 I called Poly support and they supplied the steps to me, see below. I tried to note what I did on the various steps. In the end the phone still does not work.

 

1 Contact your service provider to get the values for these above parameters: (see image. I am making the assumption that this device does not support TLS, see Ring provisioning image)
2 From the system web interface, go to Service Providers > ITSP ProviderN > SIP. (note N is note a valid profile to use, so I selected Profile A)
3 In the Default column, uncheck the boxes for the ProxyServer and RegisterServer ( I Entered SIP Domain provided by Ring)
parameters.
4 Enter the values from your service provider for the ProxyServer and RegisterServer (I Entered the Outbound Proxy address here)
parameters.
4a. I Changed the ProxyServerPort to match provider (Set to port 5090)
4b. I Changed the Outbound ProxyPort from 5060 to 5090
5 Click Submit.
6 Go to Voice Services > SPn Service.
7 In the Default column, uncheck the box for the X_DisplayNumber parameter.
8 Enter the value from your service provider for the X_DisplayNumber parameter. (I used the username here, not sure if that is what I should have entered. I noticed that this seems to create a new line appearnce on the phone.)
9 Optionally, click Submit.
10 Scroll down to SIP Credentials.
11 In the Default column, uncheck the boxes for the AuthUserName and AuthPassword parameters. 
12 Enter the values from your service provider for the AuthUserName and AuthPassword parameters. (I entered the Ring User Name and password)
13 In the Default column, uncheck the boxes for the URI parameter
14 Enter the value/phone number from your service provide for URI (I assume that is the Ring Authorization ID)
15 Click Submit.

(Step 16 I added as it was not listed in their instructions)
16 WAN Settings. then Scroll down to Time Service Settings, and uncheck LocalTimeZone Default
a) Set correct time zone
b) You can uncheck NTPServer1 and change the NTP server (a common NTP is pool.ntp.org)
17 Click Reboot

1 ACCEPTED SOLUTION

Accepted Solutions
Nate007
Visitor

Re: VVX D230 Ring Central Provisioning

I was able to get this working and attached the document. I did not have success with TLS. I hope this helps someone else.

 

Set your Timezone and NTP under systems management

Click Submit

Service Providers --> Configure ITSP Profile scroll down to Service Provider Info

Set Name, This is a user friendly name

Set URL to sip.ringcentral.com

Click Submit

Service Provider -->ITSP Profile A --> SIP

Set Proxy Server

Set  RegistrarServer (same value as proxy)

Set outbound proxy & Outbound proxy port

(submit)

Voice Services --> SP1 Service

Scroll down to SIP Credentials

AuthUserName  = Ring Authorization ID

AuthPassword = need I say more

URI = Ring Central username AKA phone number

View solution in original post

1 REPLY 1
Nate007
Visitor

Re: VVX D230 Ring Central Provisioning

I was able to get this working and attached the document. I did not have success with TLS. I hope this helps someone else.

 

Set your Timezone and NTP under systems management

Click Submit

Service Providers --> Configure ITSP Profile scroll down to Service Provider Info

Set Name, This is a user friendly name

Set URL to sip.ringcentral.com

Click Submit

Service Provider -->ITSP Profile A --> SIP

Set Proxy Server

Set  RegistrarServer (same value as proxy)

Set outbound proxy & Outbound proxy port

(submit)

Voice Services --> SP1 Service

Scroll down to SIP Credentials

AuthUserName  = Ring Authorization ID

AuthPassword = need I say more

URI = Ring Central username AKA phone number

View solution in original post