Plantronics + Polycom. Now together as Poly Logo

VVX410 phones failing to pull firmware from provisioning server

Occasional Contributor

VVX410 phones failing to pull firmware from provisioning server

I'm trying to update all VVX410 phones on our network from their current firmware versions (mostly 5.6) to the most recent 5.8 firmware. We have a provisioning server deployed and the phones can succesfully connect to this server as I can see in the FTP logs. I have attached the 00000000000.cfg and the customisations.cfg within a ZIP file. When rebooting the phone I can see that it connects to the FTP server andsome logs are transferred but then the phone boots without an update. 

 

The server has this directory structure:

 

Main FTP Directory = D:\Polycom
Which contains directories: Config, Languages, Logs, Settings Backup and VVXLocalization

 

with the sip.ld and dect.ld files being located in the Polycom directory. Both the 00000000000.cfg and customisations.cfg files are also in this directory.

 

Some of the phones also have <mac>-phone.cfg, <mac>-app.cfg, <mac>-audit.cfg files etc in the polycom directory. The <mac>-phone.cfg files contain the following (varies for each phone):

 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Finlay 5.6.0.17325 09-Jul-17 01:33 -->
<!-- Created 21-03-2018 08:08 -->
<PHONE_CONFIG>
	<OVERRIDES
		feature.deviceLock.enable="0"
		np.normal.ringing.toneVolume.chassis="-15"
		sec.TLS.customCaCert.6="-----BEGIN CERTIFICATE-----
[certificate string that I've removed]

-----END CERTIFICATE-----"
		reg.1.address="[sip address of user that I've removed]"
		reg.1.auth.loginCredentialType="usernameAndPassword"
	/>
</PHONE_CONFIG>

Is there a setting that's misconfigured within the customisations.cfg file that prevents the phone from pulling the firmware from the server? Any and all help would be appreciated. I've tried following the FAQ and the guide for this but it hasn't been of much help.

 

Message 1 of 8
7 REPLIES 7
Highlighted
Polycom Employee & Community Manager

Re: VVX410 phones failing to pull firmware from provisioning server

Hello @mzdr,

welcome back to the Polycom community.

Some or a couple of your old post(s) => here <= are still open / pending as you have not marked these as "Accept as a solution" or at least provided some form of feedback or answer.

If they are in this state nobody finding them via a community search will know if an answer or advice provided was useful and has maybe helped you.

Could you therefore kindly go over them and mark or answer as appropriate ?

If they are marked as "Accept as a solution" other users can find these easier and it helps them to utilise the community more efficiently.

 

For your new question it would be helpful to post some logs and/or a backup of the phones configuration. We do not know if the phone has even loaded what you assume it should so a backup is helpful.

 

May 25, 2017 Question: Can I create a backup of my current configuration?

Resolution:Since UC Software 4.0.0 or later a backup can be created via the Web Interface Utilities > Phone Backup & Restore > Phone Backup > Phone Backup


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 8
Valued Contributor

Re: VVX410 phones failing to pull firmware from provisioning server

Two Ideas for you:

Try putting the update file in the root directory of the FTP.  It does not appear that

DECT_FILE_PATH="3111-17823-001.dect.ld"

is pointing to the "Polycom" directory.  If there are issues loading your 000... and custom cfgs may want to try placing them in the root as well.

 

The other option you may want to change to "0" is

device.prov.lyncDeviceUpdateEnabled="1"

If an FTP is being used to provision you usually don't want a device to check the Skype server for updates.  This is problematic if registering to Skype served by O365.  The version on the Microsoft server is almost always out of date.

 

Good luck!

-Scott

 

Sources:

http://blog.schertz.name/2013/05/provisioning-polycom-sip-phones/

http://blog.schertz.name/2013/10/updating-polycom-vvx-phones/

Message 3 of 8
Polycom Employee & Community Manager

Re: VVX410 phones failing to pull firmware from provisioning server

Hello @Scott1 and @mzdr,

The DECT File reference to the D60 DECT Base unit so it can be neglected as this is a S4B installation.

 

Again it is important to see a running backup as it is all good and great assuming a configuration created is being loaded by the phone.

 

I assume somewhere along the line someone set:

 

		device.prov.upgradeServer.set="1"
		device.prov.upgradeServer=""

but without a backup we never know.

 

Also logs would help to clear this up.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 8
Occasional Contributor

Re: VVX410 phones failing to pull firmware from provisioning server

Thank you both for your suggestions and advice. Based on this I've been looking at the "device.prov.upgradeServer" line on the phone config. I exported the config of a phone that had the issue and noticed that this variable was set to a polycom download link. I changed this line to be blank and then imported the config file to the phone, rebooted the phone and it downloaded and applied the firmware from the provisioning server.

 

However I've added this line to the customisations.cfg as well as the specific <mac>-phone.cfg file of the phone, however when I export the config of the phone, the polycom download link is still on the "device.prov.upgradeServer" attribute. This is a snippet of the changes made to the customisations.cfg file:

 

  <!-- Set the Base Profile to Lync mode, with firmware updates from Lync & user-popup enabled -->
  <device device.set="1" device.baseProfile.set="1" />
  <device device.baseProfile="Lync" device.prov.lyncDeviceUpdateEnabled="0" device.prov.lyncDeviceUpdateEnabled.set="1" device.prov.upgradeServer.set="1" device.prov.upgradeServer="" />
  <lync lync.deviceUpdate.userInactivityTimeout="900" lync.deviceUpdate.popUpSK.enabled="1" lync.deviceUpdate.serverPollInterval="28800" />
  <!-- Enable audible reminder of held call-->
Message 5 of 8
Polycom Employee & Community Manager

Re: VVX410 phones failing to pull firmware from provisioning server

Hello @mzdr,

as already outlined in my initial reply the community can only work if your old posts receive some kind of feedback if the advise given have been followed up or not or is going to be.

 

This motivates and encourages people to respond to new posts.

 
The community's VoIP FAQ contains this post here:

Mar 08, 2013 QuestionWhat files does my phone download or upload and why?

Resolution: Please check => here <=

 

and

 

Feb 08, 2018 Question: Should I ever make changes to <mac>-web.cfg or <mac>-phone.cfg files ?

Resolution: No as these Files are created and uploaded by the phone itself as explained => here <=

 

The above (and the Admin Guide) clearly outlines that these files must not be touched by a user.


Please ensure you always check the community FAQ and/or utilize the community search before posting any new topics or follow up post’s.

 

For your now next problem again you are asking us to assume or second guess as you have not posted any kind of log so we could point out any errors.

 

I suggest you work with support on this.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you. This may not be who you purchased the Polycom device from.

If the unit is no longer within warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

 

Professional Services in addition can be engaged to provide a health check on this installation or training.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 8
Occasional Contributor

Re: VVX410 phones failing to pull firmware from provisioning server

Please find attached a log file from the most recent reboot of the phone as well as the exported configuration of the phone in question.

 

I've returned the <mac>-phone.cfg file to how it was before I made any changes.

Polycom Employee & Community Manager

Re: VVX410 phones failing to pull firmware from provisioning server

Hello @mzdr,

I only had a brief look at this (as I am unable to provide free support via the community) and nothing sticks out initially.

 

We would need to lower maybe the Configuration logging level to see where the source for the Polycom Hosted server comes from. 

 

Others can reply to this post with additional suggestions but the official next step would be to raise a PPI ticket via your reseller.

 

Veracomp SA sold this phone back in 31/10/2016 so if there is no other newer Phones as this is out of warranty.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 8